3d beschleunigung mit ati unter suse 9.3 geht nicht

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Seitenbacher, 24. August 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Seitenbacher

    Seitenbacher Byte

    Registriert seit:
    1. November 2003
    Beiträge:
    79
    hallo,

    leider habe ich erst lange nach meinem umstieg auf linux erfahren dass es ein grauß ist einen ati-treiber unter linux zu installieren. trotzdem würde ich meine radeon 9500 gerne weiterbenutzen.
    nun habe ich folgendes problem:

    ich benutze suse 9.3 und habe mir unter ftp://ftp.gwdg.de/pub/linux/suse/ftp.suse.com/suse/i386/supplementary/X/ATI/suse93/i386/fglrx/8.14.13 den treiber, das kernelmodul und die readme runtergeladen. letztere habe ich gelesen und den treiber entsprechend installiert.
    da aber in der readme steht, dass man die 3d beschleunigung nicht über sax2 aktivieren kann, hab ich den treiber mit "fglrxconfig" konfiguriert (zugriff auf opengl habe ich allen nutzern erlaubt).
    anschließend habe ich wie in der readme beschrieben in der datei /etc/X11/xorg.conf überprüft ob der eintrag Load "dri" vorhanden ist (ist vorhanden).
    leider funktioniert die 3d beschleunigung aber trotzdem nicht und jedes 3d game das ich starte warnt mich davor und starte ich es trotzdem, ruckelt es natürlich.

    irgendwo hab ich auch gelesen dass bei "fglrxinfo" als ausgabe "Radeon..." statt "MESA..." kommen sollte. tut bei mir aber nicht:
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

    bei "glxgears" hab ich meistens um die 96 frames (manchmals schießt er hoch auf über 300, dann wieder runter auf 96)

    was kann ich tun? hab ich vielleicht den falschen treiber? installation hat eigentlich problemlos geklappt...
     
  2. mpoindl

    mpoindl Kbyte

    Registriert seit:
    19. Februar 2004
    Beiträge:
    468
    welche ati hast du?
     
  3. Seitenbacher

    Seitenbacher Byte

    Registriert seit:
    1. November 2003
    Beiträge:
    79
    eine sapphire radeon 9500 mit 128mb speicher
     
  4. Affirmation

    Affirmation Kbyte

    Registriert seit:
    16. März 2005
    Beiträge:
    152
    Checke bitte einmal ob der Kernel-Treiber geladen wurde:

    lsmod |grep fglrx

    Danach schau dir die /var/log/Xorg.0.log an. Dort wird der Start des X-Servers protokolliert. Stelle hier sicher, dass das 'agpgart' Modul geladen wird (das ist das Modul für die Kommunikation via AGP) und der fglrx-Treiber selbst. Hierzu einfach nach diesen Namen suchen.
    Ansonsten solltest du in der Datei auch checken, ob vielleicht der DRI einfach nicht geladen werden kann (es gibt bei ATI ab und an Treiberinkompatiblitäten in der Hinsicht).
     
  5. Seitenbacher

    Seitenbacher Byte

    Registriert seit:
    1. November 2003
    Beiträge:
    79
    aaaaaaalso...
    erst mal danke für die tipps, jetzt bin ich schon etwas schlauer.

    lsmod |grep fglrx sagt folgendes:
    Code:
    fglrx                 250152  0
    agpgart                32296  2 fglrx,nvidia_agp
    da scheint mir alles in ordnung zu sein (oder?)

    aaaber: in der Xorg.0.log wird zwar fglrx geladen, aber nicht agpgart (habs zumindest nicht gefunden).

    hier erst mal fglrx:
    Code:
    (II) LoadModule: "fglrx"
    (II) Loading /usr/X11R6/lib/modules/drivers/fglrx_drv.o
    (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    	compiled for 6.8.0, module version = 8.14.13
    	Module class: X.Org Video Driver
    	ABI class: X.Org Video Driver, version 0.7
    aber es scheint tatsächlich probleme mit DRI zu geben.
    erst mal scheint DRIScreenInit fehlzuschlagen weil da eine fehlermeldung auf die andere folgt ("no such device", "unknown error 999"). und dann kommt folgendes:
    Code:
    (II) fglrx(0): Kernel Module Version Information:
    (II) fglrx(0):     Name: fglrx
    (II) fglrx(0):     Version: 8.16.20
    (II) fglrx(0):     Date: Aug 16 2005
    (II) fglrx(0):     Desc: ATI FireGL DRM kernel module
    (WW) fglrx(0): Kernel Module version does *not* match driver.
    (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
    (II) fglrx(0): [drm] removed 1 reserved context for kernel
    (II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe1281000 at 0xb7cdf000
    und anschließend weist er mich noch großzügig darauf hin dass 3d nicht funzen wird:
    Code:
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    aber ehrlich gesagt hab ich keinen schimmer was ich tun soll :(
    ich kenn mich mit linux eigentlich auch null aus. bin vor kurzem erst umgestiegen und versuch mich jetzt so gut wies geht einzuarbeiten (aber scheinbar is nicht mal suse einfach genug für mich)
     
  6. Seitenbacher

    Seitenbacher Byte

    Registriert seit:
    1. November 2003
    Beiträge:
    79
    hm, also das hauptproblem scheint zu sein dass das kernelmodul und der treiber nicht zusammenpassen. aber das raff ich nicht. ich hab von beiden die version 8.14.13 (fglrx-8.14.13-0.1.i586.rpm und km_fglrx-8.14.13-0.1.i586.rpm). aber ich glaub es gibt auch ne neuere version (8.16.20) nur find ich dazu das kernelmodul nicht.
     
  7. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Wenn Du die Suse-Pakete nimmst brauchst Du nicht das becheuerte fglrxconfig aufrufen.

    der Befehl "lsmod |grep fglrx" ist eigentlich auch Sinnlos, da zumindesten bei Ubuntu (und da wird es bei anderen auch nicht anders sein) ein Standard fglrx Modul gibt.
     
  8. Seitenbacher

    Seitenbacher Byte

    Registriert seit:
    1. November 2003
    Beiträge:
    79
    aber wenn ich das richtig verstanden hab ist genau dieses fglrx standardmodul das problem, weil das kein 3d bringen kann.
    ich versuch mal den ati-treiber zu deinstallieren (ich weiß aber nicht so genau wie ich das anstellen soll) und dann beim suse-treiber die 3d beschleunigung zu aktivieren, aber ich mach mir da wenig hoffnungen.
     
  9. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    schau nach wo diese Standard fglrx liegt, diese umbennen, dann löschen und ein symlink auf die vom Treiber erstellte bzw. dir kompilierte setzen
     
  10. Affirmation

    Affirmation Kbyte

    Registriert seit:
    16. März 2005
    Beiträge:
    152
    Das hängt stark von der Distribution ab.
    Ich nutze beispielsweise Fedora - und da werden keine Closed-Source-Treiber mitgeliefert. Wobei ich zugegebenermassen nicht sicher bin, ob das bei Suse anders ist oder nicht (ich kann mich aber daran erinnern, dass Novell da auch einen gesicherten Kurs fährt).

    Ansonsten:
    Du kannst Programme jederzeit via Yast entfernen (wenn dort der Eintrag zu sehen ist). Das mit dem Symlink ist ein wenig haarig, weil zu kompliziert (es ist ja nicht nur 1 Datei - sondern wohl durchaus mehr).

    agpart muss nur (wie der Name sagt) bei AGP-Karten geladen werden. PCI Express wäre hier zum Beispiel aussen vor. Daher ist das noch nicht unbedingt problematisch (ist auch mehr zur Sicherheit, ob deine Karte auch korrekt erkannt wird).
     
  11. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    @ Affirmation

    Habe gestern bei mein Ubuntu den Treiber installiert.

    xorg.conf

    in der Device Sektion

    statt Ati - fglrx
    + Zeile
    Option "UseInternalAGPGART" "no"

    die vom Treiber im eigenen Ordner erstellte fglrx-2.6.10-5-i386.ko in fglrx.ko umbenannt, die Ubuntu eigene gesichert und in dem Verzeichnis einen Link auf die unbenannte Ati Datei gelegt.

    Das wars und bei mir funktioniert 3D ohne das die saubere xorg.conf mit dem Ati Konfigurationstool shreddern musste.
     
  12. Seitenbacher

    Seitenbacher Byte

    Registriert seit:
    1. November 2003
    Beiträge:
    79
    hm, wie affirmation schon gesagt hat, das is ne komplizierte sache, zumindest für einen anfänger wie mich. ich hab ja schon mühe alleine das was du (ReneW) schreibst zu verstehen und ich hab echt angst dass ich mir irgendwas an der grafikausgabe kaputtmach und dann nicht weiß wie ichs beheben soll.

    erklär mir das mal bitte genauer mit dem link, von welcher auf welche datei ich da verlinken muss und welche ich da umbenennen und löschen muss (sonst lösch ich am ende noch die falsche). bei mir steht übrigens in der xorg.conf auch "no" bei "UseInternalAGPGART".
     
  13. realax

    realax ROM

    Registriert seit:
    11. September 2005
    Beiträge:
    3
    Hallo wenn der Treiber installiert worden ist und der desktop startet is alles gut gelaufen.

    wenn der Treiber installiert worden ist fglrx audführen und UNBEDINGT darauf achten das bei der Frage "Use external AGPgart?" mit Y zu bestätigen.

    danach die Finger unbedingt von Sax lassen bzw die KArte NICHT YAST konfigurieren, da der meist wieder nur die alten treiber nutzt.

    kann sein das man dann den x-server neustarten muss mit den Konsolen befehlen

    "init 3" den xserver benden und mit "init 5" den wieder starten (vorher in der konsole mit "su" als root anmelden).

    so hab ichs mit der gleichen KArte gemacht und bei mir läufts

    gruß realax
     
  14. Seitenbacher

    Seitenbacher Byte

    Registriert seit:
    1. November 2003
    Beiträge:
    79
    jop, bei mir funzt es jetzt auch. sorry dass ich mich so lange nicht mehr gemeldet hab :rolleyes:

    was du beschrieben hast hab ich aber etliche male gemacht, dadran lag's nicht.
    der treiber wurde einfach nicht korrekt installiert. hab dann mit dem installer von ati ein rpm erstellt und das dann über yast installiert, dann fglrxconfig und dann x-server neu gestartet und fäddisch :)

    glxgears
    13847 frames in 5.0 seconds = 2769.400 FPS
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen