1. Liebe Forumsgemeinde,

    aufgrund der Bestimmungen, die sich aus der DSGVO ergeben, müssten umfangreiche Anpassungen am Forum vorgenommen werden, die sich für uns nicht wirtschaftlich abbilden lassen. Daher haben wir uns entschlossen, das Forum in seiner aktuellen Form zu archivieren und online bereit zu stellen, jedoch keine Neuanmeldungen oder neuen Kommentare mehr zuzulassen. So ist sichergestellt, dass das gesammelte Wissen nicht verloren geht, und wir die Seite dennoch DSGVO-konform zur Verfügung stellen können.
    Dies wird in den nächsten Tagen umgesetzt.

    Ich danke allen, die sich in den letzten Jahren für Hilfesuchende und auch für das Forum selbst engagiert haben. Ich bin weiterhin für euch erreichbar unter tti(bei)pcwelt.de.
    Information ausblenden

8.3 Dateinamen beim dir-Befehl deaktivieren?

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von Otto-Mueller, 18. Mai 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Hallo allerseits,

    ich habe ein grosses Problem.
    Mein System:
    - Win2k
    - Netzlaufwerk (Novell 5.1) R:
    Es sind im Moment ca. 22.000 Dateien in einem Verzeichnis von dem
    Netzlaufwerk "R:\Verzeichnis". Die Dateiname haben folgende
    Konvention:
    9-stellige Nummer + 10 bis 15 Buchstaben + Dateierweiterung

    Beispiel:
    000000000-otto-mueller.tif
    000000001-otto-mueller.tif
    000000002-KaiJohann.tif
    000000003-otto-mueller.tif
    000000004-MartinBecker.tif
    000000005-HeinzKarl.tif

    usw.

    Wenn ich jetzt ein dir-Befehl mit Suchmaske ausführe, bekomme ich ganz
    andere Ergebnisse als ich es normalerweise bekommen müsste.

    Beispiel:
    dir 00051*.*

    Der dir-Befehl sollte ein LEERES Ergebnis zurückgeben, denn keine
    Datei aus der oberen Beispiel-Liste mit 00051 anfängt.

    Statt dessen, bekomme ich für mein ausgeführtes dir-Befehl z.B.
    folgendes angezeigt:

    000000003-otto-mueller.tif
    000000004-MartinBecker.tif

    Komisch..... nicht wahr?!?!

    Nach langer Suche habe ich auch die Ursache dafür gefunden und zwar
    mit "dir 00051*.* /x" Der Schalter X bewirkt, daß sowohl die
    8.3-Dateiname als auch die langen Dateiname nebeneinander aufgelistet
    werden. Da konnte ich feststellen, daß

    000000003-otto-mueller.tif
    000000004-MartinBecker.tif

    mit ihren 8.3-Dateinamen etwa

    000514D~.tif
    00051C3~.tif

    heißen und deshalb dieser komische Ergebnis

    Ich habe dann die Unterstützung für 8.3-Dateinamen auf Windows in
    Registry deaktiviert. Es hat jedoch nicht geholfen, da das dir-Befehl
    nicht auf einem Lokalen-Laufwerk ausgeführt wird, sonder auf einem
    Netzlaufwerk-Verzeichnis auf einem Novell-Server.

    Den Befehl-dir führe ich natürlich aus dem Win2k-Konsole.

    Ich denke man müßte die 8.3-Dateinamenkonvention auf den Novell-Server
    ausschalten, aber wie?? Das muß ich noch herausfinden. An dieser
    Stelle eine Nebenfrage: kennt jemand ein gutes Novell-Forum?

    Gibt es denn da eine Lösung von der Windows bzw. DOS Seite?

    Danke vorab für Eure Tipps.

    Gruß

    Otto
     
  2. Hallo allerseits,

    ich habe die Lösung:

    Beispiel: dir 00051*.* | find "00051"

    Gruß

    Otto
     
  3. Gast

    Gast Guest

    Sollte, tuts aber nicht :D

    Versuche mal den Parameter dir /b
     
  4. Jörn Stadelmann

    Jörn Stadelmann Viertel Gigabyte

    > Ich habe dann die Unterstützung für 8.3-Dateinamen auf
    > Windows in Registry deaktiviert

    Die Option bedeutet im Klartext: Es werden keine 8.3 Namen mehr generiert, auf bestehende Dateien hat das keinen Einfluss.

    Wenn du deine Suchanfrage in "" setzt
    z.B.

    dir "0051*.x??" sollte sich die Suchanfrage auf die Langen Dateinamen beziehen. Aber Mangels 20.000 Dateien kann ich das hier nicht 100% nachprüfen ;)

    J3x
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen