Abge. Modus in Win98-ich bin nicht blöd!

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von x0x2x4x6x8, 14. März 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. x0x2x4x6x8

    x0x2x4x6x8 Halbes Megabyte

    Registriert seit:
    24. Februar 2003
    Beiträge:
    571
    Guuuuuuuuuten Tag.

    Mein System:

    AMD Athlon XP 2400+
    256 MB RAM
    80 GB HDD
    16x48 DVD-ROM
    48x16x48 CD-RW
    nVidia GeForce MX 440 mit 8x AGP
    Windows 98 SE + Windows XP HE
    3,5"-FDD
    (auch bekannt als MBO P.C.V.O. 2400+/Volks-PC 2!)

    Mein Problem:
    Ich komme nicht mehr in den abgesicherten Modus von Windows 98!

    Wenn ich im Bootmanager F8 drücke, "abgesicherter Modus" und "Microsoft Windows 98 Second Edition" auswähle. starte er Windows 98 ganz normal, als ob er von keiner meiner Eingaben etwas wüsste.

    Meine Frage:
    Wer kann mir helfen?

    P.S.:
    Schreibt mir doch bitte mal eure Schuhgröße und euer Alter an
    x0x2x4x6x8@gmx.de
    aber bitte NICHT HIER posten, sonst wird der Thread geschlossen und mein Problem bleibt ungelöst!
    [Diese Nachricht wurde von x0x2x4x6x8 am 14.03.2003 | 17:16 geändert.]
     
  2. Jörn Stadelmann

    Jörn Stadelmann Viertel Gigabyte

    Registriert seit:
    7. April 2001
    Beiträge:
    4.450
    >Wie wär es denn mit mehreren bootfähigen FAT32-Partitionen,
    >jede mit eigener msdos.sys?

    Auch dann kommst du mit dem NT Bootmanager nicht weiter.

    J2x
     
  3. RaBerti1

    RaBerti1 Viertel Gigabyte

    Registriert seit:
    24. November 2000
    Beiträge:
    5.094
    Wozu rät man da?

    Stell in der msdos.sys den Parameter von
    BootGUI=0
    ein. Damit kommst Du an den Dosprompt, also
    c:\>
    Folge: Danach kannst Du eintippen, wie Win gestartet werden soll, ob abgesichert, oder abgesichert mit Netzwerk, oder normal mit/ohne Netzwerk oder ob Du beim reinen DOS bleiben willst.
    Schon zuvor irgendwelche Auswahlparameter vom Bootmanager an IO.sys weiterzuleiten klappt nicht, wie J2x zutreffend schreibt.
    Wie wär es denn mit mehreren bootfähigen FAT32-Partitionen, jede mit eigener msdos.sys? Das Win-VErzeichnis, auf das gleich zu Beginn der msdos.sys verwiesen wird, darf dann ruhig dasselbe sein.

    MfG Raberti
     
  4. Jörn Stadelmann

    Jörn Stadelmann Viertel Gigabyte

    Registriert seit:
    7. April 2001
    Beiträge:
    4.450
    Ist eigentlich ganz einfach zu verstehen:

    Der NT Bootmanager lädt den Bootsector von Win9x. Dieser ruft die IO.SYS auf die den Bootmanager im Speicher überschreibt und die MSDOS.SYS auswertet. IO.SYS kann erst hier die Entscheidung treffen ob der Abgesicherte-Modus überhaupt gestartet werden darf, und wartet per deafult 2 Sekunden auf die Bootkeys um das Startmenü anzuzeigen. Danach werden (sofern vorhanden) Config.sys und Autoexec.bat aufgerufen. (im Abgesicherten Modus werden diese übrigens (bis auf den DOS-Tastaturtreiber) igrnoriert). Danach erst wird WIN.COM gestartet. Naja, wie sollte der NT-Bootmanager nun den Parameter SAFEBOOT an WIN.COM senden ;-)

    J2x
     
  5. Jörn Stadelmann

    Jörn Stadelmann Viertel Gigabyte

    Registriert seit:
    7. April 2001
    Beiträge:
    4.450
    Ja, man kann sogar mitten im Hochfahren die Reset Taste drücken :-( dann startet win98 anschließend vollkommen automatisch im Abgesicherten Modus.

    J2x
     
  6. x0x2x4x6x8

    x0x2x4x6x8 Halbes Megabyte

    Registriert seit:
    24. Februar 2003
    Beiträge:
    571
    Danke für den Tipp, nur schade, dass man die Einstellungen aus dem XP-Bootmanager nicht direkt an 98 weitergeben kann. :-(
     
  7. wolves

    wolves Kbyte

    Registriert seit:
    12. Juni 2001
    Beiträge:
    299
    Tja sagen bzw. schreiben lässt sich so manches ;)
    ...z.B. kann ich das eigene (also dann Zweite)
    Win98/DOS-Startmenü mit der MSDOS.SYS hervorholen...

    Logo=0
    BootMenu=1
    BootMenuDefault=1

    ...um den Modus später per Tastatur auswählen zu können.

    fg
    wolves

    PS: Wissenswertes über die MSDOS.SYS-Funktionen...

    http://www.scriptinternals.de/content/biblio/win98buch/kap1/kap127.htm

    [Diese Nachricht wurde von wolves am 07.04.2003 | 05:57 geändert.]
     
  8. x0x2x4x6x8

    x0x2x4x6x8 Halbes Megabyte

    Registriert seit:
    24. Februar 2003
    Beiträge:
    571
    Ja, ich habe den Windows XP Bootmanager.

    Geht das wirklich nicht??? SCHADE, mehr kann ich dazu nicht sagen, ihr bestimmt auch nicht, na ja, was solls... :-(
     
  9. Jörn Stadelmann

    Jörn Stadelmann Viertel Gigabyte

    Registriert seit:
    7. April 2001
    Beiträge:
    4.450
    Setzt du den NT-Bootmanager (NT 2K XP) ein?

    Dieser kann Boot-Optionen wie "Abgesicherter Modus" NUR an NT Basierte Betriebssysteme übergeben.

    J2x
     
  10. x0x2x4x6x8

    x0x2x4x6x8 Halbes Megabyte

    Registriert seit:
    24. Februar 2003
    Beiträge:
    571
  11. x0x2x4x6x8

    x0x2x4x6x8 Halbes Megabyte

    Registriert seit:
    24. Februar 2003
    Beiträge:
    571
    Ich nochmal!

    Also auf meinem Rechner mit 98/2000 hat es mal funktioniert, nur jetzt läuft es auch da nicht mehr.
    Kann es denn sein, dass der Bootmanager von XP nicht zu 98 kompatibel ist oder kann ich den irgendwo bearbeiten?
     
  12. x0x2x4x6x8

    x0x2x4x6x8 Halbes Megabyte

    Registriert seit:
    24. Februar 2003
    Beiträge:
    571
    Hab ich vorhin wohl nicht lange genug gemacht, jetzt funktionierts.
    Aber wenn ich im Bootmanager den Abgesicherten Modus für Windows 98 auswähle, warum klappt es da denn nicht???

    P.S.
    Ich habe gerade mit Schrecken festgestellt, dass das Problem auch bei meinem anderen Rechner (98/2000) existiert!
     
  13. ManniBear

    ManniBear Megabyte

    Registriert seit:
    23. Februar 2002
    Beiträge:
    1.970
    Wenn\'s anders nicht geht, dann versuch doch mal Win 98 zu starten und von dort dann in den DOS-Modus zu wechseln (Im MS-DOS-Modus neu starten). Dort gibst du dann "win /d:m" ein um in den abgesicherten Modus zu kommen.

    http://service1.symantec.com/SUPPORT/INTER/tsgeninfointl.nsf/gdocid/20010201142228924

    Für XP kann man einen Eintrag in die Boot.Ini schreiben, evtl. gibt es ja auch für Win 98 irgendeine Möglichkeit:
    http://www.fehlerschiessen.de/willkommen/quickies.htm#Abgesicherter Modus über die Boot.ini

    Mfg Manni
     
  14. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Die F8-Taste muß während der Meldung "Windows wird gestartet " gedrückt werden.Überprüfe noch mal, ob die msdos.sys auch die Einstellungen gespeichert hat.Wenn nicht, mußt Du erstmal den Befehl attrib -s -h -r msdos.sys eingeben (mit passendem Pfad), damit du diese Systemdatei verändern kannst.

    franzkat
     
  15. x0x2x4x6x8

    x0x2x4x6x8 Halbes Megabyte

    Registriert seit:
    24. Februar 2003
    Beiträge:
    571
    Das bringt nichts.
    Wann soll ich denn F8 drücken?
    Vor dem Bootmanager oder danach (funktioniert nicht)?
     
  16. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Ergänze mal um folgende Einträge :

    BootMenu=0
    BootDelay=5

    Wenn Du jetzt bei der Meldung "Windows wird gestartet" F8 drückst, müßte es eigentlich funktionieren.Wenn der Standardwert bei BootDelay auf 0 gesetzt ist, kann es schon mal Probleme geben.

    franzkat
     
  17. x0x2x4x6x8

    x0x2x4x6x8 Halbes Megabyte

    Registriert seit:
    24. Februar 2003
    Beiträge:
    571
    Also, ein Tunig-Tool war das ganz bestimmt nicht, ich habe Windows 98 vorgestern neu draufgespielt, ebenso Windows XP.
    Bin noch am Treiber installieren, die MSDOS.SYS sieht so aus:

    [Paths]
    WinDir=C:\WINDOWS
    WinBootDir=C:\WINDOWS
    HostWinBootDrv=C

    [Options]
    BootMulti=1
    BootGUI=1
    DoubleBuffer=1
    AutoScan=1
    WinVer=4.10.2222
    ;
    ;The following lines are required for compatibility with other programs.
    ;Do not remove them (MSDOS.SYS needs to be >1024 bytes).
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxa
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxb
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxc
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxd
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxe
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxf
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxg
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxh
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxi
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxj
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxk
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxl
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxm
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxn
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxo
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxp
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxq
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxr
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxs

    Kann dir das helfen? Also, ich werde nicht schlau daraus!
     
  18. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Teste mal die auf dieser Seite aufgeführten Einstellungsmöglichkeiten zum abesicherten Modus in der msdos.sys.

    http://www.winguide.ch/msdos_sys.htm

    Vielleicht hast Du nur mit einem Tuning-Tool eine Einstellung verändert.

    franzkat
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen