Absturz bei Trennung des Internets

Dieses Thema im Forum "Internet: DSL, Kabel, UMTS, LTE" wurde erstellt von Head-Crash, 12. April 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Head-Crash

    Head-Crash Byte

    Registriert seit:
    15. Juli 2001
    Beiträge:
    57
    Hallo,

    ich habe folgendes Problem:

    Nach 24 Stunden erfolgt bei T-DSL eine Zwangstrennung der Verbindung. Dabei stürzt jedes Mal mein PC ab, was sehr ärgerlich ist.

    Wenn ich rechtzeitig die Kurve bekomme und die Flatrate händisch (vor Ablauf der 24 Stunden) trenne, dann stürzt der PC nicht ab und ich kann problemlos die neue Internetverbindung für die nächsten 24 Stunden aufbauen.

    Ich konnte das Problem wie folgt eingrenzen:
    - mein PC verträgt die Trennung durch REMOTE nicht.
    Wenn ich z. B. auf einem Client-PC (welcher die Internet-Verbindung mitbenutzt) die DFÜ-Verbindung trenne, stürzt der Host-Rechner genauso ab, wie wenn die Telekom die Verbindung trennen würde.

    Nur das händische Trennen am Host-PC selbst wird problemlos vertragen.

    Kann mir jemand einen Tip geben? An der Telekom kann das Problem ja schließlich nicht liegen, oder?

    Vielen Dank

    Andy
     
  2. mfccar

    mfccar ROM

    Registriert seit:
    3. Juni 2002
    Beiträge:
    2
    hi,

    ich habe auch dieses problem das mein rechner ein reset macht bei der remottrennung.

    hast du eine lösung???

    bitte
     
  3. Schugy

    Schugy Viertel Gigabyte

    Registriert seit:
    10. Juli 2001
    Beiträge:
    2.587
    Zu ISDN-Zeiten hab ich schon auf T-Offlein-Soft verzichtet.
    Gibt ja noch www.adsl-support.de
    Also 1&1 liefert einen abgespeckten cfos-Treiber, der in der neuesten Version auch gut funktioniert.
    Vielleicht kann dir der raspppoe helfen.

    So gut finde ich einen täglichen Absturz jedenfalls nicht.
    Bin von WinNT mit NTFS ja auch informiert, dass gern mal manche Dateien beschädigt werden und irgendwann die Kiste nicht mehr hochfährt. Manchmal kann auch ein Verzeichnis weg sein. Sicherlich passiert das selten, aber bei 365 Abstürzen pro Jahr wird das doch recht wahrscheinlich.

    Ich hatte auch mal unter Linux Abstürze (oder Rausschmiss zum Login) bei der Abwahl mit DSL. Da musste ich dann den Bootparameter NOAPIC setzen, und es läuft.
    APIC ist irgendwie eine erweiterte Interruptsteuerung.
    Mein System mit B-Athlon 900 auf KT133A-Via-Chip hat das jedenfalls nicht vertragen. Erstaunliche Parallel zu dir, oder?
    Also wenn du irgendwas im Bios oder in der Systemsteurung dazu ändern kannst, dann probier das mal aus!

    MfG

    Schugy
     
  4. sclub7

    sclub7 Halbes Megabyte

    Registriert seit:
    28. Oktober 2000
    Beiträge:
    831
    hi du!

    mein pc stürzt zwar nicht ab, wenn die 24h um sind (t-online flast via dsl), aber ich kann mich danach nicht mehr vernünftig einwählen! laut netzwerkmonitor bin ich verbunden, aber kein programm kann was ins internet senden oder empfangen. wenn ich jedoch die verbindung manuell kappe und danach mich neu einwähle, klappt alles ohne einen neustart.

    mein system:
    winxp
    dfü-einwahl von xp inkl. system-ppoe
    netzwerkkarte, t-online lan-modem

    mfg
    christian
     
  5. Head-Crash

    Head-Crash Byte

    Registriert seit:
    15. Juli 2001
    Beiträge:
    57
    Hi Schugy,

    zuerst vielen Dank für die Mühe, die Du Dir gemacht hast.
    Hier die Konfiguration:

    - DFI AK-74SC Mainboard, neuestes BIOS, neueste VIA-Treiber
    - WinXP home
    - PPPoE-Treiber: der mit T-DSL gelieferte DSL-Treiber (der von der T-DSL CD, nicht der Engelhardt-Treiber - glaube der hieß so...)

    Ich kann leider nicht verhindern, daß keine Anfragen gesendet werden. Die Software muß weiterlaufen, schließlich wird z. B. regelmäßig das Mail-Postfach abgefragt.

    Bist Du Dir sicher, daß es am PPPoE-Treiber liegt? Du weißt ja: never toch a running system. Momentan läuft es wenigstens, wenn auch nur 24 Stunden. Das ist immer noch besser, als wenn hinterher gar nix mehr funktionieren würde...

    Au0erdem finde ich, daß Du Dich sehr verständlich ausgedrückt hast. Danke!
     
  6. Schugy

    Schugy Viertel Gigabyte

    Registriert seit:
    10. Juli 2001
    Beiträge:
    2.587
    Sag mal lieber, welches System du hast (Kombination Athlon/Via/SIS oder P4/Intelchipsatz), nenne mal deinen PPPOE-Treiber.

    Ich könnte mir nämlich vorstellen, dass dein Kernel sich tötet, wenn angefragte Pakete nicht geliefert werden.

    Quasi so, als wenn dein CD-Rom-LW eine CD-nicht erkennt und sich dein PC beim Atapi-Reset mit dauerlaufendem CD-ROM und Totalabsturz verabschiedet.

    Das verträgt weder WinXP noch Linux bei gemounteten CD\'s.......

    Wenn du jetzt also einen Kernel-PPPOE-Treiber hast, kann sowas auch passieren. Ich hoffe zumindest, dass sich das bei Linux mit dem preemtive Patch in naher Zukunft lösen wird.

    Denn manche Anwendungen, bearbeiten intern Aufgaben, und es dauert, bis die Anwendung wieder vom User angesprochen werden kann.

    Einfaches Beispiel ist, wenn deine Maus, ohne unbedingt 100% CPU-auslastung zu haben, mal 2 Sekunden stillsteht.
    Wenn das länger ist (weil sich der Prozess (z.B. CD-Lesen)verabschiedet und damit die Macht an den User nicht mehr zurückkehrt), dann hast du einen Totalstillstand (Absturz).

    Also versuch mal den Treiber zu wechseln. Der wird zwar vielleicht nur ein Programm und kein Kernelprozess sein, und daher mehr CPU verbrauchen, aber das crasht dann das System nicht!

    Sorry, kann als quasi-Laie nur gehörtes und eigene Beobachtungen zu Abstürzen schildern.

    Kenn aber so einige Programme, die nicht weitermachen, bis die Anfrage erfüllt ist, oder einfach hängen. Z.B. hab ich keinen guten Soundbalster, der mehre Stimmen gleichzeitig wiedergeben kann, ohne durch Software analog gemischt zu werden. Höre ich dann MP3 und surfe auf eine Seite mit Flash, ist der Sound schon belegt, und ich muss erst den MP3-Player stoppen, bis der Browser weiterlädt. Passiert sowas aber mit deinem PPPOE-Treiber, dann gute N8! (Also mal angenommen, der wartet darauf 3 Pakete aus der Sendewarteschleife abzuschicken und hält dabei den Kernel an, dann kannst du in dem Moment nichtmal eine neue Verbindung herstellen!
    Was ich meine, will ich dir mal mit der folgenden Linuxausgabe klarmachen:

    ppp0 Protokoll:Punkt-zu-Punkt Verbindung
    inet Adresse:"meineIP" P-z-P:217.5.98.62 Maske:255.255.255.255
    UP PUNKTZUPUNKT RUNNING NOARP MULTICAST MTU:1452 Metric:1
    RX packets:3095 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3217 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:3
    RX bytes:1040580 (1016.1 Kb) TX bytes:251444 (245.5 Kb)

    Also mache mal einen Test:

    Bevor du die Verbindung mit dem Client trennst, schliesse alle Programme, die Pakete ins Web schicken. Dann sollte die Warteschleife, wie bei mir in der Linux -Ausgabe 0 betragen!

    Demnach kann sich dann auch nichts aufhängen.

    Bedenke auch, dass auch der Netzwerkkarten Treiber und die Karte da mit reinspielen, ob du ein solches Problem hast, oder nicht.

    Ich hoffe, du kannst annähernd verstehen, was ich meine, zu mehr bin ich als Otto-Normal-User auch nicht fähig, hab zumindest versucht mir Mühe zu geben.

    MfG

    Schugy
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen