Access 2000

Dieses Thema im Forum "Office-Programme" wurde erstellt von foco, 7. Juni 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. foco

    foco Byte

    Registriert seit:
    8. Februar 2001
    Beiträge:
    64
    Hallo
    Ich habe zwei einfache Tabellen erstellt und die Beziehung 1:n unter den Tabellen kreiert. Nun erstellte ich eine Abfragen mit einigen Feldern aus beiden Tabellen und speicherte diese. Mit dem Formularassistenten erzeugte ich ein Formular mit der Abfrage und wollte einen neuen Datensatz eingeben. Leider war es unmöglich einen neuen Datensatz hinzuzufügen. Die Schaltfläche war ebenfalls inaktiv.
    Wer kann mir einen Rat geben, woran das liegen mag.
    Vielen Dank zum voraus.
    MfG foco
     
  2. racoon0506

    racoon0506 Kbyte

    Registriert seit:
    17. August 2004
    Beiträge:
    169
    Wie sieht denn der SQL-Code der Abfrage aus? Schätze mal, dass hier kein korrekter Join besteht und die Abfrage daher nicht aktualisierbar ist. (in bezug auf das Neuanlegen von Daten...)
    ist in der Abfrage das Verknüpfungsfeld sowohl von der 1- als auch von der n-Seite enthalten?

    Btw. ist die Verwendung von Hauptfomular für die Mastertabelle und Unterformular für die verknüpfte Tabelle wohl sinnvoller....
     
  3. foco

    foco Byte

    Registriert seit:
    8. Februar 2001
    Beiträge:
    64
    Ich habe nochmals ein Formular erstellt mit der gleichen Abfrage und kann nun den neuen Datensatz eingeben. Der SQL-Code der beiden Formulare ist der gleiche. Einer geht, der andere nicht? Das ist mir schon öffters passiert, weiss aber einfach nicht warum? Was meinst du mit Btw?
    MfG
    foco
     
  4. racoon0506

    racoon0506 Kbyte

    Registriert seit:
    17. August 2004
    Beiträge:
    169
    btw ist ein Acronym für "By the way" (Ach, übrigens...)
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen