Audioumwandlung

Dieses Thema im Forum "Videobearbeitung, Bildbearbeitung" wurde erstellt von Shibby_89, 9. März 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Ich will eine AVI-Datei mit TMPGENC in eine Mpeg 2 Datei umzuwandeln, um diese Datei dann las SVCD zu brennen.

    So weit so gut.

    Nun das Problem:

    Die Tonspur im Film ist mit dem AC3-Codec codiert.Diesen kann ich installieren und den Film anschauen.
    Aber ich kann ihn mit TMPGENC nicht in eine Mpeg 2 Datei umwandeln.Es kommt der Fehler:File [Pfad\Name der Datei.avi] can not open or unsupported.

    Gibt es hierfür eine möglichkeit die Tondatei mitzudecodieren oder Ähnliches????

    Bin für Antworten sehr dankbar.

    Andreas
     
  2. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Danke.

    Ich habe es mit EO Video gemacht und es hat funktioniert.

    Andreas
     
  3. Gast

    Gast Guest

    Wenn der Ausgangston sauber ist, gibt es auch einen Weg, ihn sauber für die Weiterverarbeitung zu erhalten. Hast du es schon mit dem Diskwriter-plugin von Winamp versucht?. Da Winamp wohl ac3 lesen kann, erhältst du eine Wav-Datei, die du mit TmpgEnc zum mpeg-Video muxen kannst. Vorherige Bearbeitung ist dann ja auch möglich.
    Ach, und noch was: VirtualDub hat eine Einstellung, um eine beschädigte Tonspur trotzdem völlig herauszulösen: Error mode (für Video und auch für Audio). Hast du es damit schon versucht? Wenn nicht, dann mache es als "Full processing mode" und regle dabei Volume auf 50 % zurück.
    MfG
     
  4. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Ich habe das gemacht und glaube jetzt nicht mehr, dass die Probleme mit dem Sound auf TMPGENC zurückzuführen sind, denn mir ist jetzt aufgefallen, dass ich die gleichen Soundprobleme habe, wenn ich die Tonspur anhöre, bvor sie mit dem Hauptfilm zusammengefügt wurde.

    Das heißt, dass ich entweder Fehler mit VirtualDub mache oder ein andres Programm verwenden sollte.

    Kennt jemand noch eins???
     
  5. Gast

    Gast Guest

    Rechts unten "load", dann das gewünschte Template aus deinem TmpgEncoder-Verzeichnis /-unterverzeichnis auswählen und laden, anschließend auf dem gleichen Wege "unlock.mcf" auswählen und danach über "Setting" die gewünschten Einstellungen vornehmen. Bei Audio z.B. ein- und ausblenden und die Lautstärke auf ca. 55% reduzieren (ausprobieren), denn die ist meistens zu hoch eingestellt. Wenn dann noch 128 kBit/s für mpeg2-Audio eingestellt ist, wird der Ton Sch... (Ton mit höherer Bitrate aufnehmen und dann umrechnen!).
    MfG
     
  6. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Fällt garniemandem was ein???

    Wäre für eure Hilfe sehr dankbar.

    Andreas
     
  7. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Noch was:
    Die Tonqualität ist nicht gut. Das heißt, dass immer wieder Knackser vorkommen.

    Kann jemand helfen.
     
  8. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Wo soll ich das auswählen??
     
  9. Gast

    Gast Guest

    Hi, macht nichts! Wähle danach "unlock.vcf" und editiere dann die gewünschten Einstellungen.
    MfG
     
  10. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Hat funktioniert.

    Ich sollte jetzt nur noch dieAuflösung herunterstellen können (bei TEMPENC). Wenn ich unter Settings gehe ist die Auflösung schreibgeschützt.

    Andreas
     
  11. Gast

    Gast Guest

  12. Gast

    Gast Guest

    war falsch...
     
  13. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Kann jemand helfen????
     
  14. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Es kommt folgender Fehler:
    VirtualDub Error
    The requested audio comression is not compatible with the input format.Check that the sampling rate and channel count of input match those of the requested format.
     
  15. Gast

    Gast Guest

    Du hast schon ein . avi file richtig??

    dann ist es ja umso einfacher!!

    Besorg dir virtualdub...


    http://prdownloads.sourceforge.net/virtualdub/VirtualDub-1.5.10.zip?download


    starte das prog. und oeffne deine .avi datei.

    Nun auf video direct stream copy umstellen.

    dann wieder auf file und save wave....

    das ist alles!!!

    was vergessen...bei Audio auf FULL PROCESSING MODE umstellen......wichtig!!!!!


    oder ganz toll hier:

    http://www.brennendvd.de/sections.php?op=viewarticle&artid=18


    sag mal bescheid ob's ging
     
  16. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Danke für deine Hilfe.
    Leider kenne ich mich im Themenpunkt Videobearbeitung nicht gut aus und habe noch ein paar Fragen:

    Wie trenne ich die zwei verschiedenen Spuren
    Wie wandle ich AC3 in wav um??

    Andreas
     
  17. Gast

    Gast Guest

    Wieso machst du es nicht so:

    Erst von der avi datei film und ton spur trennen.

    Dann ac3 ton zu .wav encodieren.

    anschliessend seperate quelle von jeweils film und .wav datei in tmpeg waehlen!!

    damit sollte es doch gehen!!
     
  18. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    EO Video kann die Tonspur völlig decodieren.

    Aber nachdem das Programm 10min der Fimspur erfolgreich dekodiert hatte, hört es auf weiter die Filmspur weiterzudekodieren.

    In der neuen Datei sind dann nur die ersten 10min der Tonspur und die ganze Tonspur drauf.

    Kann mir jemand hlefen??
     
  19. Shibby_89

    Shibby_89 Halbes Megabyte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    904
    Versuche es gerade mit EO Video.

    Bis jetzt scheint es zu klappen.

    Ich melde mich, wenn die Decodierung abgeschlossen ist.
     
  20. Gysi

    Gysi Byte

    Registriert seit:
    18. November 2003
    Beiträge:
    92
    So weit ich weiß, kommt TMPGEnc nicht mit mp3 oder AC3 komprimierten Audiospuren klar. Du könntest versuchen, von der AVI-Datei Bild und Ton zu trennen, den Ton unkomprimiert zu speichern und als Quellen die jeweiligen Dateien zu laden. Wenn das nicht geht, dann liegt's am AVI-Codec. Welchen benutzt du denn? Ach ja, und auf einer (S)VCD kannst du nur Stereo-Ton speichern.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen