Boot.ini und ntoskrnl.exe Problem... Brauche Hilfe !

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von sir.jackoff, 15. Mai 2006.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. sir.jackoff

    sir.jackoff Byte

    Registriert seit:
    20. Oktober 2002
    Beiträge:
    27
    Hallo,

    letzens ist mir mein Rechner abgestürzt. Daraufhin konnte ich nur noch eine meiner beiden WIndows-Versionen starten...

    Bei der nichtfunktionierenden kommt immer die Meldung mit dem
    ich solle eine neue Kopie der ntoskrnl.exe in das Windowsverzeichniss kopieren, da diese defekt ist oder fehlt.
    Es handelt sich bei beiden Versionen um Windows XP Professional.
    Wenn ich reparieren will, kann ich nur die funktionierende Windowsversion reparieren, die defekte wird nicht gelistet (warum auch immer).

    Ich habe diverse Sachen versucht, die ntoskrnl.exe wiederherzustellen (google.de ;-) ) aber bin nicht weitergekommen.

    Ich habe die expand ...\ntoskrnl.ex_ -Methode probiert (WinXP CD),
    ich habe einfach die ntoskrnl.exe meiner funktionierenden Version rüberkopiert, alles war jedoch erfolglos.

    Schließlich habe ich noch die boot.ini verändert. Hat aber auch nicht geholfen. Ich habe /NoGuiBoot probiert, auch erfolglos...

    meine boot.ini:

    [boot loader]
    timeout=10
    default=multi(0)disk(0)rdisk(1)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(2)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer
    multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Microsoft Windows XP Professional (OK)" /noexecute=optin /fastdetect /usepmtimer

    Hier ein Screenshot meiner Plattenkonfiguration:
    www.generaljackoff.de/images/hdd_cfg.jpg

    --> das "WindowsXP" funktioniert, das andere auf Datenträger 3 nicht.

    Habe ich einen Fehler in der Boot.ini ?
    Hat noch jemand eine Idee was ich mit der ntoskrnl.exe machen könnte?

    Im schlimmsten Fall werde ich wohl Windows neu installieren müssen, was ich aber definitiv nicht will !

    Vielen Dank schonmal im Voraus !!

    Grüße Jan
     
  2. winautus

    winautus Byte

    Registriert seit:
    15. Mai 2006
    Beiträge:
    17
    Hallöchen erstmal!

    Warum ist der PC abgestürzt, und wie hatte sich das geäussert ???

    PC mit der XP Setup-CD booten und die Wiederherstellungskonsole starten. Dort dann folgende Befehle eingeben:

    FIXMBR "Y:"
    FIXBOOT "Y:"
    COPY x:\I386\NTLDR "Y:\"
    COPY x:\I386\NTDETECT.COM "C:\"
    Das "x" ist jeweils durch den Laufwerksbuchstaben des CD-ROM Laufwerks zu ersetzen, und "Y:" entsprechend durch den Buchstaben der Festplatte, wo sich das defekte "Windows" befindet.

    Der Kernel "ntoskrnl.exe" ist normalerweise noch vorhanden, wenn, wie standardmässig im laufenden Betrieb der "Windows-Systemdateischutz" aktiv war.

    Der Parameter /NoGuiBoot hat damit nichts zu tun.


    Auf Deinen Screenshot sind reichlich Partitionen zu sehen.

    Ist das Deine aktuelle "boot.ini", oder hast Du nun etwas verändert ???

    Und wie hatte sich der Absturz geäussert???


    Hierzu auch: http://www.pcwelt.de/forum/showthread.php?t=203659
     
  3. sir.jackoff

    sir.jackoff Byte

    Registriert seit:
    20. Oktober 2002
    Beiträge:
    27
    Hallo,

    danke erst mal für deine Hilfe !

    werde dass mit der WHK gleich mal ausprobieren...

    der "absturz" = stromausfall... pc aus, dann einfach wieder eingeschalter mehr nicht.

    die boot.ini die ich gepostet habe, ist die, mit der ich aktuell arbeite, d.h. das eine windows funktioniert (Windows... (OK)), mit diesem arbeite ich gerade, das andere funktioniert nicht.

    grüße jackoff
     
  4. sir.jackoff

    sir.jackoff Byte

    Registriert seit:
    20. Oktober 2002
    Beiträge:
    27
    Hi,

    habe deine Idee ausprobiert. Hat aber leider nichts bewirkt...
    Weder die Änderung in der Boot.ini noch durch das in der WHK...
    Nur in der boot.ini ist jetzt noch ein weiteres Windows gelistet, dass ich früher mal drauf hatte (jetzt nicht mehr drauf).
    Aber sonst immer noch der ntoskrnl.exe Fehler.

    gruß jan

    p.s. langsam bin ich am verzweifeln :nixwissen
     
  5. Doppelaccount

    Doppelaccount ROM

    Registriert seit:
    16. Mai 2006
    Beiträge:
    1
    Die Ideen können auch nicht funktionieren, weil sie
    1. überflüssig
    2. teilweise auch noch falsch beschrieben

    sind. Zu "fixmbr" gibt es keinen Laufwerksbuchstaben.

    Da der Rechner offenbar das Programm, das die Fehlermeldung ausgibt (nämlich NTLDR) lädt, müssen MBR und Bootsektor logischerweise in Ordnung sein, sonst käme da eine andere Fehlermeldung. :rolleyes:

    Versuche die Tipps aus http://support.microsoft.com/kb/314477/DE/

    Möglicherweise musst du die entsprechende Installation über Neuinstallation > Reparieren etwas "auffrischen" ;)


    @ den per Mail angeschriebenen Moderator

    Wenn er sich denn bequemen mag, die Mail auch irgendwann mal zu beantworten, dann kann dieser "Doppelaccount" auch entsorgt werden. Das scheint ja wohl das am häufigsten diskutierte und brennendste Problem in diesem Forum zu sein.

    /SCNR
     
  6. kalweit

    kalweit Hüter der Glaskugel

    Registriert seit:
    18. April 2000
    Beiträge:
    31.487
    Ich zitiere mal eine Mail von dir selbst:

    Du musst dich schon entscheiden :) - na gut, eigentlich nicht :baeh:
     
  7. sir.jackoff

    sir.jackoff Byte

    Registriert seit:
    20. Oktober 2002
    Beiträge:
    27
    super danke !!!

    der microsoft-support artikel ist echt gut.

    jetzt hats geklappt, damit auch andere was davon haben:

    1) wiederherstellungskonsole gestartet
    2) bootcfg /rebuild
    3) er hat alle betriebssysteme gefunden
    4) die boot.ini wurde aktualisiert
    5) mein windows geht wieder :D

    vielen dank !

    grüße jan
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen