Boot.ini

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von grappe, 20. Oktober 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. grappe

    grappe ROM

    Registriert seit:
    20. Oktober 2002
    Beiträge:
    7
    Hallo,

    ich habe 2 Festplatten. Auf der ersten ist Win98 und auf der anderen ist Win2000. Installiert habe ich erst Win98 und dann Win2000. Ich möchte aber jetzt die erste Platte von Win98 befreien weil die zweite voll ist. Ohne Win98 komme ich aber nicht mehr an Win2000 heran, weil da immer ein Multi Boot Menü erscheint. Ich habe einfach mal die erste Platte ausgebaut um zu testen ohne Win98 aber dann gibt es nur eine Fehlermeldung statt das Startmenü. Ich möchte aber zukünftig nur noch mit Win2000 fahren. Was müßte ich ändern z.B. an der Boot.ini ?

    meine momentane Boot.ini:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(1)partition(1)\WINNT
    [operating systems]
    multi(0)disk(0)rdisk(1)partition(1)\WINNT="Microsoft Windows 2000 Advanced Server" /fastdetect
    C:\="Windows 98"

    Für eure Hilfe wäre ich SEHR dankbar.
     
  2. grappe

    grappe ROM

    Registriert seit:
    20. Oktober 2002
    Beiträge:
    7
    alles scheiße
     
  3. grappe

    grappe ROM

    Registriert seit:
    20. Oktober 2002
    Beiträge:
    7
    Ginge denn folgende Möglichkeit ?

    die boot-dateien auf die zweite Platte kopieren, erste Platte entfernen, von CD oder den 4 Startdisketten booten,
    die Option R (Reparatur) auswählen um den Bootsector (aber nur diesen, nicht das ganze System) wiederherstellen lassen (in diesem Fall dann auf der 2. Platte)

    PS: bin schon ganz verzweifelt :-(
     
  4. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Das Problem ist so nicht ohne weiteres lösbar, weil in der Registry die Pfade auf ein Windows-Ordner d:\windows verweisen (unabhängig davon, dass die Bootdateien auf c: liegen).Geh mal mit regedit in die Registry und gebe in der Suche den Pfad d:\windows ein.Eine solche Pfadangabe existiert in der Registry mehr als tausend Mal.Alle diese Pfad-Angaben müßten aber auf C:\windows geändert werden.Mir ist auch nicht ganz klar, warum Du unbedingt die erste Platte formatieren möchtest.

    franzkat
     
  5. grappe

    grappe ROM

    Registriert seit:
    20. Oktober 2002
    Beiträge:
    7
    Wenn ich aber die erste Platte ausbaue nachdem ich die Boot-Dateien kopiert habe auf die zweite, dann muß doch die zweite dann als erste erkannt werden, denn schließlich gibt es dann doch nur noch EINE, und die müßte dann doch C: sein.
    Wenn nicht, und sie ist immer noch D:, wie kann man dann den Laufwerksbuchstaben auf C: ändern ? Und wie könnte man eventuell den Bootsector der ersten Platte auf die zweite bringen ?
     
  6. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hallo Jan !

    Wenn Du die erste Platte formatierst, kannst Du Win2000 nicht mehr starten.Ein Umkopieren der Bootdateien hilft hier nichts.Der Bootsektor ließe sich ohnehin nicht ohne weiteres kopieren.Hier spielt eine Windows-Besonderheit eine Rolle.Windows-Systeme erwarten, dass der Bootsektor und die Bootdateien auf der ersten Festplatte,auf der aktiven primären Partition liegen.Linux z.B. ist da großzügiger;das könntest Du auch auf der zweiten Platte installieren

    franzkat
     
  7. grappe

    grappe ROM

    Registriert seit:
    20. Oktober 2002
    Beiträge:
    7
    Ich will aber die erste Festplatte komplett neu formatieren.
    Welche Bootdateien muß ich denn dann auf die zweite rüberschieben und muß ich dann noch Änderungen an der Boot.ini vornehmen ?
     
  8. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hallo Jan !

    Der Vorschlag von Stefan ist zunächstmal richtig, weil der Bootsektor von Win98 jetzt nicht mehr geladen ist.SDa es Die aber um die Schaffung von Kapazität auf Deiner ersten Festplatte ging, ist das Problem nioch nicht ganz gelöst.Dazu mußt DSu Dir den Windows-Ordner auf der ersten Festplatte per Hand löschen.Denn den benötigst Du dann nicht mehr.Außerdem kannst Du die Dateien bootsect.dos,io.sys,command.com und msdos.sys auf der ersten Festplatte löschen, denn auch diese Dateien gehören zum Win98 Betriebssystem.Du mußt Dir allerdings bewußt machen, dass auch weiterhin die Bootdateien und der Bootsektor für Win2000 auf der ersten Platte liegen und nicht etwa auf der zweiten.Auf der zweiten liegt "nur" der Windows2000-Ordner.

    franzkat
    [Diese Nachricht wurde von franzkat am 20.10.2002 | 11:16 geändert.]
    [Diese Nachricht wurde von franzkat am 20.10.2002 | 13:06 geändert.]
     
  9. sxxsgr

    sxxsgr Byte

    Registriert seit:
    3. August 2001
    Beiträge:
    42
    Sicher deine Boot.ini und Probiere das mal

    [boot loader]
    timeout=0
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Advanced Server" /fastdetect

    Gruß SGR
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen