Boot- Problem unter Mandrake 9

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von M3zZiaH, 3. Juni 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. M3zZiaH

    M3zZiaH Byte

    Registriert seit:
    23. September 2002
    Beiträge:
    77
    Hi,

    ich habe grade versucht, Mandrake 9 zu installieren, hat auch alles wunderbar geklappt, nur funktioniert anscheinend der Boot-Manager nicht so ganz. Ich verwende LILO, habe ihn auf hda installiert, aber beim Systemstart wird nur

    L 99 99 99 99 ... (fortlaufend)

    angezeigt. Kann mir jemand weiterhelfen? Was mach ich hier falsch? Ansonsten hats doch eigentlich auch immer geklappt mit dem Boot-Manager.
     
  2. ilmirulez

    ilmirulez Kbyte

    Registriert seit:
    24. Januar 2003
    Beiträge:
    213
    Doch das gehtauch bei Mandrake. Wähle den Punkt Installation, der Installer bekommt dann mit, dass es schon ne Linux-Version gibt und aktualisiert diese. Dort kannst du auch den BS-Starter neu konfigurieren lassen und evtl. noch nicht installierte Pakete installieren.
     
  3. emacs

    emacs Megabyte

    Registriert seit:
    10. Dezember 2002
    Beiträge:
    1.031
    Hi,

    also, wenn du mit Knoppix bootest, erscheint irgendwann der KDE-Desktop mit diversen Icons und allem was dazugehört. Dort suchst du dir dein Laufwerk, auf dem der Ordner /etc liegt (vermutlich hda2).

    Zum schreiben habe ich das hier:

    "F: Ich sehe die Partitionen meiner Festplatte auf dem Desktop, und kann
    durch Draufklicken auch auf die Inhalte zugreifen, beim Schreiben bekomme
    ich aber immer "keine Berechtigung" als Fehlermeldung. Wie kann ich auf
    meine vorhandenen Partitionen schreiben?

    A: Die generelle Philosophie der KNOPPIX ist es, so wenig wie möglich
    Schreibzugriffe zu erlauben, daher werden die vorhandenen Partitionen
    wenn überhaupt, nur "read-only" eingebunden. Wenn mit der rechten
    Maustaste auf das jeweilige Icon geklickt wird, lässt sich jedoch unter
    "Gerät" das "read-only" wegklicken. Anschließend lässt sich die jeweilige
    Partition dann "read-write" einbinden (evtl. bei bereits eingebundenen
    Partitionen vorher noch mal auf "Aushängen" klicken!).
    ACHTUNG: Beim Schreiben auf NTFS-Partitionen kann es zu Datenverlusten
    kommen, da dieses Dateisystem von Linux kaum unterstützt wird!
    DOS/FAT32-Dateisysteme sind jedoch im Schreibzugriff unkritisch.

    Tipp:
    In der Shell funktioniert das "schreibbar machen" von bereits
    eingebundenen Partitionen mit "mount -o remount,rw /mnt/partitionsname". "

    In den Knoppix FAQ gefunden, die FAQ findest du hier:

    http://download.linuxtag.org/knoppix/KNOPPIX-FAQ.txt

    gruß

    emacs
     
  4. Jörn Stadelmann

    Jörn Stadelmann Viertel Gigabyte

    Registriert seit:
    7. April 2001
    Beiträge:
    4.450
    Boote von der Knoppix-cd mit eingabe:
    <B>knoppix 2</B>
    dann mountest du deine Mandrake partition:
    X= Festplattennummer - die erste a, die zweite b.
    n=Partitionsnummer
    Wenn du dir nicht sicher bist mit der Nummer (Auf welcher Platte Mandrake liegt wirst du wohl wissen, rufe <B> cfdisk </B> auf. falls die 2te Platte benötigt wird <B> cfdisk /dev/hdb </B>. Nachdem du diese Infos beisammen hast:
    <B>mount /dev/hdXn /mnt/hdXn
    chroot /mnt/hdXn bin/bash
    lilo</B>
    (hier sollte dann
    * added Linux
    oder ähnliches erscheinen.
    Wenn dort eine Fehlermeldung kommt, passt deine Lili.conf nicht.
    Dann diese mal mit einem Editor deiner Wahl öffnen. Ansich findet man Fehler hier recht schnell - sind ja reichlich kommentare zu den einzelnen Optionen enthalten. Danach dann nochmal <B>Lilo</B> aufrufen.
    <B>exit
    shutdown -r now</B>
    CD entfernen und gucken ob es beim Neustart funzt.

    J2x
    [Diese Nachricht wurde von j2x am 04.06.2003 | 12:37 geändert.]
     
  5. M3zZiaH

    M3zZiaH Byte

    Registriert seit:
    23. September 2002
    Beiträge:
    77
    "die Partition mit Lilo.conf mounten."

    Kannst du mir das genauer erklären? Kenne nur den Befehl mount zum mounten von Laufwerken.

    "Damit das klappt musst du vorher auf allen Partionen Schreibrecht haben."

    Das habe ich bei Knoppix bis heute nicht hingekriegt...

    Sorry, aber Linux ist derzeit noch Neuland für mich, deswegen sind mir manche Sachen fremd/ungewöhnlich.
     
  6. emacs

    emacs Megabyte

    Registriert seit:
    10. Dezember 2002
    Beiträge:
    1.031
    Hallo,

    wenn du an die Lilo.conf heran willst, dann versuche es mit Knoppix. Einfach CD einlegen, booten und wenn es läuft, die Partition mit Lilo.conf mounten. Anschließend an der Konsole Lilo eingeben und es sollte funktionieren.

    Damit das klappt musst du vorher auf allen Partionen Schreibrecht haben.

    gruß

    emacs
     
  7. M3zZiaH

    M3zZiaH Byte

    Registriert seit:
    23. September 2002
    Beiträge:
    77
    Öhm... nee, entweder Installation, oder gar nix.
    Finds eigentlich schade, hätte zu gerne mal wieder Linux drauf gehabt.
     
  8. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Unter Suse kann man bei Start über die InstallationsCD im Menü den Punkt "installiertes Betriebssystem laden" auswählen, vielleicht gibt es unter Mandrake eine vergleichbare Option.
    MfG
     
  9. M3zZiaH

    M3zZiaH Byte

    Registriert seit:
    23. September 2002
    Beiträge:
    77
    Danke für die schnelle Antwort.
    Ich würde ja gerne die Datei einsehen, aber ich kann absolut nicht auf das System zugreifen, weil eben beim Start dieser "Fehler" (oder was auch immer das sein mag) angezeigt wird. Ist gut möglich, dass es an der Plattenkonfiguration liegt, aber wo genau, das weiß ich dann auch nicht...
     
  10. bitumen

    bitumen Megabyte

    Registriert seit:
    4. Juni 2002
    Beiträge:
    1.952
    Dieses Problem taucht auf, wenn in der /etc/lilo.conf auf eine nicht vorhandene Partition gezeigt wird, oder wenn das BIOS nicht die gesamte Platte erkennt. Da die Installation erfolgreich war, ist dies auszuschließen. Kontrolliere die /etc/lilo.conf, da müsste bei "linux" die entsprechende partition angegeben sein. Falls du deine Part.tabelle nicht auswendig kennst, kannst du sie mit dem befehl "cfdisk" besichtigen.

    Falls du die /etc/lilo.conf geändert hast, kannst du dann mit dem Befehl "lilo" den MBR neu schreiben.

    Gruß, buherator
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen