Cd-Brennen unter K3B unbekannter Fehler 255

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Cheetah, 7. November 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Cheetah

    Cheetah Kbyte

    Registriert seit:
    28. September 2000
    Beiträge:
    456
    Habe da ein kleines Problem. Wenn ich unter K3B (Suse Linux 9.1) eine CD brennen will, bricht das Brennprogramm die Aktion mit dem Hinweis unbekannter Fehler 255, Cdrecord gibt Brennautrag zurück. Ich habe übrigens einen externen CD-Brenner (Freecom II classic series) der über USB 2 läuft. Lesen lassen sich die CD's aber mit dem Brennen gibt es ein kleines Problem. Unter Google war da auch nicht besonders viel Hilfreiches zu finden, anscheinend gibt es dieses Problem öfters. Aber nichts desto trotz, vielen Dank schon mal im Voraus für eure Hilfe.

    Gruß Cheetah :bet:
     
  2. RaBerti1

    RaBerti1 Viertel Gigabyte

    Registriert seit:
    24. November 2000
    Beiträge:
    5.094
    Hi!

    Nein, Erfahrung mit externem Brenngerät unter Linux hab ich nicht. Sorry. Was mir zu Deinem Prob einfällt:

    Hast Du sichergestellt, daß der Brenner als rw gemountet ist? Ich vermute, daß da die Einbindung der USB-Geräte generell noch Macken hat. Ich selber bin mit einer externen HD gesegnet, die auch nicht immer so läuft, wie sich der Hersteller das gedacht haben mag. Aber die Mount-Optionen wären das erste, wo ich noch suchen würde: Schließ das Teil an und schau in der Konsole als root mit
    mount
    nach, was eigentlich alles an Geräten angemeldet ist. Ggf. gibts da schon den ersten Hinweis. Danach wären ggf. Meldungen aus
    /var/log/messages
    interessant, um der Ursache auf den Grund zu kommen.

    MfG Raberti
     
  3. reinie

    reinie Kbyte

    Registriert seit:
    15. September 2003
    Beiträge:
    197
    Reduziere mal die brenngeschwindigkeit auf ein minimum und versuche es nochmal.
     
  4. blauerklaus2

    blauerklaus2 Kbyte

    Registriert seit:
    27. Februar 2004
    Beiträge:
    482
    Hier mal mit der Kommandozeile brennen !!!

    Erstmal überprüfen ob der USB erkannt wird ,
    ab Kernel 2.6..... in einer shell folgen des eingeben !
    ls /dev/sd* ## dann könnte die Antwort so
    etwa aussehen !
    /dev/sda /dev/sdb /dev/sdc /dev/sdd /dev/sdd1
    hier ist es dann /dev/sdd1
    Anmerkung : Die Daten für USB hier sdd1 solten
    in der /etc/fstab eingetragen sein und im Wurzelverzeichnis
    ein Mountpoint hierfür vorhanden !
    Ich brenne nicht mit k3b sondern in der Kommandozeile
    Auch hier ist zu beachten das ab Kernel 2.6... man nur
    als root brennen kann seidenn man hat über sudo sich
    die Rechte gesetzt . So etwar
    visudo Paket sudo install
    user ALL = NOPASSWD: /usr/bin/cdrecord* ###### vorletzte Zeile

    sudo /usr/bin/cdrecord dev=ATA: -scanbus ########testen als user ###

    /bin$ vi cdrecord ##### eingeben ###

    #!/bin/sh


    sudo /usr/bin/cdrecord "$@"

    /bin$ chmod 755 cdrecord

    /bin$ echo $PADH


    Wenn dieses so eingerichtet kann man auch als User brennen !
    Jetzt hier für CD selbst zusammen stellen mkisofs
    mkisofs -J -r -v -V "Software" -o test.raw test
    Nun für brennen ab Kernel 2.6.......
    Hier ist der Brenner am zweiten Bus Master !
    cdrecord dev=/dev/hdc speed=24 fs=16m -v -eject x.raw
    Es gibt für Cdrecord auch ander Möglichkeiten.

    Ich hoffe ich konnte helfen .

    Viel Spass mit Linux

    bk2
     
  5. Cheetah

    Cheetah Kbyte

    Registriert seit:
    28. September 2000
    Beiträge:
    456
    Vielen Dank für Eure Antworten, sobald ich das hingekriegt habe melde ich mich noch einmal....

    Gruß Cheetah
     
  6. Carbonat

    Carbonat Byte

    Registriert seit:
    27. Juni 2001
    Beiträge:
    85
    Habe ein ähnliches Problem... ist mein Laufwerk richtig gemountet fürs brennen?

    /dev/hdc on /media/cdrecorder type subfs (ro,nosuid,nodev,fs=cdfss,procuid,iocharset=utf8)

    Carbonat
     
  7. Cheetah

    Cheetah Kbyte

    Registriert seit:
    28. September 2000
    Beiträge:
    456
    Wenn ich unter Linux 9.1 eine Daten-CD erstellen will, so klappt das anstandslos. Der Brenner springt an und kurbelt mir meine Daten auf die CD-ROM. Nur wenn ich eine CD kopieren will, dann kommt diese komische Fehlermeldung "unbekannter Fehler Fehlermeldung 255". Sehr seltsames Problem, meine Laufwerke sind alle richtig gemountet....Unter Details kann (K3B - Debbuging) kann ich dann lesen das der Brenner bzw. cdrecord Probleme hat das SCSI-Laufwerk zu finden.

    Gruß Cheetah
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen