compiler problem

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von sp33dpu55y, 16. Februar 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. sp33dpu55y

    sp33dpu55y ROM

    Registriert seit:
    16. Februar 2004
    Beiträge:
    2
    Hi!
    Ich bin totaaler newbie in sachen linux und hab folgendes problem:
    wenn ich ein paket z.B eggdrop installieren möchte kommt nach der eingabe des
    befehls ./configure immer der fehler:
    configure: error: no acceptable C compiler found in $PATH
    was kann ihc dagegen tun?
    (habe bei der installation von linux suse 9.0 eigentlich den c++ compiler
    installiert)
    Hoffe es kann mir jemand helfen!
     
  2. emacs

    emacs Megabyte

    Registriert seit:
    10. Dezember 2002
    Beiträge:
    1.031
    Und genau deshalb sollte der Threadstarter erstmal ALLE Entwicklertools nachinstallieren, was unter SuSE nun wirklich kein Problem darstellt.

    Greg
     
  3. wickey

    wickey Megabyte

    Registriert seit:
    8. Januar 2002
    Beiträge:
    1.126
    Du meinst vermutlich /usr/src und dort muss sich kein Verzeichnis linux befinden, ausgenommen man kompiliert ein Programm das die Kernelsourcen in genau diesem Pfad benötigt.
    Eggdrop benötigt weder diesen Pfad noch installierte Kernelsourcen.

    Es fehlt einfach der (richtige) gcc (der Kompilier) wie die Fehlermeldung einwandfrei zu erkennen gibt.

    grüße wickey
     
  4. rapmaster

    rapmaster Halbes Gigabyte

    Registriert seit:
    21. Juli 2002
    Beiträge:
    5.181
    wechsel ins:

    usr/share

    dann ls
    und sag uns was da steht

    mfg
     
  5. sp33dpu55y

    sp33dpu55y ROM

    Registriert seit:
    16. Februar 2004
    Beiträge:
    2
    mhh ich weiß net genau! was muss denn dann da stehn?
    bin doch newbie =)
     
  6. rapmaster

    rapmaster Halbes Gigabyte

    Registriert seit:
    21. Juli 2002
    Beiträge:
    5.181
    gibt es einen link namens linux in
    /usr/share/
    zu deinem kernel ?

    mfg
     
  7. emacs

    emacs Megabyte

    Registriert seit:
    10. Dezember 2002
    Beiträge:
    1.031
    Installiere die ganzen Developer-Tools nach, wahrscheinlich fehlt der passende Compiler. Dumm wird es dann, wenn die mitgelieferte Compiler-Version nicht kompatibel zu deinem Programm ist.

    Greg
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen