drucker druckt nicht über samba

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Michi0815, 26. März 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Michi0815

    Michi0815 Guest

    Registriert seit:
    7. Januar 2004
    Beiträge:
    3.429
    ich habe einen epson aculaser c900 an einem win2k-system hängen und im lan freigegeben; er lässt sich auch von meinen win-pc's aus ansprechen, nur von einem debian-system aus bekomme ich ihn nicht zum laufen.

    auf dem pc (2800+, 1gb ram, 160gb platte) läuft debian sarge mit einem standard kernel (2.6.8-2-k7) mittlerweile fast perfekt. ein treiber für den epson (alc900-cups-0.6.i386), samba (samba, samba-common) und cups (cupsomatic-ppd, cupsys, cupsys-bsd, cupsys-client, cupsys-pt) sind installiert. samba selbst scheint zu funktionieren (freigaben laufen in beide richtungen), aber dafür karkt die namensauflösung im lan; smb://computername im konqueror funktioniert, ansonsten muss ich über die ip gehen.
    der drucker ist unter cups installiert, es gibt keine nutzungsbeschränkungen und jeder darf drucken.
    druckertyp ist smb-drucker (windows), uri ist (momentan :D ) smb://matrix/192.168.77.17/epson

    wenn ich dann etwas drucken will, dann scheint alles zu funktionieren, es gibt keine (sichtbaren) fehler, der auftrag erscheint und verschwindet (lokal) in der druckerverwaltung unter druckaufträge aber in der druckerwarteschlange am win-rechner kommt nichts an und der drucker tut daher nichts.

    irgendwelche ideen? :nixwissen
     
  2. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    So eine Kofiguration habe ich noch nicht betrieben, aber ich vermute mal, daß du in die falsch Queue druckst.

    Durchforste mal dein Verzeichnis /var/spool/(lpd) und vor allem auch mal /var/log/messages + log.smb*

    mit dem Befehl "mail" auf der Konsole bekommt man bei Druckfehlern mitunter auch nützliche Hinweise.
     
  3. hokkaido

    hokkaido Byte

    Registriert seit:
    31. Januar 2005
    Beiträge:
    33
    hast du einen Windows Benutzernamen der im freigegebenen Druckrechner enthalten sein muss eingegeben?

    Passwort ist nicht so wichtig. Aber der fehlende Benutzername hat mich über Ostern Stunden gekostet. Leider wiess ich nicht wo das im Debian geht. Ich hab über Yast2 im Suse konfiguriert


    Peter
     
  4. Michi0815

    Michi0815 Guest

    Registriert seit:
    7. Januar 2004
    Beiträge:
    3.429
    danke für die antworten!

    hat sich automatisch erledig als ich in meiner verzweiflung den druckertreiber auf ver0.7 upgedated habe; offenbar hat die 0.6'er version probleme mit samba.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen