Einbinden einer neuen zweiten Festplatte

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von ssieg, 6. Dezember 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. ssieg

    ssieg Guest

    Bei mir läuft Debin Linux auf Knoppix-Basis, Kernel 2.6.7, KDE 3.2.
    Meine erste IDE-Festplatte kann ich prima mounten. /dev/hda6 ist auf / gemountet, //dev/hda10 auf /home usw. Nun kommt die zweite IDE-Platte dran:
    /dev/hdb1 soll eigentlich nach /new/first gemountet werden. Aber trotz korrekter /ect/fstab wird schon beim Systemstart mitgeteilt, /dev/hdb1 bereits eingehängt oder /new/first wird gerade verwendet. Nun, was mache ich falsch? Woran kann's liegen? :confused:
     
  2. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    Was spuckt denn der Befehl

    mount

    auf der Konsole aus und was steht in der /etc/fstab?
    Das geht auch, wenn man nicht als root angemeldet ist.
     
  3. ssieg

    ssieg Guest

    Also ich führe folgendes als root aus:
    root@victory:/home/stephen# mount -t ext3 /dev/hdb5 /new/lin1
    mount: /dev/hdb5 ist bereits eingehängt oder /new/lin1 wird gerade benutzt

    Und als User stephen:
    stephen@victory:~$ mount
    /dev/hda6 on / type ext3 (rw,errors=remount-ro)
    proc on /proc type proc (rw,nodiratime)
    devpts on /dev/pts type devpts (rw,gid=5,mode=620)
    usbdevfs on /proc/bus/usb type usbdevfs (rw)
    sysfs on /sys type sysfs (rw)
    /dev/hda1 on /win/winxp type ntfs (ro,nosuid,nodev,umask=000)
    /dev/hda2 on /win/win98 type vfat (rw,nosuid,nodev,umask=000)
    /dev/hda7 on /win/daten type vfat (rw,nosuid,nodev,umask=000)
    /dev/hda8 on /win/temp type vfat (rw,nosuid,nodev,umask=000)
    /dev/hda9 on /win/archiv type vfat (rw,nosuid,nodev,umask=000)
    /dev/hda10 on /home type ext2 (rw,nosuid,nodev)

    Hier die /ect/fstab:

    # /etc/fstab: filesystem table.
    #
    # filesystem mountpoint type options dump pass
    /dev/hda6 / ext3 defaults,errors=remount-ro 0 1

    proc /proc proc defaults 0 0
    /dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
    usbdevfs /proc/bus/usb usbdevfs defaults 0 0
    sysfs /sys sysfs defaults 0 0
    /dev/dvd /dvd iso9660 defaults,ro,user,exec,auto 0 0
    # Added by root at victory
    /dev/hdb1 /new/first vfat auto,users,exec,umask=000 0 0
    # Added by root at victory
    /dev/hdb2 /new/sec vfat auto,users,exec,umask=000 0 0
    # Added by root at victory
    /dev/hdb3 /new/third vfat auto,users,exec,umask=000 0 0
    # Added by root at victory
    /dev/hdb5 /new/lin1 ext3 auto,users,exec, 0 0
    # Added by root at victory
    /dev/hdb6 /new/lin2 ext3 auto,users,exec, 0 0
    # Added by root at victory
    /dev/hdb7 /new/lin3 ext3 auto,users,exec, 0 0
    # Added by KNOPPIX
    /dev/hda1 /win/winxp ntfs auto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda2 /win/win98 vfat auto,users,exec,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda5 none swap defaults 0 0
    # Added by KNOPPIX
    /dev/hda7 /win/daten vfat auto,users,exec,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda8 /win/temp vfat auto,users,exec,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda9 /win/archiv vfat auto,users,exec,umask=000 0 0
    # Added by KNOPPIX
    /dev/hda10 /home ext2 auto,users,exec 0 0

    Hoffentlich hab' ich jetzt alles zusammen...

    Ich weiß leider keinen Rat mehr...
     
  4. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    :confused:

    müßte laut /etc/fstab gemauntet sein, ist es aber nicht.

    Kommen beim Systemstart irgendwelche Fehlermeldungen?

    Was sagt denn "dmesg" zur hdb ?

    Steht in /var/log/messages irgendwas auffälliges?

    Was sagt

    lsof | grep /dev/hdb5

    und

    lsof | grep /new/lin1

    Im übrigen fällt mir auf, daß überhaupt nichts von /dev/hdb gemountet ist!
    Läuft die Platte überhaupt an (drin sein wird sie hoffentlich :p ) und hast du die Mount Points angelegt?
     
  5. ssieg

    ssieg Guest

    Beim Systemstart kommen die gleichen Meldungen, dass /dev/hdb5 bereits gemountet sei oder /new/lin1 bereits benutzt werde.
    Wie legt man die Mount Points an? Bisher sind das mei mir ganz normale Verzeichnisse. Vielleicht liegt da der Hase im Pfeffer!

    Bitte um Hilfe!

    Danke!
     
  6. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    'tschuldigung, meine vorherige Antwort war nicht ganz korrekt.

    der Befehl "mount" zeigt eindeutig an, daß die Patitionen nicht in den Verzeichnisbaum eingebunden sind.

    Hast du auf den Partitionen dein Filesystem angelegt?

    etwas muß du aber noch beantworten -> was sagen die Befehle

    "lsof | grep /dev/hdb5"

    "lsof | grep /new/lin1"

    und

    "dmesg"

    ?
     
  7. ssieg

    ssieg Guest

    Hallo!

    Ich habe mittlerweile meine zweite Festplatte umformatiert, es gibt nur noch eine Partition, /dev/hdb1 mit Typ ext3. Aber das gleiche Problem besteht weiterhin. Die /ect/fstab habe ich angepasst und

    lsof | grep /dev/hdb1

    sowie

    lsof | grep /mnt/hdb1

    ergeben keinerlei Ausgaben.

    Allerdigs ist die Platte unter einer Knoppix-CD sehr wohl les- und beschreibbar.

    Vielleicht mache ich nur einen kleinen Fehler???
     
  8. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    :confused:

    was zu erwarten war

    also vollkommen ok!

    mit Sicherheit! Einen Schreibfehler?

    Erklärung zu einer älteren Bemerkung von mir:
    Ein Mountpoint ist ein ganz normales Verzeichnis, das im inaktiven Zustand, d.h. die Zielpartition ist nicht gemountet, leer sein sollte. Wenn was drin steht, ist das aber auch nicht schlimm. Es wird dann von den Daten der gemounteten Partition überdeckt.

    Was gibt "df" aus? Und poste doch bitte mal alle Ausgeben von "dmesg" , was so HDD-Aktivitäten betrifft.

    Und was gibt der Befehl

    file -s /dev/hdb1

    aus. Langsam kommt mir dein Fall spanisch vor. Hast du den Kernel selbst compiliert?
     
  9. ssieg

    ssieg Guest

    Hallo!

    Hier die Ausgaben:

    df:
    stephen@victory:~$ df
    Dateisystem 1K-Blöcke Benutzt Verfügbar Ben% Eingehängt auf
    /dev/hda6 6293420 4191612 1782120 71% /
    /dev/hda1 4249160 4017812 231348 95% /win/winxp
    /dev/hda2 361264 329360 31904 92% /win/win98
    /dev/hda7 12277680 11955064 322616 98% /win/daten
    /dev/hda8 3078416 256020 2822396 9% /win/temp
    /dev/hda9 9846208 9384672 461536 96% /win/archiv
    /dev/hda10 2276992 801972 1359356 38% /home
    stephen@victory:~$

    dmesg:

    stephen@victory:~$ dmseg
    bash: dmseg: command not found
    stephen@victory:~$ dmesg

    SIS5513: IDE controller at PCI slot 0000:00:02.5
    SIS5513: chipset revision 1
    SIS5513: not 100% native mode: will probe irqs later
    SIS5513: SiS 962/963 MuTIOL IDE UDMA133 controller
    ide0: BM-DMA at 0xff00-0xff07, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xff08-0xff0f, BIOS settings: hdc:DMA, hdd:DMA
    hda: ST340810A, ATA DISK drive
    hdb: ST3200822A, ATA DISK drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    hdc: HL-DT-ST DVDRAM GSA-4160B, ATAPI CD/DVD-ROM drive
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: max request size: 128KiB
    hda: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=65535/16/63
    hda: hda1 hda2 hda3 < hda5 hda6 hda7 hda8 hda9 hda10 >
    hdb: max request size: 1024KiB
    hdb: 390721968 sectors (200049 MB) w/8192KiB Cache, CHS=24321/255/63
    hdb: hdb1
    libata version 1.02 loaded.
    device-mapper: 4.1.0-ioctl (2003-12-10) initialised: dm@uk.sistina.com
    cdrom: open failed.
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed
    device-mapper: error adding target to table
    ttyS1: LSR safety check engaged!
    ttyS1: LSR safety check engaged!
    NTFS driver 2.1.14 [Flags: R/W MODULE].
    NTFS-fs warning (device hda1): ntfs_fill_super(): Atime updates are not implemented yet. Disabling them.
    NTFS volume version 3.1.
    ts: Compaq touchscreen protocol output
    There is already a security framework initialized, register_security failed.
    selinux_register_security: Registering secondary module capability
    Capability LSM initialized as secondary
    NET: Registered protocol family 10
    Disabled Privacy Extensions on device c035fcc0(lo)
    udf: registering filesystem
    UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'PCM03_04', timestamp 2004/01/23 13:19 (103c)
    UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'Gault_Millau', timestamp 2004/03/22 17:15 (103c)
    UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'pcm07_04', timestamp 2004/05/18 12:21 (103c)
    UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'Gault_Millau', timestamp 2004/03/22 17:15 (103c)
    UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'PCM03_04', timestamp 2004/01/23 13:19 (103c)
    UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'PC_Magazin_09_2004', timestamp 2004/07/23 11:00 (103c)
    UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'CAPTAINJACK', timestamp 2004/08/17 15:53 (103c)
    UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'PC_MAGAZIN_11_2004', timestamp 2004/09/20 10:29 (103c)
    UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'PC_MAGAZIN_12_2004', timestamp 2004/10/20 15:36 (103c)
    UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'RS2K4DVD', timestamp 2004/12/13 12:54 (103c)

    file -s:

    stephen@victory:~$ file -s /dev/hdb1
    /dev/hdb1: writable, no read permission
    stephen@victory:~$

    Den Kernel habe ich nicht selbst kompiliert.

    Ich habe den logical volume manager im Verdacht für das Problem. Aber bisher habe ich keinen Schimmer, wie weiter...

    Bitte um Antwort.

    Danke!
     
  10. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    file -s /dev/hdb1

    mußt du als root ausführen.

    Was

    device-mapper: error adding target to table
    device-mapper: : dm-linear: Device lookup failed

    bedeutet, weiß ich momentan auch nicht. Muß ich erst mal suchen. Kann es sein, daß du nichts oder irgendwas im CD-Laufwerk liegen hast, womit Linux nichts anfangen kann?
     
  11. ssieg

    ssieg Guest

    Also als root erhalte ich folgendes:

    root@victory:/home/stephen# file -s /dev/hdb1
    /dev/hdb1: Linux rev 1.0 ext3 filesystem data

    Außerdem kann ich als root jederzeit die /dev/hdb1 formatieren. Das deutet darauf hin, dass sie nicht gemountet ist.

    Also was hier los ist, ist mir rätselhaft. Ich denke, dass es mit dem Devicemapper zusammenhängt, aber mit welchem Tool kann man solche Einstellungen bearbeiten, z.B. die Sachen beim Systemstart?

    Bitte antworte wieder, in meinem kleinen Bekanntenkreis (derjenigen, die Linux benutzen) , weiß es leider auch niemand.

    Also im DVD-Laufwerk liegt in der Regel kein Medium, es sei denn, ich will es explizit benutzen, da hab' ich bisher keine Probleme.

    Also bis bald!
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen