Excel 97/2000/XP: Rechnen mit Stunden und Minuten

Dieses Thema im Forum "Ihre Meinung zu Artikeln auf pcwelt.de" wurde erstellt von WHenze, 22. Dezember 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Mars47

    Mars47 ROM

    Registriert seit:
    22. Dezember 2003
    Beiträge:
    1
    Leichter geht's durch benutzerdefinierte Uhrzeit-Zellen wie folgt:
    [hh]:mm
    Danach sind einfaches Addieren über 24 Stunden hinaus sowie Subtrahieren bis auf 00:00 Stunden / Minuten möglich.
     
  2. WHenze

    WHenze ROM

    Registriert seit:
    20. Dezember 2003
    Beiträge:
    1
    Geht die Arbeitszeit jedoch über 24:00 gibt es ein falsches Ergebnis
     
  3. doba

    doba ROM

    Registriert seit:
    25. August 2004
    Beiträge:
    2
    der Tip ist ja schon nen bisschen alt :o

    13.11.2001 11:49

    wenn man sich wenigsten die Mühe gemacht hätte die alte Bandwurmformel

    =(STUNDE(B1-A1)*60+MINUTE (B1-A1))/60

    den heutigen Kentnissen anzupassen könnte es als Tip betrachten

    folgende Formeln bringen das gleiche Ergebnis:
    lt.Beispiel
    =(B1-A1)*24 Format "Standard" Ergebnis 9,5

    =B1-A1 Format "hh:mm" Ergebnis 9:30

    berechnet Zeiten die über Mitternacht hinaus gehen
    =REST(B1-A1;1)*24 Format "Standard" Ergebnis 9,5

    =REST(B1-A1;1) Format "hh:mm" Ergebnis 9:30

    berechnet Zeiten die über Mitternacht hinaus gehen
    und schreibt erst in die Ergebniszelle wenn Anfangs und Endzeit eingegeben sind
    =WENN((A1*B1);REST(B1-A1;1);"") Format "hh:mm" Ergebnis 9:30

    =WENN((A1*B1);REST(B1-A1;1);"")*24 Format "Standard" Ergebnis 9,5

    die Summenzelle mit "[hh]:mm" formatieren
    Formate natürlich ohne ""

     
  4. seppl2

    seppl2 Byte

    Registriert seit:
    6. Oktober 2000
    Beiträge:
    87
  5. jhilli45

    jhilli45 Byte

    Registriert seit:
    25. Juli 2003
    Beiträge:
    89
    @WHenze:
    Nicht, wenn 1 Tag dazugerechnet wird und die Zellen mit [hh]:mm formatiert werden!

    Annahme:
    A:A = ArbeitsBeginn
    B:B = ArbeitsEnde
    C:C = Arbeitszeit

    in Feld C1, C2,... eintragen:

    =WENN(B1="";"ArbeitsEnde verpennt!";WENN(B1>A1;B1-A1;(B1+1)-A1))
    =WENN(B2="";"ArbeitsEnde verpennt!";WENN(B2>A2;B2-A2;(B2+1)-A2))
    ...

    Als benutzerdefinierte Funktion sieht das z.B. so aus:

    Public Function Arbeitszeit(ArbeitsBeginn, ArbeitsEnde)
    ' Berechnet die Arbeitszeit aus der Differenz von ArbeitsEnde und ArbeitsBeginn
    ' Geht das ArbeitsEnde über 24:00 Uhr hinaus, wird 1 (Tag) addiert
    ' Den Spalten für Arbeitsbeginn und Arbeitsende muß über "Namen / Definieren..."
    ' der Name zugewiesen werden
    '
    ' z.B.:
    ' Spalte B:B = ArbeitsBeginn
    ' Spalte C:C = ArbeitsEnde
    '
    ' Spalte A:A ist für das Datum vorgesehen und braucht nicht benannt zu werden
    ' In Spalte D:D bzw. Feld D1 wird die Formel "=Arbeitszeit(B1;C1)" eingetragen,
    ' in Feld D2 die Formel "=Arbeitszeit(B2;C2)" usw.
    '

    If (ArbeitsEnde = "") Or (ArbeitsEnde = 0) Then
    Arbeitszeit = InputBox("Bitte Arbeitszeit als Std:Min eintragen", _
    "Arbeitsende verpennt? ;)", "8:00")
    Exit Function
    End If
    If (ArbeitsEnde > ArbeitsBeginn) Then
    Arbeitszeit = ArbeitsEnde - ArbeitsBeginn
    Else
    Arbeitszeit = (ArbeitsEnde + 1) - ArbeitsBeginn
    End If
    End Function

    Grüße vom Jürgen
    :fs:
     
  6. doba

    doba ROM

    Registriert seit:
    25. August 2004
    Beiträge:
    2
    irgendwie ist meine Antwort nicht hier gelandet,darum nochmal

    Excel 97/2000/XP/2003: Rechnen mit Stunden und Minuten

    der Tip ist ja schon nen bisschen alt

    13.11.2001 11:49

    wenn man sich wenigsten die Mühe gemacht hätte die alte Bandwurmformel

    =(STUNDE(B1-A1)*60+MINUTE (B1-A1))/60

    den heutigen Kentnissen anzupassen könnte es als Tip betrachten :o

    folgende Formeln bringen das gleiche Ergebnis:
    lt.Beispiel
    =(B1-A1)*24
    Format "Standard" Ergebnis 9,5

    =B1-A1
    Format "hh:mm" Ergebnis 9:30

    berechnet Zeiten die über Mitternacht hinaus gehen

    =REST(B1-A1;1)*24
    Format "Standard" Ergebnis 9,5

    =REST(B1-A1;1)
    Format "hh:mm" Ergebnis 9:30

    berechnet Zeiten die über Mitternacht hinaus gehen
    und schreibt erst in die Ergebniszelle wenn Anfangs und Endzeit eingegeben sind

    =WENN((A1*B1);REST(B1-A1;1);"")
    Format "hh:mm" Ergebnis 9:30

    =WENN((A1*B1);REST(B1-A1;1);"")*24
    Format "Standard" Ergebnis 9,5

    die Summenzelle mit "[hh]:mm" formatieren
    Formate natürlich ohne ""

     
  7. migII

    migII Byte

    Registriert seit:
    22. August 2002
    Beiträge:
    124
    Ich hole den alten Thread mal hoch. :D

    Wie rechne ich die Std/Min aus, die in Zelle A1 bis A31 stehen?
    Quasi so:
    8:00
    8:10
    8:45
    8:05
    -------
    Gesamt 33 Std.

    Fuer Hilfe waere ich dankbar
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen