Excel 97-2003: Zellinhalte bedingt verstecken

Dieses Thema im Forum "Ihre Meinung zu Artikeln auf pcwelt.de" wurde erstellt von MichaL, 20. Juni 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. MichaL

    MichaL Byte

    Registriert seit:
    7. Januar 2005
    Beiträge:
    42
    Für die Unterdrückung von Nullwerten ist =WENN(<Formel> = 0; ""; <Formel>) zuviel des guten, d. h. keine Formel nötig.
    1) Gibt es unter Optionen die Möglichkeit "Nullwerte unterdrücken" grundsätzlich zu aktivieren, und
    2) tut es einfacher ein benutzerdefiniertes Zahlenformat, z. B. 0;0;
    3) Folgt aus der vorgeschlagenen Methode das Problem, dass mit dieser Zelle - falls sie "" enthält - nicht mehr weiter gerechnet werden kann, d. h. es ergeben sich u. U. Folgefehler. :heul:
    Allerdings sollte man sich imer gut überlegen, ob man soetwas in Mappen, die auch andere benutzen sollen, tut. Woher weiss ein anderer, oder man selbst nach Monaten, dass diese Zelle in Wirklichkeit nicht leer ist?
    :) http://dr-luthardt.de
     
  2. catean

    catean Byte

    Registriert seit:
    8. Juni 2005
    Beiträge:
    92
    Nicht unbedingt der Hit. Wert Null kann durchwegs ein Wert sein, so zB zum Weiterrechnen Inventar etc. hier kann der Wert 0 durchwegs einen Sinn haben und darf nicht unterdrückt werden.

    Nehmen wir zB an A1 ist Stückzahl und B1 der Stückpreis. Falls Stückzahl 0 ist dann müsste in C1 (gesamtpreis) stehen:
    =WENN(A1 <>"";(A1*B1);"")
    oder auf deutsch wenn in A1 ungleich nichts, also etwas steht, soll er rechnen A1*A2, sonst soll er nichts schreiben ("")
    Enzo
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen