Excel-Datumsformatierung bei SVERWEIS

Dieses Thema im Forum "Office-Programme" wurde erstellt von thueringer123, 8. Juli 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. thueringer123

    thueringer123 Kbyte

    Registriert seit:
    24. Oktober 2004
    Beiträge:
    247
    Hallo,

    eine Excel-Formatierung gibt mir Rätsel auf.

    Nach der Erstellung einer Tabelle trage ich
    in Zelle C3,4,5... einen Namen ein. In Zelle G3,4,5...
    soll ein zu dem Namen gehöriges Geburtsdatum
    automatisch übernommen werden.

    Beide o.a. Zellen sind verbunden Zellen C3 bis H3
    Sowie I3 bis J3.

    Ich bin folgendermaßen vorgegangen:

    Ich habe Hilfszellen mit allen Namen C107 bis C154
    und Geburtsdaten J107 bis J154 erstellt.

    Mit der Formel =SVERWEIS(C3;$C$107:$J$154;2;FALSCH)

    bekomme ich bei der Zellenformatierung als TEXT die Zahl 0,
    und bei der Zellenformatierung Datum TT.MM.JJ das Datum
    00.01.0 ausgeworfen. :aua:

    Könnt Ihr mir bei der Lösung bitte helfen?
    Ich danke Euch im Voraus.
     
  2. MIKAPet

    MIKAPet Kbyte

    Registriert seit:
    16. Dezember 2003
    Beiträge:
    306
    Hallo thueringer123

    Anstelle der 2 im Spaltenindex der Formel musst du eine 7 eingeben (I3 ist die 7. Spalte rechts von C3.
    Da du die Zellen von C3 bis H3 und die Zellen I3 bis J3 verbunden hast, mag es optisch so erscheinen, dass die Zellen nebeneinander liegen. Intern rechnet Excel aber weiterhin mit nichtverbundenen Zellen, es holt sich in diesem Fall also den Wert aus der nebenliegenden Zelle (D3) und da diese Zelle nichts enthält, wird das Datum 00:01:1900 angenommen, was Excel bei Standardfomat mit 0 anzeigt und bei deiner Formatierung (TT.MM.JJ) halt mit 00.01.00 angezeigt wird.
     
  3. thueringer123

    thueringer123 Kbyte

    Registriert seit:
    24. Oktober 2004
    Beiträge:
    247
    Hi MIKAPet,

    ich danke Dir für diese geniale Lösung. :bet:

    Eigendlich hatte ich schon aufgegeben.

    Gedacht ist die Prozedur für einen ständig wechsenden Manschaftmeldebogen, wo Manschaftmitglieder von der II in die I. Manschaft aufsteigen oder welche von der III. in die IV. absteigen usw.
    Ich war im Grund nur zu "faul" ständig die zu den Namen zugehörigen Daten
    neu zu schreiben bzw. zu kopieren.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen