Excel-Datumsliste (kompliziert?)

Dieses Thema im Forum "Office-Programme" wurde erstellt von Eispirat, 5. Juni 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Eispirat

    Eispirat ROM

    Registriert seit:
    5. Juni 2005
    Beiträge:
    1
    :confused:

    Ich habe ein Anfangsdatum und ein Enddatum.
    Nun will ich eine Liste erstellen, die wie folgt aussieht:
    Von Anfangsdatum bis Ende des Monats
    Danach jeder Monat vom 1. bis letzten
    1. des Monats bis einen Tag vor Enddatum.

    Beispiel:
    Anfangsdatum: 07.11.03
    Enddatum: 26.02.04

    Das Erbebniss sollte so aussehen:
    07.11.03-30.11.03
    01.12.03-31.12.03
    01.01.04-31.01.04
    01.02.04-25.02.04

    Wer kann mir dabei helfen?
     
  2. Beatcounter

    Beatcounter Guest

    Registriert seit:
    25. Januar 2003
    Beiträge:
    313
    da musst du wohl ein makro programmieren
     
  3. MIKAPet

    MIKAPet Kbyte

    Registriert seit:
    16. Dezember 2003
    Beiträge:
    306
    Ich habe mal den Zeitraum vom 1.1.2000 bis 31.12.2015 gewählt.
    Jahr 2000 in
    A1: =Tabelle2!A1
    B2: =Tabelle2!C2
    A4: 1.1.2000
    A5: 2.1.2000
    bis A34: 31.1.2000 ausfüllen
    B4: =WENN(A4=$A$1;A4;"")
    B5: =WENN(A5=$A$1;A5;"") bis B34 ausfüllen
    C4: =WENN(A4=$B$1;$B$1;"")
    C5: =WENN(A5=$B$1;$B$1;"") bis C34 ausfüllen
    B35: =WENN(UND($A$1<=A4;$B$1>=A4);A4;"")
    B36: =WENN(MAX(B4:B35)=0;"";MAX(B4:B35))
    C35: =WENN(UND($A$1<=A34;$B$1>=A34);A34;"")
    C36: =WENN(MAX(C4:C35)=0;"";MAX(C4:C35))

    D4: 1.2.2000
    D5: 2.2.2000
    bis D32: 29.2.2000 ausfüllen
    E4: =WENN(D4=$A$1;$A$1;"")
    E5: =WENN(D5=$A$1;$A$1;"") bis E32 ausfüllen
    F4: =WENN(D4=$B$1;$B$1;"")
    F5: =WENN(D5=$B$1;$B$1;"") bis F32 ausfüllen
    E35: =WENN(UND($A$1<=D4;$B$1>=D4);D4;"")
    E36: =WENN(MAX(E4:E35)=0;"";MAX(E4:E35))
    F35: =WENN(UND($A$1<=D32;$B$1>=D32);D32;"")
    F36: =WENN(MAX(F4:F35)=0;"";MAX(F4:F35))
    Tabelle so bis zum 31.12.2000 erstellen. (Achte bei den Werten in z.B. F35 -->"D32" darauf, dass sich der Bezug auf den letzten des zugehörigen Monats bezieht)
    Für das Jahr 2001 : 2002.......
    A37: 1.1.2001 usw. dto. untereinander ausfüllen.
    In einem neuen Tabellenblatt Tabelle2:
    A1: Anfangsdatum eingeben
    C1: Enddatum eingeben
    C2: =C1-1
    A3: "Anfang" ; B3,B4,B4 usw.: "bis" ; C3:"Ende"
    A4: =Tabelle1!B$36 ; C4: =Tabelle1!C$36 (Für Januar 2000)
    A5: =Tabelle1!E$36 ; C5: =Tabelle1!F$36 (Für Februar 2000)
    solange weiter erstellen, wie nötig ist.
    Wenn diese Tabelle fertig ist, Zelle A3 bis A?(Tabellenende) markieren, Daten, Filter -->Autofilter aktivieren.
    Beim Anklicken auf den Pfeil in "Anfang" Option (Nichtleere) anklicken.
    Sollten nur Zahlen angezeigt werden, unter Format --> Zellen --> Register Zahlen "Datum" auswählen
    Bei Änderung des Anfangs- oder des Enddatums muss allerdings dieses wiederholt werden. (Dieser Schritt lässt sich aber prima mit dem Makrorecorder aufzeichnen und einer Befehlsschaltfläche zuweisen). Sollte es nicht klappen, melde dich mal bei mir. Dann kann ich dir die komplette Datei auch mailen.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen