Excel : Mehr als 8 WENN Verschachtelungen?

Dieses Thema im Forum "Office-Programme" wurde erstellt von thueringer123, 29. Oktober 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. thueringer123

    thueringer123 Kbyte

    Registriert seit:
    24. Oktober 2004
    Beiträge:
    247
    In einem Excel-Formular möchte ich für mehrere Anwender einen Plan darstellen. In diesem Formular sind für die Anwender nur bestimmte Zellen zur Eingabe freigegeben.
    Als Beispiel trägt der Anwender in Zelle B2 den Text „N“ ein und die Zelle B3 wirft die Zahl 12 aus.

    Hier meine Formel in der für die Anwender gesperrten Zelle B3.

    =WENN(B2=$U$24;$V$24;WENN(B2=$U$25;$V$25;
    WENN(B2=$U$26;$V$26;WENN(B2=$U$27;$V$27;
    WENN(B2=$U$28;$V$28;WENN(B2=$U$29;$V$29;
    WENN(B2=$U$30;$V$30;WENN(B2=$U$31;$V$31;""))))))))

    Soweit funktioniert die Formel.
    Die Zellen U24 bis U31(Text) sowie V24 bis V31(feste Größe als Zahl) fungieren als Hilfszellen da diese Einträge feste unveränderbare Größen darstellen.


    Nun zu meinem Problem.

    Ich benötige

    1. In der Zelle B3 eine weitere WENN - Funktion. und
    2. diese WENN - Funktion soll nun wiederum eine variable Zahl
    auswerfen welche der Anwender in Zelle B2 einträgt.
    Diese variable Zahl soll nun auch in Zelle B3 angezeigt werden.

    Frage. Wie löse ich das Problem mit der weiteren WENN-Funktion und wie kann ich mittels einer Formel diese Variable in Zelle B3 darstellen?

    Vielen Dank im Voraus
     
  2. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    Frage: warum benutzt Du nicht einfach die Funktion SVERWEIS ?

    Damit geht's viel einfacher und Du hast keine Beschränkung auf 8 Werte. Ansonsten hilft wohl nur anstelle des "" ein Ergebnis aus einer anderen Zelle, in der Du dann die nächsten Bedingungen abfragst (finde ich aber unschön und umständlich).

    Hoffe, das hilft Dir

    Und tschüx ...
     
  3. juelobe

    juelobe Kbyte

    Registriert seit:
    19. Oktober 2004
    Beiträge:
    249
    dem kann ich nur zustimmen. Man bentutz auch keine 8 Wenn-Verschachtelungen :eek:
    Wehe da ist ein Fehler drin.......dann gute Nacht.

    Gruß
    juelobe
     
  4. thueringer123

    thueringer123 Kbyte

    Registriert seit:
    24. Oktober 2004
    Beiträge:
    247
    Hallo,

    ich habe mit SVERWEIS und auch mit WVERWEIS versucht.
    Klappt beides nicht. Ich komme damit nicht klar. Ich vermute mal,
    dass es daran liegt, dass bestimmte Zellen als Text Formatiert
    sind. Diese Text-Formatierung muß aber zwingend erhalten bleiben.
    :aua:
     
  5. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    Hast Du's mal mit
    =SVERWEIS(B2;$U$24:$U31;1;FALSCH)
    probiert ?
    Soweit ich Dich verstanden habe, handelt es sich bei den Vergleichswerten doch nicht um Zahlen, also dürfte die Textformatierung nicht das Problem sein :confused: :confused:

    Und tschüx ...
     
  6. thueringer123

    thueringer123 Kbyte

    Registriert seit:
    24. Oktober 2004
    Beiträge:
    247
    Danke an alle.

    die Formel SVERWEIS hat geholfen.

    =SVERWEIS(B2;$U$24:$U31;1;FALSCH)

    hab aber noch ein wenig daran herumdocktern müssen, da ich
    selbst mit der Formel noch nie gearbeitet habe.

    also nochmals Dank an alle :jump:
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen