Excel: Monatsersten oder -letzten Ermitteln

Dieses Thema im Forum "Ihre Meinung zu Artikeln auf pcwelt.de" wurde erstellt von Mexcel, 20. September 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Mexcel

    Mexcel ROM

    Registriert seit:
    24. Januar 2003
    Beiträge:
    3
    würde ich diese Lösung nennen, es sei denn, man benötigt das Analyse-Add-In sowieso für andere Funktionen. Die Problemstellung ist auch mit "normalen" Bordmitteln leicht zu lösen, so liefert

    =DATUM(JAHR(HEUTE());MONAT(HEUTE());1)
    den Monatsersten des aktuellen Monats und

    =DATUM(JAHR(HEUTE());MONAT(HEUTE())+1;1)-1
    den letzten Tag des aktuellen Monats.

    Die Datum-Funktion verträgt auch überdimensionierte Argumente, so liefert der Parameter 13 für den Monat keine Fehlermeldung, sondern zählt einfach in den nächsten Januar weiter. Die Heute-Funktion kann natürlich durch einen beliebigen Datumsausdruck ersetzt werden.

    Viele Grüße,
    Mexcel
     
  2. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    und es geht noch einfacher:

    =HEUTE()-TAG(HEUTE()) liefert den Monatsletzten des Vormonats

    =HEUTE()-TAG(HEUTE())+1 liefert demnach den Monatsersten des aktuellen Monats

    =HEUTE()+31-TAG(HEUTE()+31) liefert den Monatsletzten des aktuellen Monats

    und alles ohne Nachinstallation irgendeines AddIns, dass man auf einem anderen PC dann unter Umständen sowieso nicht hat.

    Und tschüx ...
     
  3. migII

    migII Byte

    Registriert seit:
    22. August 2002
    Beiträge:
    124
    Hallo,
    irgendwie funktionieren eure Tips bei mir nicht.
    Es kommt immer #Name?
     
  4. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    Hallo migII,

    vielleicht hast Du Dich verschrieben. Poste doch mal, wie Deine Formeln aussehen, bei denen #NAME? angezeigt wird.

    Und tschüx ...
     
  5. migII

    migII Byte

    Registriert seit:
    22. August 2002
    Beiträge:
    124
    Hallo,
    also ich bin kein Excel Experte.

    Zur Zeit schaut meine Tabelle so aus:
    A10 01.07.2008
    A11 =IF(A10="";"";A10+1)
    A12 =IF(A11="";"";A11+1)
    A13 =IF(A12="";"";A12+1)
    ...
    das ganze geht bis
    A40 =IF(A39="";"";A39+1)

    Hat der Monat nur 30 Tage erscheint bei mir der 1. des nächsten Monats.

    Wie baue ich das nun um?

    Danke
     
  6. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    Hallo,

    für den Fall, dass Du nur die Tage des jeweiligen Monats angezeigt bekommen willst, würde ich das wie folgt machen:

    a10 01.07.2008
    a11 =WENN(A10="";"";WENN(MONAT(A10+1)<>MONAT(A10);"";A10+1))
    usw. bis
    a40 =WENN(A39="";"";WENN(MONAT(A39+1)<>MONAT(A39);"";A39+1))

    Das ist für die deutsche Excel-Version. Du scheinst eine englische Version zu haben, da bei Dir WENN als IF dargestellt wird. Du müsstest das bei Dir austauschen und wahrscheinlich MONAT durch MONTH ersetzen.

    Der eigentliche Tipp für den Monatsersten bzw. -letzten hilft Dir in Deiner Situation nicht unbedingt weiter. Aber auch dort müsstest Du wahrscheinlich HEUTE() durch TODAY() ersetzen und TAG() durch DAY().

    Und tschüx ...
     
  7. migII

    migII Byte

    Registriert seit:
    22. August 2002
    Beiträge:
    124
    Hallo,
    ja ich habe ein englisches Office 2003.
    Hat aber geklappt.

    Danke :)
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen