Excel Summe von Spalte abhängig von 2 anderen Spalten

Dieses Thema im Forum "Office-Programme" wurde erstellt von kobe.xls, 14. April 2006.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. kobe.xls

    kobe.xls ROM

    Registriert seit:
    14. April 2006
    Beiträge:
    4
    Hallo,
    Ich habe leider folgendes Problem:
    Ich habe 3 Spalten (A,B,C). Sagen wir einfachheitshalber, dass in allen 3 Spalten Zahlen stehen. Ich möchte jetzt diejenigen Zahlen in der Spalte C aufsummieren, die einem Suchkriterium, dass sich über die Spalten A und B erstreckt, genügen.
    Beispiel:
    Summiere die Zahlen aus C, wenn in Spalte A (=) 5 und in Spalte B (=) 100 steht.
    Also das ist eine Art 'SUMMEWENN'-Funktion, nur gekoppelt mit 2 Suchkriterien.

    So etwas klappt z.B. nicht: SUMME(WENN(E11:E51=70;WENN(C11:C51="Sa";D11: D51;0);0))

    Ich hoffe, es ist einigermaßen deutlich ausgedrückt.
    Vielen Dank schon mal im Vorraus!
     
  2. Hockeyruls

    Hockeyruls Kbyte

    Registriert seit:
    27. Februar 2006
    Beiträge:
    164
    Hallo.

    So müsste deine Schilderung funktionieren.

    =WENN(UND(A1=5;B1=10);SUMME(A1:B1);0)

    Wenn in A1 5 steht und in B1 10 (Beispiel), dann wird die Summe in C1 gespeichert, ansonsten ist sie 0.
     
  3. kobe.xls

    kobe.xls ROM

    Registriert seit:
    14. April 2006
    Beiträge:
    4
    Das wäre jetzt für eine Zeile. Mache ich es genauso, wenn ich mehrere Zeilen in den Spalten habe?
    Hinzukommt, dass ich die Summe in einer weiteren Zelle speichern möchte. Also die Summe der Zahlen aus C, mit den Bedingungen aus A und B.
     
  4. Hockeyruls

    Hockeyruls Kbyte

    Registriert seit:
    27. Februar 2006
    Beiträge:
    164
    Entweder: Du markierst die komplette Spalte C und klickst auf Bearbeiten / Ausfüllen / Nach Unten.

    Oder: Du kopierst den Befehl Zeile 1 Spalte C mit Strg + C in den Zwischenspeicher, markierst dann die Spalte C und fügst die Formel in die einzelnen Zeilen mit Strg + V ein.

    Klingt etwas kompliziert, ich hoffe du weist was ich meine.
     
  5. kobe.xls

    kobe.xls ROM

    Registriert seit:
    14. April 2006
    Beiträge:
    4
    Also dein Weg geht über eine weiter Spalte, in denen dann entweder die Zahl steht, die den Bedingungen genügt oder 0. Diese kann ich dann aufsummieren. Das wäre ne Möglichkeit. Geht das auch direkt? Also ohne zusätzliche Spalte?
     
  6. Hockeyruls

    Hockeyruls Kbyte

    Registriert seit:
    27. Februar 2006
    Beiträge:
    164
    Oh. Sorry ich hatte dein Problem doch nicht ganz verstanden.

    Also nochmal von vorne. In den Spalten A,B und C stehen irgendwelche Zahlen. Nun möchtest du die Spalten C aufsummieren, wenn A und B entsprechende Anforderungen erfülllen.

    Ich würde zunächst für jede Zeile eine Spalte D einführen mit foldendem Zeileninhalt:

    =WENN(UND(A1=10;B1=5);C1;0) (Beispiel für Zeile 1)

    In der Spalte E (kann auch andere Spalte sein) steht dann die Summenformel, die D aufsummiert:

    =SUMME(D1:D4). (D4, musst du durch die Anzahl der Zeilen ersetzen die du tatsächlich hast!)

    In der Spalte D wird also der Wert C gespeichert, wenn A und B die Bedingungen erfüllen, ansonsten 0. In der ersten Zelle der Spalte E wird dann die Summe der Spalten D gebildet, was das Ergebnis darstellen sollte.
     
  7. First Evangelist

    First Evangelist Kbyte

    Registriert seit:
    19. Juni 2004
    Beiträge:
    333
    Hallo,
    mal sehen ob ich Dich richtig verstanden habe:
    Du hast in 3 Spalte (A, B und C) Werte stehen. Wenn nun beispielsweise der Wert in A3 = 5 ist und gleichzeitig der Wert in B3 = 100 ist, möchtest Du den Wert in C3 zählen. Sollte weiterhin der Wet beispielsweise in A7 = 5 und in B 7 = 100 sein, möchtest Du den Wert aus C 7 zu dem Wert aus C 3 hinzuzählen.

    Wenn dem so ist, dann in
    d1: =WENN(UND(A1=5;B1=100);C1;"")
    und in
    d2:=WENN(UND(A2=5;B2=100);C1+C2;"").
    diesen Wert aus D2 dann nach unten kopieren.

    War es das was Du meintest oder liege ich völlig daneben??

    :confused: FE
     
  8. kobe.xls

    kobe.xls ROM

    Registriert seit:
    14. April 2006
    Beiträge:
    4
    @ First Evangelist: Wenn du mit hinzuzählen aufsummieren meinst, dann hast du es richtig verstanden.

    Ich habe dank Hockeyruls' Anstoß für eine zusätzliche Spalte eben das Problem mit so einer gelöst.
    Lösung:
    In der zusätzlichen Spalte D steht halt immer (fortlaufend) '=WENN(UND(A1="5";B1="100");C1;0)'. Damit kann ich dann D wiederum einfach summieren ('=SUMME(D1 : Dx)').
    Ursprünglich wollte ich eine Lösung, die keine zusätzliche Spalte zum Zwischenspeichern benötigt. Ob dies geht oder nicht, möge mir jetzt mal egal sein. So reicht es völlig aus. Falls doch jemand zufällig dafür ne Lösung bietet, wäre es auch gut, ansonsten belassen wir es so.

    Danke euch
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen