Excel-Tabellen vergleichen

Dieses Thema im Forum "Office-Programme" wurde erstellt von Hornist, 18. Oktober 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Hornist

    Hornist Kbyte

    Hallo,

    mal ne Frage: Ich habe 2 Tabellen (Tabelle A und B). A alle Daten. B enthält einen Teil von A. Wie kann ich nun A mit B vergleichen, und die Zeilen die in A und B gleich sind, aus A löschen (Per Makro oder jedenfalls automatisch)?

    Danke
     
  2. Hallo,


    aus wie vielen Spalten bestehen Deine Tabellenblätter?
     
  3. Hornist

    Hornist Kbyte

    13. Wobei allerdings nur 2 relevant sind.
     
  4. Hi,

    sorry das ich mich erst so spät melde.
    Habe einige Versuche durchgeführt, bin aber zu keinem 'automatisiertem' Ergebnis gekommen, so dass Dir meines Erachtens nur der manuelle Weg bleibt, also beide Tabellen mittels "Daten" / "Sortieren" nach der jeweiligen Spalte sortieren. Dann erkennst Du ja, welche doppelten Einträge bestehen und kannst diese aus Tabelle A löschen.
    Das Sortieren kannst Du allerings durch ein Makro eröedigen, beispielsweise

    Sub Makro1()
    Columns("A:O").Select
    Selection.Sort Key1:=Range("B1"), Order1:=xlAscending, _
    Header:=xlGuess, _
    OrderCustom:=1, MatchCase:=False, Orientation:=xlTopToBottom
    End Sub
    sortiert nach Spalte B. Bei einer anderen maßgeblichen Spalte ändere halt B1 in die entsprechende Spaltenbezeichnung.
    Greetz FE
     
  5. Hornist

    Hornist Kbyte

    Vielen Dank für Deine Bemühungen. Ich hab auch nicht gefunden. Ich machs mittlerweile manuell. Das geht am schnellsten. Denn noch mehr Zeit möchte ich auch nicht investieren.
     
  6. volkerK

    volkerK Byte

    Hallo,
    wie sieht es denn mit der Funktion VERGLEICH aus.
    Die Syntax wäre z.B.:

    =WENN(ISTZAHL(VERGLEICH(Tabelle1!A1;Tabelle2!$A$1:$A$8;0));Tabelle1!A1;"")

    Die Funktion ISTZAHL ist nur dazu da um den Fehlerwert #NV abzufangen.

    So wie ich es jetzt gemacht habe steht die Funktion in Tabelle3 Spalte A Zeile 1-8

    Gruß Volker
     
  7. Hi,

    hab ich gerade ausprobiert. Funzt absolut nicht, weder bei nur einer Spalte, geschweige denn bei 13. - Schade.

    FE :(
     
  8. volkerK

    volkerK Byte

    Hallo ,

    in meinem Beispiel habe ich natürlich nicht die orginal Tabelle ich habe eine mit einer Spalte und 8 Zeilen, wenn ich mehr zB. 13 Spalten habe dann muß ich natürlich bei Tabelle2 als Bereich A1:M8 (bei 8 Zeilen) angeben.
    Es kann auch mit ISTZAHL probleme geben (nur wenn was anderes wiee zahlen drinstehen) , #NV kann man aber auch mit ISTFEHLER abfangen.
    Gruß Volker.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen