Excel - Unterschiedliche Einträge zählen

Dieses Thema im Forum "Office-Programme" wurde erstellt von speax, 7. April 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. speax

    speax ROM

    Registriert seit:
    7. April 2003
    Beiträge:
    4
    Hallo,
    hab in einer Spalte verschiedene Texteinträge (viele auch doppelt), möchte nun in einer Zelle die Anzahl der unterschiedlichen Einträge zählen bzw. anzeigen.
    Vielleicht hat einer ne Lösung parat.

    MfG speax
     
  2. speax

    speax ROM

    Registriert seit:
    7. April 2003
    Beiträge:
    4
    Hallo,

    damit ist mein Problem gelöst, ich danke mkl.

    MfG speax
     
  3. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    Hi,

    versuch doch mal folgendes. Angenommen, Deine Texteinträge stehen in Spalte A, in meinem Beispiel konkret in A1 bis A10. Dann schreibst Du in B1 folgendes hinein:
    =WENN(ZÄHLENWENN($A$1:A1;A1)>1;0;1)
    Dieses kopierst Du in alle Zellen B2 bis B10. Daraus ergibt sich in Spalte B für jedes erste Auftreten eines Wertes eine 1, für jedes weitere Auftreten eine 0. Die Anzahl der verschiedenen Einträge ist dann die Summe der Zellen B1 bis B10.

    Hilft Dir das weiter ?

    Und tschüx
     
  4. speax

    speax ROM

    Registriert seit:
    7. April 2003
    Beiträge:
    4
    dies liefert mir aber nur die anzahl der einträge, beachtet aber nicht die doppelten und zählt die mit.

    Ich bräuchte schon eine Lösung als reine Excel Formel. (ist bestimmt nicht unmöglich)
    MfG speax
    [Diese Nachricht wurde von speax am 07.04.2003 | 18:25 geändert.]
     
  5. castanho

    castanho Kbyte

    Registriert seit:
    4. März 2003
    Beiträge:
    292
    Gibt\'s die Möglichkeit, Access zu benutzen? Man kann die Tabelle einbinden und eine Abfrage darauf laufen lassen.

    SELECT Count(spaltenname) GROUP BY spaltenname;
     
  6. speax

    speax ROM

    Registriert seit:
    7. April 2003
    Beiträge:
    4
    Danke,
    aber das hilft mir auch nicht viel weiter.
    Ich denke, das das größte Problem bei der Formel ist, die gleichen Inhalte nur einmal zu zählen. Für das brauch ich eine Lösung.
    Aber trotzdem Danke.

    MfG speax
     
  7. mici46

    mici46 Kbyte

    Registriert seit:
    10. Juli 2001
    Beiträge:
    174
    "=ANZAHL2(?:?)"
    Zählt wie viele Einträge in deinem Bereich sind. Aber auch doppelte.

    Tschau
    Mici46
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen