Excel:verschieden Spalten und Bedingungen

Dieses Thema im Forum "Office-Programme" wurde erstellt von Lieschen, 23. März 2006.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Lieschen

    Lieschen ROM

    Registriert seit:
    23. März 2006
    Beiträge:
    3
    Hallo,
    ich habe ein Problem mit Excel: Ich würde gerne Zeilen zählen, in denen in der ersten Spalte "20", in der zweiten "-99" und in mindestens zwei der Spalten 3 bis 6 "3" steht.
    Danke für die Hilfe schon mal im Voraus!
     
  2. schwarzm

    schwarzm Viertel Gigabyte

    Registriert seit:
    24. Januar 2005
    Beiträge:
    3.979
    :schieb: nach "Office-Programme"
    Ist hier besser aufgehoben ;)
     
  3. Hockeyruls

    Hockeyruls Kbyte

    Registriert seit:
    27. Februar 2006
    Beiträge:
    164
    Hallo. Ich denke ich hab eine Lösung für dein Problem, wenn auch mit Hilfe einer etwas merkwürdigen Formel.

    Vorraussetzungen:

    Meine Formel gilt wenn die 6 Zahlen die von dir genannt wurden in den Spalten A bis F stehen. Außerdem gehe ich davon aus, dass alle drei Bedingungen erfüllt sein müssen, d.h. in A steht 20, in B steht -99 und in C bis F steht mindestens drei mal die Ziffer 3.

    Die nachfolgende Formel gibst du in eine hintere Spalte ein (z.B. H)

    =WENN(UND(A1=20;B1=-99;ZÄHLENWENN(C1:F1;3)>1);1;0)

    Treffen alle Bedingungen zu, so wird in diese Spalte z.B. H, eine 1 geschrieben, ansonsten 0.

    Nun musst du die 1en einfach mit einer Summenformel aufsummieren. Wenns Probleme gibt oder nicht ganz klar ist, dann kannst ja nochmal fragen.
     
  4. Lieschen

    Lieschen ROM

    Registriert seit:
    23. März 2006
    Beiträge:
    3
    Danke! An sich funktioniert das ganz gut, aber, vielleicht stelle ich mich jetzt gerade besonders doof, aber ich habe ja über 900 Zeilen, und wenn ich das dann für jede einzeln mache...
    Wie sage ich ihm denn, dass er das gleich für alle machen soll?
     
  5. Hockeyruls

    Hockeyruls Kbyte

    Registriert seit:
    27. Februar 2006
    Beiträge:
    164
    Ich geh davon aus, dass du meinst, wie er die 1 oder 0 für jede Zeile schreiben soll. Du hast die Formel zur Berechnung der 0 oder 1 in die Spalte H bspw. geschrieben. Klicke also auf die Spalte und dann Strg+C (Kopieren). Nun markierst du alle weiteren Zeilen, wo dieser Prüfwert eingetragen werden soll und dann Strg+V (Einfügen). Anschließend machst du eine Summenformel z.B. SUMME(H1:H1000), welche die Prüfwerte aufsummiert.
     
  6. Lieschen

    Lieschen ROM

    Registriert seit:
    23. März 2006
    Beiträge:
    3
    Funktioniert leider wieder nicht so, wie ich will, weil in der Formel ja immer nur die erste Zeile betrachtet wird, und dann ich ja immer das gleiche Ergebnis bekomme...
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen