Excel - Zelladressierung

Dieses Thema im Forum "Office-Programme" wurde erstellt von deanman, 19. März 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. deanman

    deanman Byte

    Registriert seit:
    11. April 2001
    Beiträge:
    17
    Hallo zusammen,

    ich brüte seit Tagen an einem Excel-Problem:

    Täglich importiere ich eine Tabelle mit jeweil unterschiedlicher Länge aber identischer Breite in ein formatiertes Arbeitsblatt. Um die hinterlegten Formeln nicht jeweils auf per Hand anpassen zu müssen suche ich einen "Automatismus" jedoch keine Makrolösung.

    Gibt es eine Möglichkeit die Zelladressierung "dymanisch" durchzuführen?

    In Zelle B2 schreibe ich per Hand die Nummer der letzten Zeile: z.B. 1.234

    Dann hätte ich gerne, dass die Formel
    =MITTELWERT($A$8:$E$"B2")

    das ganze umwandelt in
    =MITTELWERT($A$8:$E$1234)


    So, und "mein Formelversuch"
    =MITTELWERT($A$8:$E$"B2")
    klappt natürlich nicht.

    Weiß jemand eine Lösung?

    Danke im voraus
    Chris
     
  2. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    Na klar,

    das Geheimnis ist die Funktion BEREICH.VERSCHIEBEN. Damit kannst Du Teile aus einer Spalte (oder Zeile) "herausschneiden",
    z.B. mit der Anweisung

    =MITTELWERT(BEREICH.VERSCHIEBEN($A:$E;7;0;$B$2-7;5))

    verschiebst Du den Bereich $A:$E um 7 Zeilen nach unten und um 0 Spalten nach rechts (fängt also bei $A$8 an) und der Bereich besteht aus ($B$2-7) Zeilen und 5 Spalten.

    Das war's doch, was Du wolltest, oder ???

    Und tschüx ...
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen