Excel

Dieses Thema im Forum "Office-Programme" wurde erstellt von kn, 9. Mai 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. kn

    kn Byte

    Registriert seit:
    2. März 2003
    Beiträge:
    80
    Hallo,
    gibt es eine Möglichkeit in der folgenden Array Formel die Abfrage "Bücher" durch einen Zellbezug zu ersetzen? Und wie muss die Formel dann aussehen?
    Beispiel:
    {=SUMME(WENN(Berlin04!$A$4:$A$980="Bücher";Berlin04!$C$4:$C$980;0))}

    Bei der Funktion Zählewenn funktioniert das mit "&A4" zum Beispiel.
    Danke.
     
  2. Gast

    Gast Guest

    Klar gehts auch ohne die $ Zeichen in $A$1, wenn Du dann aber die Formel in andere Zellen kopierst, dann wandert Dein Ausgangswert entsprechend.

    MfG
    Vimes
     
  3. kn

    kn Byte

    Registriert seit:
    2. März 2003
    Beiträge:
    80
    Hi,
    großen Dank an mkl!!

    Ich konnte mich von den Anführungszeichen nicht lösen, das war der Fehler!
    Es geht übrigens auch ohne die Absolut-Zeichen($)!
    Nochmals vielen Dank!
    kn
     
  4. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    Lange Rede, kurze Antwort:

    Natürlich geht das:

    {=SUMME(WENN(Berlin04!$A$4:$A$980=$A$1;Berlin04!$C$4:$C$980;0))}

    Es wird dann mit dem Wert in A1 verglichen. Die beiden $ sind wichtig, damit immer der Wert in A1 genommen wird.

    Alles klar ???

    Und tschüx ...
     
  5. mschuetzda

    mschuetzda Megabyte

    Registriert seit:
    5. September 2001
    Beiträge:
    1.131
    @kn,
    das PCW-Forum hat:
    Benutzer: 106,038, Themen: 123,543, Beiträge: 976,584

    und ist demnach auch nicht hilfreich! Trotzdem stellst Du eine Frage hier rein ?
    Da Excel erfahrungsgemäß hier nicht sehr oft vorkommt, finde ich, dass ghost rider Dir einen guten Tipp gegeben hat!
    Warum Du ihn deswegen anmachst, verstehe ich aber nicht.

    Du kannst eine Antwort auf Deine Frage wahrscheinlich wirklich eher bei Herber oder im Office-Forum: http://www.ms-office-forum.net/forum/ bekommen.
    Ich kenne mich zwar mit Excel auch einigermaßen aus, weiss aber auch keine Antwort auf deine Frage.
     
  6. ghost rider

    ghost rider Megabyte

    Registriert seit:
    23. März 2002
    Beiträge:
    2.319
    Hi,

    mein Antwort war ja nicht böse geimeint, aber ich würde halt eben Deine Anfrage so stellen, daß Du eine Funktion mit "=& blabblabla" stellst.... da sollte sich auf der von mir verlinkten Seit allgemien was finden, was Du für Dich anpassen kannst.
     
  7. kn

    kn Byte

    Registriert seit:
    2. März 2003
    Beiträge:
    80
    Hi,
    und wo nach wuerdest Du suchen?
    Nach Summewenn oder nach Array Formeln. Das hilft alles nicht weiter.
    Wie waere es mit einer klaren Antwort auf die Frage, naemlich ob ein Zellverweis in einer Array Formel ueberhaupt zulaessig ist und wenn ja mit welche Trick! In der Funktion Zaehlewenn ist es das & und nun versuch mal das in der Excel Hilfe oder in dem Herber Excel Forum zu finden!
    Sorry, aber Verweise auf irgendwelche Foren sind wenig hilfreich.
    kn
     
  8. ghost rider

    ghost rider Megabyte

    Registriert seit:
    23. März 2002
    Beiträge:
    2.319
    @kn:

    Ähm sorry, aber für was gibt eine Suchfunktion auf dieser Seite?
    Wenn ich weniger auskunftsfreudig gewesen wäre, hätte ich Dich ausschließlich auf "googel" verwiesen. Ein bisschen Eigeninitiative kann man ja wohl noch erwarten.....
     
  9. kn

    kn Byte

    Registriert seit:
    2. März 2003
    Beiträge:
    80
    Hi,
    das Excel Forum hat ca. 420.000 Beitraege, der Verweis darauf ist wenig hilfreich!
    kn
     
  10. ghost rider

    ghost rider Megabyte

    Registriert seit:
    23. März 2002
    Beiträge:
    2.319
    HI,

    beim Excel-Papst solltest Du eine Lösung finden.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen