Excel97: Wenn-Funktion/Datumswiedergabe

Dieses Thema im Forum "Office-Programme" wurde erstellt von HSuttor, 26. Juni 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. HSuttor

    HSuttor Byte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    14
    Excel97: Wenn-Funktion zur Wiedergabe von Datum und Uhrzeit

    Hallo!

    Wenn-Funktion die in Zelle A1 Datum (tt.mm+Uhrzeit) abbildet für den Fall, dass in B1 irgend etwas steht (Text oder Zahl oder beides)

    Wie müsste eine solche Funkton aussehen.

    Freundliche Grüße

    Helmut
     
  2. Geertakw

    Geertakw Kbyte

    Registriert seit:
    25. Februar 2001
    Beiträge:
    418
    Hi
    Anbei ein Makro, der das Datum einer Änderung im Feld rechts davon protokollieren kann

    Dim chflag As Boolean
    Sub Worksheet_Change(ByVal Target As Range)
    If chflag = False Then
    chflag = True
    znr = Target.Row
    zln = Target.Column
    ActiveSheet.Cells(znr, zln + 1).Value = Date
    Else
    chflag = False
    End If
    End Sub

    chflag verhindert, das der Eintrag des Datum als Änderung zum recursiven Aufruf führt und damit den Rest der Zeile mit dem Datum füllt.
    Vielleicht ist das ja ein erster Ansatz - man könnte natürlich noch
    den Bereich in dem geändert wurde und und und......

    Gruss
    Geert
     
  3. HSuttor

    HSuttor Byte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    14
    Hallo Mathias,

    eine ähnliche Funktion hatte ich schon

    =wenn(istleer(B1);"leer";heute())

    Ich brauche eine Funktion, die Datum/Uhrzeit zu dem Zeitpunkt des Eintrags in der Bezugszelle B1 festhält, quasi einfriert. Ich will also wissen, wann ich den Eintrag gemacht habe, wenn ich zwei Tage später die Datei wieder benutze.

    Es müsste also eine Funktion sein, die deinen Vorschlag mit einer nachgelagerten Kopierfunktion, die Wert und nicht mehr die Funktion kopiert.

    Trotzdem Danke.

    Freundliche Grüße
    Helmut

    Deien Formel führt dazu, dass
     
  4. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    Hallo,

    z.B. so:
    =WENN(B1<>"";JETZT();"")

    Die Zeile A1 muß dann mit dem Format TT.MM. hh:mm versehen werden.

    Hoffe, das hilft Dir weiter

    Und tschüx
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen