excelformel: von bis.

Dieses Thema im Forum "Office-Programme" wurde erstellt von djobst, 26. März 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. djobst

    djobst Kbyte

    Registriert seit:
    19. September 2000
    Beiträge:
    371
    Guten Tag Alle.
    wenn in Zelle A1 ein wert steht,der grösser Null;kleiner/gleich 5,4 ist, dann soll in B1 ein "Text1" erscheinen.

    Weiter: a1 grösser 16,2 aber kleiner 21,4; soll in b1 ein "Text2" stehen.

    Es ist also immer ein wert "von bis" der durch den text kommentiert wird.

    Die texte leg ich in andere zellen.

    weiss jemand eine listige formel?

    Danke.gruss dieter
     
  2. djobst

    djobst Kbyte

    Registriert seit:
    19. September 2000
    Beiträge:
    371
    Hallo Fritz, ich kriegs nicht gebacken; entweder ich bin blind oder vernagelt (oder doch blöd?)

    "= SVERWEIS(A1;A2:B6;2;WAHR)"

    =WENN(REST(A1;42,96)=0;42,96;REST(A1;42,96))

    es soll sein:
    0 - 5,37 "A"
    16,12 - 21,48 "B"
    21,49 - 26,85 "C"
    37,60 - 42,96 "D"
    42,97 - 48,33 "E"

    alles was nicht a,b,c,d,e, ist, heisst "x"

    mit der obigen formel wird mit A1= 123,52 bei 37,60 "X" angegeben.

    Wo hab ich da den fehler?
     
  3. djobst

    djobst Kbyte

    Registriert seit:
    19. September 2000
    Beiträge:
    371
    Naja, ein kleiner kinken ist doch noch;

    ein wert ist 37,60 der eigentliche text dazu erscheint aber erst bei 37,61....

    der wert zwischen 26,86 und 37,59 soll text8 zugeordnet sein.

    hm
     
  4. djobst

    djobst Kbyte

    Registriert seit:
    19. September 2000
    Beiträge:
    371
    Dank auch dir nochmals; das prob ist gelöst.
    gruss djobst
     
  5. djobst

    djobst Kbyte

    Registriert seit:
    19. September 2000
    Beiträge:
    371
    Problem gelöst !!!
    Jau Fritz, jetzt klabbet.Mit deinem vorschlag. :) :) :)

    Ich hatte das mit den leerzeichen irgendwie missverstanden.
    Die matrix ist auch noch ein bisschen länger geworden-ich musste also ein wenig SELBST überlegen.

    Ich danke dir. Falls du das ergebnis sehen willst + wofür der ganze aufwand, lass es mich wissen.
    [Diese Nachricht wurde von djobst am 27.03.2002 | 18:12 geändert.]
    [Diese Nachricht wurde von djobst am 27.03.2002 | 18:13 geändert.]
     
  6. 1995

    1995 Kbyte

    Registriert seit:
    20. November 2000
    Beiträge:
    128
    Wenn der Kommentar "falsch" erscheint, hast Du die Formel von Tschosta nicht korrekt eingegeben.

    Deine Zusatzfrage wegen eines Wertes zwischen 5,4 und 16,2 bei dem Text8 erscheinen soll:

    Hier ist eben die Funktion SVERWEIS hilfreich.
    Nimm nochmal mein obiges Beispel ("= SVERWEIS(A1;A2:B6;2;WAHR)"):

    Die Tabelle (A2:B6) hat zwei Spalten und 5 Zeilen. In der ersten Spalte stehen die Vergleichswerte, in der zweiten die Texte, die zurückgegeben werden sollen:
    In A2 steht 0; in B2 ein Leerzeichen
    In A3 steht 0,1; in B3 Text1
    In A4 steht 5,5; in B4 ein Leerzeichen bzw. Text8
    In A5 steht 16,3; in B5 Text2
    In A6 steht 21,5; in B6 ein Leerzeichen

    Die Funktion "= SVERWEIS(A1;A2:B6;2;WAHR)" macht nun folgendes:
    Sie nimmt den Wert A1 (z.B. 10,3) und sucht in der ersten Spalte der Tabelle (Zellen A2 bis A6), bis sie den letzten Wert findet, der kleiner oder gleich A1 ist (in diesem Fall A4 = 5,5; denn A5 = 16,3 ist größer als A1). Aus der Zeile 4 wird der Wert der zweiten Spalte zurückgegeben (B4 = Leerzeichen,d.h. kein Text bzw. Text8).

    Im übrigen ist SVERWEIS in der Excel-Hilfe gut beschrieben.

    mfg Fritz Weinel
     
  7. djobst

    djobst Kbyte

    Registriert seit:
    19. September 2000
    Beiträge:
    371
    Sehe ich auch so,Fritz.

    Wie du ja siehst, bin ich recht unerfahren a) in mathe, B) in excel. (vv)

    Ich kam mit deinem vorschlag irgendwie nicht zurecht, liegt aber daran, dass ich mich nicht klar genug ausdrücke.....
     
  8. djobst

    djobst Kbyte

    Registriert seit:
    19. September 2000
    Beiträge:
    371
    hallo chancen !

    danke dafür. habe deinenvorschlag benutzt.

    Frage nun: wenn ein wert dazwischen auftaucht - zb. zwischen 5,4 und 16,2 -
    steht jetzt als kommentar "falsch" wie kann ich den ersetzen durch einen "text8" ?

    Danke.

    Und danke auch an fritz
     
  9. chancen

    chancen Kbyte

    Registriert seit:
    3. Juli 2001
    Beiträge:
    203
    Hallo Fritz,
    natürlich hast Du recht, dass eine Matrixformel wie sverweis viel leistungsfähiger ist. Ich kenne mich mit Excel seit Version 2.01 (DOS) recht gut aus. Ich hab nur mit meinem Vorschlag versucht, die Frage von djobst wörtlich zu beantworten.
    Hauptsache Ihm ist geholfen. Schönen Abend noch.
    Gruss Tschoko
     
  10. 1995

    1995 Kbyte

    Registriert seit:
    20. November 2000
    Beiträge:
    128
    Dein Vorschlag ist einfacher, wenn es nur um wenige Varianten geht. Mit SVERWEIS kann mann jedoch aus einer Tabelle (Matrix) beliebig viele Varianten herausfiltern.

    mfg Fritz Weinel
     
  11. chancen

    chancen Kbyte

    Registriert seit:
    3. Juli 2001
    Beiträge:
    203
    Hallo djobst,

    noch ein anderer Vorschlag(nichts gegen Fritz):

    =WENN(UND(A1>0;A1<=5,4);"Text1";WENN(UND(A1>16,2;A1<21,4);"Text2";""))

    Gruß Tschoko
     
  12. 1995

    1995 Kbyte

    Registriert seit:
    20. November 2000
    Beiträge:
    128
    Schreibe in die Zellen A2 bis A6 die Zahlen 0; 0,1; 5,5; 16,3 und 21,5.
    und in die Zellen B2 bis B6: Leerzeichen; Text1; Leerzeichen; Text2; Leerzeichen.
    Dann muß die Formel in B1 heißen: "= SVERWEIS(A1;A2:B6;2;WAHR)".

    mfg Fritz Weinel
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen