Firebird, Javascript gehtnichganz

Dieses Thema im Forum "Browser" wurde erstellt von Hummer, 17. Januar 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Hummer

    Hummer Megabyte

    Registriert seit:
    21. November 2002
    Beiträge:
    2.241
    Nabend, heute mal wieder eine doofe Frage, aber die sollen ja oft die besten sein:
    Wenn ich so mit dem Firebird rumsurf komm ich ab und an auch mal auf Seiten mit Javascriptelementen.
    z.B. dieses wahrscheinlich allseits bekannte nette "Gedankenleser"-Spielchen auf http://home.arcor.de/der-stefan/NeueHp/Gedankenleser.htm
    DAS wird aber vom Firebird höchst unvollständig angezeigt.
    Opera (und IE....) zeigen das Javascriptelement korrekt (und spielbar) an.
    Die Javascript-Konsole zeigt auch brav den Fehler an: sym is not defined Quelldatei blabla Zeile28
    Muss das sein?
    Ich tipp mal diletantisch, dass das script unsauber geschrieben ist und Firebird bisserl pingelig ist.....
    Gibts eine Möglichkeit Firebird zu überreden das Javascript anzuzeigen? (die Konkurrenz kanns doch auch)
    THX
    H.
    PS.:javascript ist natürlich aktiviert;)
     
  2. Dex2000

    Dex2000 Byte

    Registriert seit:
    8. Januar 2004
    Beiträge:
    21
    Sorry, hab ich erst später gesehn
    Nimm's einfach als Antwort auf Dein "oder?" :)
     
  3. Hummer

    Hummer Megabyte

    Registriert seit:
    21. November 2002
    Beiträge:
    2.241
    :zzz:
    Häh? Lies mal den Thread vollständig.
    War alles geklärt.
     
  4. Dex2000

    Dex2000 Byte

    Registriert seit:
    8. Januar 2004
    Beiträge:
    21
    Oh die selbst ernannten Experten.
    2 Sachen: JAVA von Sun oder die verbugte MS-VM-Version haben mit JavaScript in etwa so viel zu tun, wie - ähm - Du ahnst es schon: Genau, NIX.

    Das Problem lösen kannst Du, indem Du dem Autor der betreffenden Seite eine Mail schreibst, in der Du ihn höflich und sachlich drauf hinweist, dass er doch nochmal schauen soll wo er Mist gebaut hat.
     
  5. Hummer

    Hummer Megabyte

    Registriert seit:
    21. November 2002
    Beiträge:
    2.241
  6. Gast

    Gast Guest

    Zu alt du bist, um mit der Ausbildung zu beginnen. Ja, zu alt du bist.

    :vader:
     
  7. Hummer

    Hummer Megabyte

    Registriert seit:
    21. November 2002
    Beiträge:
    2.241
    Bis source Hummer in sich spürt viel Hummer noch lernen muss.
     
  8. Gast

    Gast Guest

    Nein. Du kannst auch am Firebird mitwirken und fürs nächste Release einen Patch coden, der auch dem FB erlaubt, fehlerhaftes JS zu interpretieren, damit er dann auch so unsicher wird wie der IE.
    May the source be with you.
     
  9. Hummer

    Hummer Megabyte

    Registriert seit:
    21. November 2002
    Beiträge:
    2.241
    siryessir.
    ad1) Thx. Isklar wurde ja auch mit ähnlichen Worten im anderen Thread so dargelegt.
    ad2) "Ich tipp mal diletantisch, dass das script unsauber geschrieben ist und Firebird bisserl pingelig ist....." sachichdoch

    adad 2)Muss ich mich jetzt also, wie befürchtet, damit abfinden, dass IE und Opera unsaubere Javascripts anzeigt und Firebird NICHT?:heul::heul:
     
  10. Gast

    Gast Guest

    Flachs.
    Bei bestimmten ZIP-Installversionen des Browsers wird ein bestimmter Schlüssel in der Registry nicht angelegt, den aber das Java-Plugin sucht und erwartet.
    Zum Ausgangsposting mit dem Fehler auf der Gedankenleser-Seite:
    Es ist ganz einfach: Das JavaScript ist fehlerhaft.
    Mozilla merkt das, IE nicht. Das ist einer der Gründe, warum man dem IE soviel Malware unterschieben kann, die er dann brav installiert.
     
  11. Hummer

    Hummer Megabyte

    Registriert seit:
    21. November 2002
    Beiträge:
    2.241
    okok
    ich hab kein Problem zuzugeben, dass ich nicht allzuviel Ahnung hab, aber beim rumstöbern/lesen in den diversen Threads hier mein ich doch verstanden zu haben, dass das JAVA-Plugin für die Darstellung von JAVA-Applets zuständig ist (dampfende Tasse) und das javascriptelemente damit nix zu tun haben...
    Oder?
    Ich bin ja noch jung, ich lern gern dazu......:confused:
     
  12. fabifri

    fabifri Halbes Megabyte

    Registriert seit:
    29. April 2003
    Beiträge:
    667
    das JAVA-Plugin hat einfach ein problem darum geht es nicht.
    der bugfix repariert dass.
    mfg
     
  13. Hummer

    Hummer Megabyte

    Registriert seit:
    21. November 2002
    Beiträge:
    2.241
    ...sorry, das war ein bisschen missverständlich: Das in dem einen Thread beschriebene Problem (Stern, Gehaltsberechnung) gibts mit meinem "ollen" Plug-In nicht. Das heisst auch ohne DLLs-Verschiebung und Registryeintrag funzts.
    Nach der Devise "Never change a running System" werd ichs auch erstmal so lassen mit dem Plug-In. :D

    Aber zu meiner ursprünglichen Problematik: Wie kann ich Firebird überreden fehlerhaften javascript darzustellen ?
    :confused:
     
  14. fabifri

    fabifri Halbes Megabyte

    Registriert seit:
    29. April 2003
    Beiträge:
    667
    ist doch ganz klar
    du hast ein JAVA problem, dann brauchst du auch eine JAVA-Problemlösung:p

    also: Java von SUN runterladen, die DLL?s von JAVA in den Plugin-Ordner kopieren und dann den registryfix ausführen --> neustert von Fierbird und siehe da es geht
     
  15. Hummer

    Hummer Megabyte

    Registriert seit:
    21. November 2002
    Beiträge:
    2.241
    Ich denk das Ding von SUN heisst JRE und das Dings von MS VM???
    VM von SUN??
    Das Downloaden könnte bei mir ein bisschen dauern mit 56K....:heul:
    Werds über kurz oder lang aber doch mal probieren, THX.
    Auch dass mit den DLLs und registry.
    Aber was mein Javascriptproblem mit dem JAVA-Plugin zu tun hat weiss ich immer noch nicht......
    :confused:
     
  16. Hummer

    Hummer Megabyte

    Registriert seit:
    21. November 2002
    Beiträge:
    2.241
    THX, wenn ich mir das so durchlese....
    1. Hat mein javascriptproblem was mit dem JAVA-Plug-In zu tun?
    (Colonel Steele bemerkt treffenderundpassenderweise doch öfters an, dass Java und javascript nixgleich)
    2. Ich hab "noch" 1.4.1._01, trifft dann die im Thread beschriebene Problematik überhaupt auf mich zu?
    :confused: :confused:
     
  17. Wolfgang77

    Wolfgang77 Ganzes Gigabyte

    Registriert seit:
    1. Oktober 2002
    Beiträge:
    20.804
    Hallo,

    die Konkurrenz ist ja auch besser und keine Beta-Software mehr. Musst du warten bis der Firebird mal bis zur 1.0 kommt..
     
  18. whisky

    whisky Ganzes Gigabyte

    Registriert seit:
    1. Oktober 2001
    Beiträge:
    11.014
    Ich würde es einfach mal ausprobieren.

    Installier die neue Java RE von Sun - kopier die dlls in den Plugin Ordner und installier den Registryfix.

    :aua:

    Edit: Hab das ding gerade ausprobier - funkt nicht - da ist ein Fehler auf der Seite was dem IE anscheinend egal ist
     
  19. whisky

    whisky Ganzes Gigabyte

    Registriert seit:
    1. Oktober 2001
    Beiträge:
    11.014
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen