Firewire unter SuSE 7.3

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von BruteForce, 10. Juli 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. BruteForce

    BruteForce Byte

    Registriert seit:
    21. September 2000
    Beiträge:
    48
    Hallo,
    ich hätte da mal ein Problem: Ich hab mir ne Firewire-Karte gekauft, die den eigentlich am meisten verbreitesten OHIC-Chip besitzt. Nun gut, wenn ich mit modprobe die nötigen Kernel module (ieee1394, ohic1394, raw1394, und video1394) geladen hab, schein alles zu funktionieren. Mit dmeg sehe ich auch, dass er meine Sony-Kamera erkannt hat, und reagiert auch wenn ich sie wieder ausschalte, also eigentlich völlig korrekt. Blos wenn ich mit dvgrap das Band auf die Platte laden will, meldet er, das er das Gerät nicht ansprechen kann, und dass vermutlich das ieee1394-Modul nicht richtig geladen ist. Aber das ist es leider. Helft mir, ich will nicht immer in Windows gehen, um Videos zu bearbeiten (in Windows funktionierts, mal abgesehen von den üblich Hängern, also Karte und Kamera funktionieren).

    Danke schon einmal im voraus,
    Richard
     
  2. BruteForce

    BruteForce Byte

    Registriert seit:
    21. September 2000
    Beiträge:
    48
    Danke,
    der Kernel ist jetzt 2.4.16, funktioniert aber eider immer noch nicht. dvgrab gibt mir den Fehler aus, das /dev/raw1394 nicht existiert, obwohl in dmesg steht: raw1394: /dev/raw1394 device initialized

    Kann man das irgentwie mit der Hand erzeugen, oder wie bekommt man das hin, das er das erstellt.
     
  3. UglyKidJoe

    UglyKidJoe Byte

    Registriert seit:
    9. Februar 2002
    Beiträge:
    119
    Hallo,

    hier ist ein Link, der dir bei einem Kernel-Update vielleicht weiterhilft.
    http://sdb.suse.de/de/sdb/html/ftpkernel.html

    mfg

    Joe
     
  4. quereller

    quereller Kbyte

    Registriert seit:
    22. Juni 2001
    Beiträge:
    277
    Richtig das modul sbp2 ieee1394 und ohci1394.
    Dann kanst du die platte als sd ansprechen.
     
  5. BruteForce

    BruteForce Byte

    Registriert seit:
    21. September 2000
    Beiträge:
    48
    Schön, ich bin in Linux nicht so bewandert, wie installiert man nen neuen Kernel????

    Trotzdem Danke
     
  6. BruteForce

    BruteForce Byte

    Registriert seit:
    21. September 2000
    Beiträge:
    48
    Habs probiert, kann aber ieee1394 nicht entladen, device busy, auch wenn ich die Kamera ausschalte und warte. Funktioniert auch nicht, wenn ich nur die restlichen entlade und wieder lade. Ich glaub, dass man für festplatten noch das Modul sbp2 braucht, keine Ahnung ob du das geladen hast. Werd mir jetzt mal die neusten treiber besorgen und dann weiterschauen.
     
  7. UglyKidJoe

    UglyKidJoe Byte

    Registriert seit:
    9. Februar 2002
    Beiträge:
    119
    Hallo,

    in einer der Ausgaben der Zeitschrift Linux-User am Anfang des Jahres stand drin, dass der von Suse angepasste Kernel der 7.3 Distri ziemliche Macken in Sachen FireWire hat. Die empfehlen ein Update auf den aktuellen Kernel.

    mfg

    Joe
     
  8. quereller

    quereller Kbyte

    Registriert seit:
    22. Juni 2001
    Beiträge:
    277
    Versuch mal die module (ieee1394, ohic1394, raw1394, und video1394) mit rmmod rauszuschmeissen, und dann mit modprobe nochmal zu laden, versuchs mehrmals wenns nicht klappt.
    Bitte gib mir bescheid obs so funktioniert, hatte nämlich gestern einn ähnliches problem mit einer firewire-hd.

    MfG
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen