Formel für Excel-Tabelle, zählen

Dieses Thema im Forum "Office-Programme" wurde erstellt von tim.balduin, 4. Januar 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. tim.balduin

    tim.balduin Byte

    Registriert seit:
    26. August 2002
    Beiträge:
    11
    Hi,
    ich habe folgendes Problem.
    In einer Monatstabelle muß ich die anwesenheit mehrerer Personen zählen. Die Tabelle ist vereinfacht so aufgebaut,
    in den Spalten stehen die Wochentage, in den Zeilen die Personen.

    ...:....a....:....b....:....c....:....d....:....e....:....f....:....g....:....h....:....i....:
    1.:...mo...:...di....:...mi...:...do...:...fr....:...mo..:...di....:...mi...:.........:
    2.:..........:...gt....:....x....:.........:....x....:....x....:.........:....x....:....2...:
    3.:.....x...:..........:....x....:....x...:..........:...waf..:...x....:..........:....1...:

    Z.B. soll in der Spalte i die Anwesenheit Am Mittwochen gezählt werden (c2 und h2),also 2 mal.
    Leider bekomm ich keine funktionierende Formel dafür hin. Ich hoffe jemand von den Profis kann mir da einen Tipp geben.

    MfG
    tim
    [Diese Nachricht wurde von tim.balduin am 04.01.2003 | 09:31 geändert.]
     
  2. tim.balduin

    tim.balduin Byte

    Registriert seit:
    26. August 2002
    Beiträge:
    11
    Hallo ghostrider,

    hier meine Lösungsformel

    =SUMME(WENN(($A$6:$AG$6="So")*(A7:AG7<>"");1))

    es handelt sich bei dieser Formel um eine Matrixformel und muss mit [Strg]+[Shift]+[Return] abgeschlossen werden (WICHTIG).
    Wenn jemand an der Tabelle Interesse hat, kann ich sie ihm per E-Mail schicken.

    MfG
    tim
     
  3. ghost rider

    ghost rider Megabyte

    Registriert seit:
    23. März 2002
    Beiträge:
    2.319
    Hallo tim,

    bitte poste doch Deine Lösung noch ins Forum, damit für alle User mit dem gleichen Problem diese ebenfalls zur Verfügung steht. Vielen Dank.

    mfg ghostrider
     
  4. tim.balduin

    tim.balduin Byte

    Registriert seit:
    26. August 2002
    Beiträge:
    11
    Hallo @all,
    für eure schnelle Hilfe möchte ich mich sehr bedanken. Durch eure anregungen und einer Formel von www.excelformeln.de, die ich dann modifizieren konnte, habe ich das Problem gelöst.

    MfG
    tim
     
  5. lpofo

    lpofo Byte

    Registriert seit:
    25. März 2001
    Beiträge:
    74
    Hab\' meinen Lösungsversuch auf: http://www.bgbrgleibnitz.at/~lpofo/Zaehlen.xls hochgeladen.
     
  6. V99

    V99 ROM

    Registriert seit:
    4. Januar 2003
    Beiträge:
    2
    Tim ich schicke dir eine Tab. die ich benutze

    V99
     
  7. ghost rider

    ghost rider Megabyte

    Registriert seit:
    23. März 2002
    Beiträge:
    2.319
    Hallo Tim,

    nur so ein Gedanke: geht es eventuell über eine Vergleich-Funktion kombiniert mit einem Zähler, also wenn du die Namen der Personen als Variablen deklarierst und dann mit IF(Zeilen/Spalten)=(Name1) Or (Name2).... usw. then (Counter 1 , 2 usw.) =Variable+1 ... so mal vom Prinzip her...?

    Ansonsten wäre die Homepage vom "Excel-Pabst" eine gute Quelle für Dich: http://www.herber.de

    mfg ghostrider
    [Diese Nachricht wurde von ghost rider am 04.01.2003 | 11:30 geändert.]
     
  8. tim.balduin

    tim.balduin Byte

    Registriert seit:
    26. August 2002
    Beiträge:
    11
    Hallo V99,
    das Problem ist das ich im Beispiel nur die "x" an bestimmten Tagen, z.B. alle Montage, zählen muss. Mit ZÄHLENWENN geht es bei mir leider nicht.

    Gruß
    tim
    [Diese Nachricht wurde von tim.balduin am 04.01.2003 | 11:25 geändert.]
    [Diese Nachricht wurde von tim.balduin am 04.01.2003 | 11:25 geändert.]
     
  9. V99

    V99 ROM

    Registriert seit:
    4. Januar 2003
    Beiträge:
    2
    Hey Tim!
    Du musst die Formelfunktion "Zählenwenn" benutzten, so z.B.
    =ZÄHLENWENN(B4:AF4;"x"). Du kannst statt dem x auch etwas anderes einsetzen.

    Gruß V99
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen