Formel mit Prozentzahl

Dieses Thema im Forum "Office-Programme" wurde erstellt von lihasi, 24. Februar 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. lihasi

    lihasi Byte

    Registriert seit:
    28. Oktober 2002
    Beiträge:
    51
    Hallo Leute, bitte helft mir beim erstellen folgender Formel.

    Ich habe zwei Werte.
    Z.Bsp. A1 ist eine Zahl in Prozent, B1 ist eine Zahl.

    Folgendes Ergebnis soll für C1 erstellt werden:

    Zu B1 soll der Prozentsatz aus A1 addiert werden und das
    Ergebnis durch 2 dividiert werden.
    Steht in A1 kein Wert, soll auch in C1 nichts stehen.
    Danke für Eure Hilfe!!!
    Grüße, lihasi
     
  2. annette65

    annette65 Kbyte

    Registriert seit:
    8. Januar 2005
    Beiträge:
    477
    Hallo,

    in C1 muss stehen:

    =((B1/100)*A1)+B1

    Grüße, Annette.:)
     
  3. UKW

    UKW Megabyte

    Registriert seit:
    27. August 2003
    Beiträge:
    1.438
    Versuche es mal mit der Formel in C1

    =WENN(A1=0;0;B1+B1/100*A1)

    Nach der Formel von Annette wird die Bedingung "Steht in A1 kein Wert, soll auch in C1 nichts stehen" nicht erfüllt .... =((B1/100)*A1)+B1

    UKW
     
  4. lihasi

    lihasi Byte

    Registriert seit:
    28. Oktober 2002
    Beiträge:
    51
    Danke für Deine Antwort, so weit so gut.
    Das Ergebnis soll dann durch zwei dividiert werden.
    Bis dahin funktioniert die Formel, aber wenn in A1 der Wert 0 ist,
    oder dort nichts steht, dann soll in C1 0 oder nichts stehen.
    So wie die Formel im Moment ist ( =(((F14/100)*D15)+F14)/2 )
    rechnet diese auch mit 0 Prozent, was sie nicht soll.
    - hier F14 z.Bsp. 3% und D15 z.Bsp.100-
    Das Ergebnis ist 51,50. Wenn ich nun in F14 nichts stehen
    habe, kommt das Ergebnis 50,00.Es soll aber 0 stehen oder
    gar nichts, also keine Berechnung.
     
  5. lihasi

    lihasi Byte

    Registriert seit:
    28. Oktober 2002
    Beiträge:
    51
    Hallo UKW,
    hatte Deine Antwort noch nicht gesehen, werde es gleich
    testen,
    Danke
     
  6. annette65

    annette65 Kbyte

    Registriert seit:
    8. Januar 2005
    Beiträge:
    477
    Es fehlt keine schließende Klammer !
    Nach deiner Empfehlung hast du nun 2 geöffnete Klammern und 3 geschlossene Klammern.
    Das geht nicht und führt sofort in Excel zur Fehlermeldung.

    Grüße, Annette.;)
     
  7. lihasi

    lihasi Byte

    Registriert seit:
    28. Oktober 2002
    Beiträge:
    51
    Danke, so ,klappt es prima.
    Grüße, Halisi
     
  8. UKW

    UKW Megabyte

    Registriert seit:
    27. August 2003
    Beiträge:
    1.438
    @Annette
    Entschuldigung, du hast recht mit der Klammer. Habe meinen Beitrag geändert.

    Divison durch 2, das hatte ich nicht berücksichtigt:

    =WENN(A1=0;0;(B1+B1/100*A1)/2)

    UKW
     
  9. annette65

    annette65 Kbyte

    Registriert seit:
    8. Januar 2005
    Beiträge:
    477
    Hallo UKW,

    das funktioniert, habe es gerade "durch 2" auch ausprobiert.

    Grüße, Annette.:)
     
  10. UKW

    UKW Megabyte

    Registriert seit:
    27. August 2003
    Beiträge:
    1.438
    @Annette

    So ganz richtig ist die Formel nicht, man sollte eigentlich unterscheiden ob die Zelle A1 "leer" ist oder den Wert 0 "Null" hat.

    Beispiel:
    =WENN(ISTLEER(A1);0;(B1+B1/100*A1)/2)

    dann rechnet Excel natürlich wenn in A1 "null" steht, wenn die Zelle leer ist dann wird in C1 "null" ausgegeben.

    UKW
     
  11. annette65

    annette65 Kbyte

    Registriert seit:
    8. Januar 2005
    Beiträge:
    477
    @UKW

    Danach dürfte in C1 aber nicht einmal die 0 zu sehen sein.
    Nach lihasi´s Forderung müsste die Zeile dann auch leer bleiben.

    Geht das technisch überhaupt bei Excel?

    Grüße, Annette.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen