FreeNX Server

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von HenkOB, 19. November 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. HenkOB

    HenkOB ROM

    Registriert seit:
    19. November 2004
    Beiträge:
    2
    Hallo zusammen,

    in der PCPraxis 11/04 war ein kurzer Artikel mit dem Hinweis, daß unter Vewendung des mit Knoppix ausgelieferten FreeNX-Servers und dem unter www.nomachine.com herunterzuladendem Client ein Knoppix-Rechner von einem Windows-PS in einem fenster ferngesteuert werden kann.

    Ich habe den NX-Server gestartet, einen neuen Benutzer samt Paßwort angelegt und den NX-Server neu gestartet. Wenn ich dann mit dem Client auf meiner Windows-Maschiene auf das Knoppix-Notebook zugreifen will, wird erst die Verbindung hergestellt (Der Client greift dabei über verschiedene Programme insgesamt 6x auf das Internet zu um den Schlüssel zu authentifizieren *kotz*), dann kommt authentication complete und dann - tadaaaa: connection timeout. Obgleich keine 20sec nach Start der Verbindung vergangen ist.

    Bin die Einstellungen am NX-Server durchgegangen, User vorhanden, Verbindung steht. Im Config-Menü des Clients gibt es keine großen Einstellmöglichkeiten. Warum macht der Client nicht weiter?

    Nota bene sei angemerkt, daß die Netzwerkverbindung natürlich einwandfrei steht, ein gegenseitiger Zugriff auf die Shares ist möglich.

    Hier noch das log vom Client:

    NX> 203 NXSSH running with pid: 1204
    NX> 285 Enabling skip of SSH config files
    NX> 200 Connected to address: 172.16.156.189 on port: 22
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    HELLO NXSERVER - Version 1.4.0-01 OS (GPL)
    NX> 105 hello NXCLIENT - Version 1.4.0
    NX> 134 Accepted protocol: 1.4.0
    NX> 105 SET SHELL_MODE SHELL
    NX> 105 SET AUTH_MODE PASSWORD
    NX> 105 login
    NX> 101 User: hob
    NX> 102 Password:
    NX> 103 Welcome to: Knoppix user: hob
    NX> 105 listsession --user="hob" --status="Suspended","Running" --geometry="1024x768x32+render" --type="unix-kde"
    NX> 127 Sessions list of user 'hob'

    Display Username Remote IP Session ID
    ------- --------------- --------------- --------------------------------
    NX> 105

    Kann mir bitte jemand helfen?

    Herzliche Grüße aus dem Sauerland
    HenkOB
     
  2. schreibe

    schreibe ROM

    Registriert seit:
    22. November 2004
    Beiträge:
    1
    Das Problem liegt am Client. Irgendwie wurde das Protokol geändert. Im Verzeichnis C:\Dokumente und Einstellungen\USER\.nx\temp findest du jeweils verschiedene Verzeichnisse, die wiederum sshlogs beinhalten. Wenn du dich mit dem Nomaschine testaccount verbindest, siehst du, daß der Server anderes reagiert.
    Wenn man eine älteren Windowsclient runterladen könnte, würde meiner Meinung nach alles funktionieren. Mit dem auf Knoppixclient läuft alles. Dieser benützt aber das 1.3.x Protokol.
    Normalerweise müßte der Client auch mit älteren Servern funktionieren. Ich weiß aber nicht wie man ihm das beibringt. Evtl. muß das nxserver script geändert werden.

    Grüße

    Manfred
     
  3. rainerkl

    rainerkl ROM

    Registriert seit:
    4. Dezember 2004
    Beiträge:
    1
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen