Gimp 2.2.8 über CUPS mit Canon PIXMA MP750

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von halebob, 29. September 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. halebob

    halebob Byte

    Registriert seit:
    26. September 2005
    Beiträge:
    51
    Hi
    Ich habe den Drucker soweit unter Cups eingerichtet das er funktioniert.
    Allerdings tut er das nicht wenn ich über Gimp drucken möchte.
    Als Treiber verwende ich den PIXUSIP4100
    siehe http://www.linuxprinting.org/piperm...5q2/002094.html

    Auf dem Drucker steht dann zwar das er drucken will, macht es aber nicht.
    Hat jemand eine Idee woran das liegen könnte?

    Danke schonmal im Voraus
     
  2. Affirmation

    Affirmation Kbyte

    Registriert seit:
    16. März 2005
    Beiträge:
    152
    Wird denn der Drucker bei gimp an sich angezeigt?
    Also wenn du auf "Drucken" gehst - ist dann der Name des Druckers oben im Dialog zu sehen?
     
  3. halebob

    halebob Byte

    Registriert seit:
    26. September 2005
    Beiträge:
    51
    Ja im dialog wird er angezeigt.
    Normales Drucken über kprint funktioniert
    bei gimp kan ich ihn auswählen
    nur wenn ich dann auf drucken klick zeigt mir der drucker nur an das er drucken will, druckt aber nicht
     
  4. Affirmation

    Affirmation Kbyte

    Registriert seit:
    16. März 2005
    Beiträge:
    152
    Du kannst folgende Dinge tun:

    1. Wenn du KDE installiert hast:
    Geh in den Print-Dialog, lege einen neuen Drucker "kprinter" an (Name ist relativ egal hier). Nun gehe auf Setup-Printer und stelle das Command auf "kprinter". Dann wird bei jedem Druck das Druckmenü des KDEs aufgerufen und darüber gedruckt.

    2. Du hast eventuell nicht die nötigen CUPS-Printibibliotheken oder in denen ist kein Treiber für deinen Drucker
    gimp nutzt nicht die CUPS-Bibliotheken, sondern eigene Treiber.

    Prüfe das einmal mit:
    Code:
    rpm -qa | grep gimp
    Das gibt alle Einträge der Packete aus und filtert die dann aus je nachdem ob im Namen "gimp" enthalten ist oder nicht.

    Beispielsweise bei mir:
    Code:
    [oetzi@Oetzi ~]$ rpm -qa | grep gimp
    xsane-gimp-0.95-3
    gimp-data-extras-2.0.1-1
    gimp-print-plugin-4.2.7-7
    [b]gimp-print-4.2.7-7[/b]
    gimp-gap-2.0.2-4
    gimp-2.2.8-0.fc4.2
    gimp-print-utils-4.2.7-7
    gimp-help-2-0.1.0.7.1
    Weitere Namen für gimp-print sind so libgimpprint oder so. Schau mal so nach, ob die installiert sind. (Wobei das Fehlen auch kein 100%ige Diagnose ist - die Bibliotheken könnten ja direkt im Hauptpacket sein).

    Beim Suchen habe ich auch so eine kurze Notiz entdeckt, dass das eventuell am Befehl liegen kann, wenn man da zum Beispiel raw-Daten hat.
    Bei mir ist beim Befehl die Zeile: "lp -s -dprinter -oraw". Vielleicht mal ohne das "-oraw" versuchen. (Natürlich wird die Zeile von deiner abweichen - printer heisst beispielsweise mein CUPS-Drucker)
     
  5. halebob

    halebob Byte

    Registriert seit:
    26. September 2005
    Beiträge:
    51
    Danke für die Mühe
    gimp-print hab ich schon installiert

    Hab das ganze jetzt so gelöst indem ich von gimp aus den Druckauftrag per postscript 1 auf kprinter umleite und darüber ausdrucke.
    Funktioniert ohne Probleme
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen