Hilfe!! 2. Festplatte wird nicht erkannt

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von Dr. Benway, 22. November 2001.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Dr. Benway

    Dr. Benway ROM

    Registriert seit:
    22. November 2001
    Beiträge:
    6
    Ich habe 2 Festplatten WD und Maxtor 5T030H3 an einem Promise ATA100 Controller angeschlossen. Unter Win98SE werden beide Platten problemlos erkannt. Unter WinXP Pro nur die WD-Platte! Auf der Maxtor befindet sich eine primäre Partition sowie mehrere logische Laufwerke. Alle HDDs wurden mit FAT32 formatiert. Die Maxtor Platte wird in der Systemsteuerung als SCSI Platte mit der korrekten Bezeichnung angezeigt (angeblich keine Probleme). Im Explorer werden von den 40 GB nur 2 GB angezeigt und angeblich ist die Platte nicht formatiert!!! Woran kann das liegen? Ich bin ratlos!!!!
     
  2. Dr. Benway

    Dr. Benway ROM

    Registriert seit:
    22. November 2001
    Beiträge:
    6
    Das IBM Tool ist der Drive Fitness Test. Habe ich auch schon ausprobiert, allerdings funktioniert das Löschen des MBR nur mit IBM Platten.

    Werde noch ein paar Sachen ausprobieren. Micro$oft hat zu dem Thema auch noch was geschrieben. http://support.microsoft.com/support/kb/articles/Q297/1/85.ASP (Das mit dem Kabel trifft nicht auf mich zu) Evtl. probiere ich auch fdisk/mbr wie oben beschrieben. Erstmal vielen Dank, ich melde mich wieder!
     
  3. Der Eiserne

    Der Eiserne Byte

    Registriert seit:
    26. Juli 2001
    Beiträge:
    121
    Ich habe zwar auch nicht so viel Ahnung über Partitionen und den MBR aber ich glaube ich weiß wie Du dort hin kommst. Ich gehe davon aus daß Win 98 einwandfrei arbeitet.

    1. Erweitere deine Win 98 Partition auf die gesamte Platte.
    2. Boote mit der Win 98 CD und gebe den Befehl fdisk/mbr ( damit schreibst Du den MBR neu )
    3. Lasse nun zur Sicherheit Scandisk und Defrag. Laufen ( nun sollte die Platte laut Win 98 in Ordnung sein ).

    Und aus diesem Zustand richte dein System neu ein .

    Die Platte würde ich vor dem MBR neu schreiben neu Partionieren, weil die Partitionen stehen im MBR, dadurch sollte dieser sauber sein.
    Falls du die PC-Welt 10/2001 hast kannst Du ja ab Seite 210 einiges über Portionen und den MBR nachlesen, auch wie man in händisch schreiben kann.

    Im übrigen es gibt sicher ein Tool, daß das kann aber ich weiß keines, das einzige was ich dir sagen kann ich glaube IBM hat für seine Platten ein solches Tool, frage mich aber bitte nicht wie es heißt oder wo Du es bekommst.

    Ich hoffe daß, das klappe. Gib mir doch bitte Bescheid wenn es hinhaut.

    Der Eiserne
     
  4. Dr. Benway

    Dr. Benway ROM

    Registriert seit:
    22. November 2001
    Beiträge:
    6
    Vielen Dank erstmal für Deine Anregungen! Leider läßt sich XP aufgrund dieses Unmountable Boot Volume-Fehlers überhaupt nicht installieren! Weder auf einer FAT32 noch auf NTFS. Das Setup kommt gar nicht bis zu der Frage ob man NTFS einrichten soll. Ich vermute, daß bei der Maxtor-Platte irgendetwas zerschossen ist. In einem US-Forum hat jemand ein ähnliches Problem und hat es gelöst, in dem er die Reparaturfunktion des XP Setups genutzt hat und CHKDSK /p durchgeführt hat. Allerdings weiß ich nicht, wie man zu der Repfunktion kommt, wenn das Setup vorher mit einem Bluescreen abbricht. Der Parameter /p funktioniert bei dem W98/DOS chkdsk NICHT!! Gibt es evtl. ein anderes Tool, was so eine Reparatur durchführt??
     
  5. Der Eiserne

    Der Eiserne Byte

    Registriert seit:
    26. Juli 2001
    Beiträge:
    121
    Ich glaub nicht das, daß Problem mit Maxxtor zu tun hat. "Unmountable Boot Volume" heißt für mich, er kann eine Bootpartition nicht in das Dateisystem einbinden.
    1. Also kennt er die Win 98 Partition und will auf diese zugreifen, was er aber durch den Bootmanager nicht kann.
    2. Oder deine NTFS Partition paßt XP nicht. Mit was für einem Fdisk hast Du denn patitioniert XFDISK oder dem Fdisk von Win 98. Ob es bei XP dabei ist weiß ich nicht, ich habe es immer mit Partition Magic 5.01 von der PC-Welt 10/2001 Heft CD gemacht.
    3. Win XP hatt vielleicht auch einen Bootmanager wie Win NT vielleicht bekommen sich die Bootmanager in die Haare. Das wäre eine Erklärung für Punk 1.

    Du könntest probieren die NTFS auf eine FAT 32 Partition umzustellen und auf dieser XP zu installieren ( denn mit dieser hast Du ja schon ein Multibootsystem aufgebaut, also solltest Du keine Probleme damit haben ). Wenn das geklappt hat kannst Du die Fat 32 in eine NTFS mit Win XP umwandeln, daß hat nämlich ein Tool dazu, sowie Win 98 eines von Fat 16 auf Fat 32 hat. Dann bist Du auch dort wo du hin willst.

    Ich habe es so gemacht.
    1. Eine Fat 32 Partition gemacht und diese mit Partition Magic Aktiv gesetzt.
    2. Ganz normal XP installiert wie wenn es alleine wäre.
    3. Mit Win 98 CD DOS gebootet und mein Xosl installiert und eingerichtet.
    Und ich hatte schon mein 3 Windows.
    Der einzige Schönheitsfehler an der Geschichte ist XP hat seinen Bootmanager auch installiert und läßt mir nun mein altes System auf C: oder Windows XP booten. Nur durch meinen Bootmanager kann er nicht auf das alte System auf C: zugreiben und landet im Nichts.

    Ich hoffe ich konnte Dir helfen.
    Der Eiserne

    PS:
    Einen Vorschlag habe ich noch. vergieß die NTFS und erweitere deine Fat 32 von Win 98 und installiere Win XP da einfach hinein. Denn lau der PC-Welt 12/2001 Seite 62 fragt das Setup bei einem Update von Win98 oder ME auf XP, ob das bestehende Dateisystem – zumeist wohln Fat32 oder NTFS umstellen werden soll. Das hat den Vorteil, im Fall des Falles auf das alte System zurückkehren zu können. Außerdem ist damit die Parallelinstallation von XP auf der selben Partition möglich, auf der sich bereits ein Windows-System befindent.
    Das müßte dann heißen Win XP hat auch eine Bootmanager.
     
  6. Dr. Benway

    Dr. Benway ROM

    Registriert seit:
    22. November 2001
    Beiträge:
    6
    Ich hatte auch ein Multibootsystem mit XFDISK. Hat auch immer sehr gut funktioniert. Der Fehler hat aber anscheindend mit der Maxtor-Platte zu tun. Ich habe sie mit FDISK neu partitioniert, formatiert und Win98 in der primären Partition installiert. Jetzt will ich XP auf der zweiten Partition mit NTFS installieren. Allerdings bekomme ich vorher einen Bluescreen mit der Fehlermeldung "Unmountable Boot Volume" Was kann man da machen? Ist der MBR nicht in Ordnung?
     
  7. Der Eiserne

    Der Eiserne Byte

    Registriert seit:
    26. Juli 2001
    Beiträge:
    121
    Jetzt dämmert es mir.
    Du hast also auf deiner Maxxtor mehrere Primäre Partitionen, die Du versteckt hast. Das einzige was mir jetzt noch spanisch vor kommt ist, daß du die Partitionen nicht als Laufwerk im Explorer siehst. Das könnte aber davon kommen, daß Sie nicht Formatiert sind. Das verstecken der Primären Partitionen kommt davon, daß Windows immer nur von der C: Paltte also 1. Primäre Partition auf der Master am Primären EIDE Kontroller Booten kann. Wenn Du jetzt z. B. Win 98 und Win ME auf einer Platte haben willst brauchst du eine Bootmanger und der versteckt dann einmal die Win Me oder die Win 98 Partition , und so glaubt das Andere Win, daß es alleine und auf Platte C: ist .

    Du kannst jetzt mit Partition Magic entweder die anderen Primären Partitionen löschen und eine Große machen. Du kannst dir ein weiteres Laufwerk zum speichern deiner Daten machen , falls Du Win neu installieren muß brauchst du dann um deine Daten keine angst haben weil sie auf einem anderen Laufwerk sind. Wenn du so etwas machen willst schau dir die PC-Welt 10-2001 an oder gib mir Bescheid. Denn durch den Artikel habe ich mir folgendes System gezimmert. Win 98SE, ME, XP und Linux SuSE 7.2 auf einer Platte mit dem Bootmanager Xosl. Findest Du im übrigen alles auf der Heft CD.
     
  8. Dr. Benway

    Dr. Benway ROM

    Registriert seit:
    22. November 2001
    Beiträge:
    6
    Lt. der Promise-Website gibt es keine aktuelleren Treiber als die, welche von XP mitgeliefert werden :-)
     
  9. schroedinger

    schroedinger Kbyte

    Registriert seit:
    21. September 2001
    Beiträge:
    155
    treiber für den controller wäre doch mal ne idee, oder??
     
  10. Dr. Benway

    Dr. Benway ROM

    Registriert seit:
    22. November 2001
    Beiträge:
    6
    Anzeige IDE als SCSI ist OK, das stimmt. Mein Mainboard ist ein Gigabyte 6BA. Ich vermute es hat was mit den aktiven Partitionen zu tun. Anscheindend ist MBR der Maxtor Platte eine Einstellung, das aktive Partitionen gegenseitig versteckt werden. So etwas habe ich zumindest mit Partition Magic gesehen. Ich werde mal alle Daten umschaufeln und eine Neuformatierung vornehmen.
     
  11. bitandbyte

    bitandbyte Byte

    Registriert seit:
    28. Januar 2001
    Beiträge:
    22
    Häng die platten doch einfach an die Normalen IDE anschlüsse nicht an den promise kontroller

    festplatte bringt eh ned mehr als 30 Mb/s
    also ist des 100 für die katz :-)

    CD laufwerke kannst dann ja an promise hängen...
    also des würd ich so machen!" gruß BB
     
  12. Der Eiserne

    Der Eiserne Byte

    Registriert seit:
    26. Juli 2001
    Beiträge:
    121
    Hallo.
    Das mit dem SCSI kommt davon weil, UDMA ein Bios so wie SCSI haben.

    Ne blöde Frage.
    Hast Du vielleicht ein Asus A7V133 Bord weil die haben eine Bug mit den UDMA Kontrollern. Weil beim Partitionieren mit Fdisk hatte ich immer Probleme.

    Sonnst habe ich keine Erklärung. Wenn Du kannst dreh doch die Platten mal um. Also die jetzige Master als Slave und umgekehrt vielleicht bringst was.

    Oder Partitioniere die Platte mit 40 GB mit XP neu.

    Sonnst habe ich auch keine Idee.
    Der Eiserne
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen