Hilfe Linux killt Windows TEIL 2

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von cat123, 6. September 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. cat123

    cat123 Byte

    Registriert seit:
    15. August 2002
    Beiträge:
    20
    Vorgeschichte: Auf dem PC ist Windows98 installiert. Von der dazugehörigen Partition habe ich etwas abgeknapst (paragonpartitionsmanager) und habe auf dem freien Platz SuseLinux7.3 installiert. LINUX kann ich über LILO Bootdiskette starten und funktioniert. Beim "normalen" Hochfahren des PC ohne LILOBootdiskette bootet der PC jetzt aber nicht mehr von der Festplatte windows, sondern behauptet kein Betriebssystem zu finden. Starte ich Linux mit Bootdiskette erscheint ein Linuxbootmanager auf dem man auch windows auswählen kann.Tue ich dies so ist der Bildschirm schwarz und mit weisser Schrift: " windows loading...." und dann tut sich garnix mehr. Starte ich den PC mit vorher angefertigten Partitionsmanagerbootdiskette, so tut sich auch nix. Noch nicht mal die oben erwähnte Anzeige. Auf einem anderen PC kann die "rettungsdiskette" windows starten.
    Nach den gestrigen Forumtipps (Herzlichen Dank an alle) habe ich heute den PC mit der win-Startdiskette hochgefahren und brav fdisk/mbr eingegeben. Im Diskettenlaufwerk tat sich was und ich freute mich, da ich dachte mbr neu geschrieben alles prima,doch nach wie vor das gleiche Problem beim neubooten....
    (Noch eine Merkwürdigkeit: Wenn ich unter DOS den Inhalt der Laufwerke aufrufe (DIR) klappt das bei Floppy und Laufwerk D, jedoch Laufwerk C meldet UNGÜLTIGER MEDIENTYP BEIM LESEN VON LAUFWERK C.)

    Was ist zu tun damit WINDOWS wieder startet. Am liebsten schon gleich beim "normalen" Hochfahren?
    LINUX mit Diskette starten ist für mich ok.
     
  2. cat123

    cat123 Byte

    Registriert seit:
    15. August 2002
    Beiträge:
    20
    Danke für dir Tipps,aber die show ist vorbei (hoffentlich). Nachdem ich noch dies und das probiert habe (zB neuen Bootsektor schreiben) wurde immer deutlicher, dass ein Zugriff auf C untzer DOS (geschweige denn Windows) möglich ist. Nur unter Linux weiterhin seltsamerweise.
    Wie gesagt noch nicht mal mit DIR unter DOS ließ sich C aufrufen.
    In einer spontanen Kurzschlussaktion habe ich C neu formatiert mit FDISK.
    Believe it or not: Unter Linux wurden auf der neu formatierten Partition noch immer die alten Dateien angezeigt (???????????)
    Als ich C dann noch mit SCANDISK mal durchscannen wollte kam eine lange Warnmeldung:Die letzte Zuordnungseinheit auf Laufwerk C kann nicht gelesen werden. Diese Zuordnungseinheit ist beschädigt oder das System ist nicht richtig konfiguriert. Gegebenenfalls muss für Laufwerk C die Logische Blockadressierung (LBA) aktiviert werden oder die Datenträgerpartition ist fälschlicherweise als LBA-Partition markiert blablabla.
    Im BIOS fand ich einen "Knopf" den ich von "Auto" auf "LBA" schalten konnte.
    Danach klappte das scannen,nur reparierte er dabei ca 200 Dateien (verschob sie.....?).
    Danach konnte man C auch unter DOS aufrufen und zeigte (obwohl vorher formatiert!!) alle Verzeichnisse an.
    (!!) Aber beim Hochfahren des PCs immer noch kein Betriebssystem gefunden.......
    Über den Bootmanager von Linux windows gestartet lud er etliche Dateien bis welche fehlten......
    Nochmal C formatiert und dann war offensichtlich alles soweit "platt",dass unter Dos und unterLinux endlich (??) angezeigt wurde ,dass nix mehr auf C lebt.
    Morgen werd ich dann mal Windows und die anderen ca 40 Programme neu installieren.............
    (Linux läuft mit LILO-Startdiskette prima.......)

    PS:Könnte jemand mir Dilettanten mal erklären was mir da wiederfahren ist???
     
  3. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Es könnte sein, dass bei Dir der Bootsektor von Windows beschädigt worden ist.Schreibe ihn neu, indem Du eine Win 98-Bootdiskette nimmst und den Befehl sys C: eingibst.

    franzkat
     
  4. cat123

    cat123 Byte

    Registriert seit:
    15. August 2002
    Beiträge:
    20
    laut FDISK folgende Infos: Partition C:1 TYP Pri DOS, Status A.
    Partition2 Ext DOS.log Laufwerk D. Und wenn ich dieMBZahlen zusammenzähle fehlen genau die 3 GB die ich für LINUX abgeknapst hatte (und unter DOS nicht angezeigt werden) Wenn ich mit Linux hochfahre wird mir das dort beim abchecken auch bestätigt.
    WINDOWS d.h C und D ist noch da, ich kann unter Linux in den Verzeichnissen stöbern.
    Wenn ich das beim partitionieren so richtig verfolgt habe ,habe ich die 3 GB vom Ende des Laufwerks genommen.
    [Diese Nachricht wurde von cat123 am 06.09.2002 | 18:54 geändert.]
     
  5. cat123

    cat123 Byte

    Registriert seit:
    15. August 2002
    Beiträge:
    20
    Danke für den Tipp, doch das hab ich heut beim rumprobieren voller Hoffnung auch probiert. Die erste Partition war schon als aktiv markiert und ich hab sie nochmals als aktiv angemeldet,doch das half auch nicht...............
     
  6. whisky

    whisky Ganzes Gigabyte

    Registriert seit:
    1. Oktober 2001
    Beiträge:
    11.014
    Hast du möglicherweise ausversehen Linux über Windows installiert! Starte mit Win Bootdisk und gib fdisk ein! Wenn auf der 1. Platte die 1. Partition "nondos" oder so ist dann hast du beim installieren von Linux etwas falsch gemacht!
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen