HTML Frames

Dieses Thema im Forum "Web-Know-how für die Homepage" wurde erstellt von Blacky_da_wu, 9. Februar 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Blacky_da_wu

    Blacky_da_wu Byte

    Registriert seit:
    12. September 2003
    Beiträge:
    49
    hallo.
    ich habe ein kleines Problem bei meiner Homepage. die index-seite soll die ganzen frames verwalten. ich habe 3 reihen als frames wobei die oberste und die mittlere feste größen haben sollen. die letze reihe soll nur als Platzhalter dienen, wenn jemand eine hohe auflösung benutzt. wenn ich aber das fenster kleiner mache, wird die oberste reihe verkleinert. sie soll aber nicht in der größe verändert werden.
    hier mein quelltext:
    <html>
    <head>
    <title>title</title>
    </head>
    <frameset rows="110,500,*" border="0">
    <frame name="Top" scrolling="no" resizable=no target="Inhalt" src="top.htm">
    <frameset cols="216,*">
    <frame name="Inhalt" scrolling="no" resizable=no target="Hauptframe" src="inhalt.htm">
    <frame name="Main" src="main.htm" target="Inhalt">
    </frameset>
    <frame name="Navigationsframe unten" scrolling="no" noresize target="Inhalt" src="leer.htm">
    <noframes>
    <body>

    </body>
    </noframes>
    </frameset>
    </html>

    der frame mit 110 pixel (Top) soll so groß bleiben. jetzt wird nämlich die darin enthaltene flash beim kleiner machen des Fensters überdeckt vom unteren Teil der Seite. Obwohl ich "resizable=no" drin habe, weiss ich nicht woran das liegen kann.
    thx im vorraus
     
  2. Gast

    Gast Guest

    wie wärs wenn du es wie folgt angeben würdest:

    <frameset rows="110,500,*" frameborder="0" framespacing="0" border="0">
    <frame name="oben" src="oben.html" scrolling=xyz NORESIZE>
    .....
    </frameset>
    das resizeable=no, was du einsetzt ist XHTML!

    der xhtml befehl resizeable=no wird dadurch nicht erkannt, und somit ausgelassen!

    nachzulesen unter:

    Selfhtml/html/xhtml/unterschiede.htm

    in deiner selfhtml version auf der platte!

    Auszug:
    ...Solange Sie also XHTML-konforme Dateien mit den HTML-typischen Endungen .htm oder .html abspeichern, erreichen Sie eine "normale" Darstellung im Browser, verhindern aber auch, dass die Dateien im Browser auf XML-Basis verarbeitet werden....

    speichere die datei als index.xhtml ab, dann sollte es funktionieren oder benutze den befehl NORESIZE

    beachte:

    wenn du xhtml und html mischt, solltest du ganz genau aufpassen und dich in die materie reinfuchsen, sonst entstehen fehler, an denen du verzweifelst! :)

    michael
     
  3. Macgillegan

    Macgillegan Byte

    Registriert seit:
    22. März 2002
    Beiträge:
    93
    Hallo Blacky_da_wu,
    dieses Problem habe ich auch. Aber ich glaube es kommt einfach daher, weil beim verkleinern der Fenster sich die einzelnen Frames übereinander schieben. Die einzelnen Frames ansich werden ja nicht kleiner. Hast Du einmal bei Selfhtml nachgesehen ob es eine Möglichkeit gibt? Wäre ja schön, glaube ich aber nicht.
    resizable, bewirkt lediglilch folgendes:
    Wenn ja (yes), kann der Anwender das Fenster in der Größe verändern. Wenn nein (no), kann er die Fenstergröße nicht ändern. Voreinstellung ist no, beim Internet Explorer jedoch nur, wenn die Optionenzeichenkette mindestens eine Option enthält. (lt. selfhtml)
    Also es verhindert nicht, daß sich die Fenster übereinander schieben, sondern regelt nur das man die eigentlich Fenstergröße verändern kann.
    Gruss
    Mac
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen