Icons werden "neu eingelesen"

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von steff_ks, 11. September 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. steff_ks

    steff_ks Byte

    Hallo!

    Ich habe ein nicht wirklich schlimmes, aber nerviges Prob, noch dazu schwer zu beschreiben. Ich hoffe, damit kann trotzdem jemand was anfangen:
    Wenn sich nach dem Windowsstart der Desktop aufbaut, werden jedesmal die Icons "neu eingelesen". D.h. erst erscheint der Icontext, dann das typische Windowsicon darüber (wie wenn Win eine Datei nicht kennt, bzw. kein Programm zugeordnet ist) und nach ein paar Sekunden erscheint das eigentliche Icon. Das nervt, zumal es vor der (kompletten) ME-Neuinstallation nicht so war. Mein Rechner ist schnell genug (700MHz, 320MB RAM) und ich habe auch schon verschiedene Icon-Cache-Größen durchprobiert. Es ändert nichts.
    Fällt dazu jemandem was ein?
     
  2. steff_ks

    steff_ks Byte

    So, jetzt hab ich\'s! :D
    Dank den beiden Füchsen weiter unten (franzkat und rspezi) habe ich mal den Reg-Eintrag kontrolliert und die Leerzeichen rausgenommen. Als ich die shelliconcache-Datei im Windowsordner löschen wollte, musste ich aber feststellen, dass diese dort gar nicht vorhanden ist. Mein Win weigerte sich standhaft, sie nach diversen Neustarts wiederherzustellen. Weiß der Geier! Ich habe die Datei nun über DriveImage wiederhergestellt und - TATAAAAA! - es funktioniert!
    Vielen Dank an alle Helfer hier, es war eine Team-Lösung!
     
  3. steff_ks

    steff_ks Byte

    Hallo dieschi!

    Der Active Desktop ist deaktiviert. Das ist es also auch nicht. Aber wie gesagt, es handelt sich ja "nur" um ein kosmetisches Problem, der Rechner läuft ja trotzdem. Naja, wie Win halt läuft! ;-)
     
  4. franzkat

    franzkat CD-R 80

    So, habe das mit den Registry-Konventionen für die Werte-Angaben für unterschiedliche Werte nochmal auf verschiedenen Systemen getestet.Ergebnis : Wenn zwischen den Begriffen ein Leerzeichen steht, bleibt die Einstellung wirkungslos ! Das zum Thema Berufsgruppen und : Microsoft hat immer recht.

    franzkat
     
  5. franzkat

    franzkat CD-R 80

    Muß Dir leider recht geben !

    franzkat :-)
     
  6. franzkat

    franzkat CD-R 80

    Sprachlogik ? Was hat Microsoft mit den Berufsgruppen zu tun ?

    franzkat
     
  7. franzkat

    franzkat CD-R 80

    Die winfaq-Seite enthält in Bezug auf den Icon-Cache leider einen Fehler.Es darf nicht heißen : "Max Cached Icons" - sondern richtig ist: "MaxCachedIcons" ohne Leerzeichen(!), entsprechend der Registry-Konvention.Die falsche Schreibweise läßt den Eintrag wertlos werden.

    franzkat
     
  8. steff_ks

    steff_ks Byte

    Danke, aber wie ich auch oben schon geschrieben habe, habe ich das schon getestet, ohne Erfolg.
    Trotzdem danke für die Antwort!
    [Diese Nachricht wurde von steff_ks am 11.09.2002 | 14:12 geändert.]
     
  9. dieschi

    dieschi CD-R 80

    Sorry, meine schuld .. hab den Tipp von RSpezi nicht komplett gelesen, da stand das ja schon drin.

    Weitere Möglichkeit die mir noch einfällt:
    Ist eventuell der ActiveDesktop aktiviert?

    Könnte es sein das beim Start erst der ActiveDesktop geladen wird und dann erst *dein* Desktop?
    Habe bei mir schon öfters beobachtet das bei aktiviertem ActiveDesktop erst dieser geladen wird und kurz darauf erst mein WindowsTheme .. in der Zeit zwischen dem laden des Active Desktops und meinem Theme haben die Icons auch ihre Beschriftung und zeigen das normale WindowsIcon erst kurz danach werden diese gegen meine Theme-Icons ersetzt ...

    Schau da mal nach ...

    Gruß .. dieschi
    Moderator Pc-Welt Forum
     
  10. dieschi

    dieschi CD-R 80

    Kommt davon wenn man nur bis zum reg-Eintrag nachließt ...
    Egal hab noch eine Idee ... ;)
     
  11. dieschi

    dieschi CD-R 80

    Vielleicht ist die IconShell aber auch defekt.

    Entweder versuch mal per TweakUI - Register *Repair* - dort den Eintrag *repair Icons* aktivieren oder, was einfacher geht, lösch die Datei <B>ShellIconCache</B> unter C:\Windows und mach einen Neustart.

    Die Datei wird dann neu angelegt ...

    Gruß .. dieschi
    Moderator PC-WELT Forum
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen