Installation meckert Dienst Windows Installer an

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von Immi, 30. Oktober 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Immi

    Immi Byte

    Registriert seit:
    20. September 2000
    Beiträge:
    9
    Hallo,

    wenn ich eine neuere Installation (hier Acrobat Reader 6.0) starten, meckert das Programm meinem Windows-Installer Dienst an. Die Meldung lautet:

    "Auf den Windows Installer Dienst konnte nicht zugegriffen werden. dies kann auftreten, wenn Windows im abgesicherten Modus ausgeführt wird oder wenn der Windows Installer nicht korrekt installiert wurde. Setzen Sie sich mit dem Supportpersonal in Verbindung, um weitere Unterstützung zu erhalten"

    Ich nutze win2k Professional. Kann mir jemand helfen? Der Dienst ist gestartet, auf automatisch gestellt. Ich weiß nicht mehr weiter. Man kann den Dienst doch nicht einfach runterschmeissen und neu installieren, oder?
     
  2. Wolfgang77

    Wolfgang77 Ganzes Gigabyte

    Registriert seit:
    1. Oktober 2002
    Beiträge:
    20.804
  3. Immi

    Immi Byte

    Registriert seit:
    20. September 2000
    Beiträge:
    9
    Hi Wolfgang,

    das geht leider nicht. Ich erhalte die Info:

    "Der angegebene Dienst ist bereits vorhanden".

    Noch eine Idee?

    Gruß
    Immi

    :heul:
     
  4. Immi

    Immi Byte

    Registriert seit:
    20. September 2000
    Beiträge:
    9
    Hi Maxmaster,

    danke für die Info. Damit hat es geklappt.

    Thanx
    Immi

    :bet: :D
     
  5. baelli

    baelli ROM

    Registriert seit:
    23. November 2004
    Beiträge:
    1
    Hallo Zusammen!

    Ich habs verscuht, aber es klappt nicht. Ich kann zwar die files umbennenen. sie sind aber alle im anschluss wie von gesiterhand wieder da, d.h. das umbenannte file existiert sowie das original. was mach ich falsch. gib es einen anderen weg den isntaller zu "flicken"?

    gruss
    aus dem land der
    kühe un schokolade
     
  6. UKW

    UKW Megabyte

    Registriert seit:
    27. August 2003
    Beiträge:
    1.438
    Hallo,

    wie "Kühe und Schokolade"... postest du aus der Schweiz ??.

    Also mit "Geisterhand" hat das nichts zu tun, sondern mit dem Selbstschutz von Windows "autom. Systemwiederherstellung". Mit welchem Windows vergnügst du dich denn gerade ??.

    Grüße
    UKW
     
  7. semmelmayer

    semmelmayer ROM

    Registriert seit:
    8. Dezember 2004
    Beiträge:
    3
    Danke,
    zusammengenommen haben mir die Antworten in diesem Forum geholfen mein problem unter WINDOWS 2000 PROFESSIONAL zu loesen.

    1) problem
    die installation von norton internet security 2005 bricht ab, und lt. FAQ von symantec (nachdem alle anderen Versuche norton installationsleichen via regedit zu entfernen nichts genutzt haben) weist darauf hin, dass man den windows installer neu installieren soll

    Norton fehermeldung: "instopts.dat is missing"
    link auf FAQ http://service1.symantec.com/SUPPOR...OpenDocument&ExpandSection=3&Src=sg#_Section3

    2) daher download von INSTMSIW.EXE von WWW.microsoft.com

    http://www.microsoft.com/downloads/...A1-6F8A0F5DCA8F

    3) aber beim versuch dieses zu installieren, kommt die angegebene fehlermeldung
    "Der angegebene Dienst ist bereits vorhanden"

    4) Dienst "windows installer" stoppen oder auf manuellen Start setzen (unter einstellungen-systemsteuerung-verwaltung-dienste) hilft nichts, und das entfernen der 3 files MSI.DLL, MSIHND.DLL und MSIEXEC.EXE sowohl auf \winnt\system32\dllcache und \winnt\system32\ gelingt nicht, weil win2000 die files immer wieder sofort wiederherstellt.

    5) aber boot von windows2000 installations CD und start der reparaturkonsole hilft: hier einfach die 3 (bzw. 6) files loeschen oder rename

    6) nach dem reboot sind die files auch wirklich weg und der windows installer dienst laeuft auch nicht

    7) nun einfach INSTMSIW.EXE installlieren und und erneut reboot und danach sind die dateien und der dienst wieder vorhanden.

    8) jetzt geht es wieder weiter mit norton/symantec ...

    9) die hinweise von der sehr guten seite http://beqiraj.com/windows/installer/index.asp bzgl. msiexec/unregister haben bei mir nicht geholfen, daher eben die erneute installation

    mfg
    lse/leo
     
  8. semmelmayer

    semmelmayer ROM

    Registriert seit:
    8. Dezember 2004
    Beiträge:
    3
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen