Internet Explorer stürzt bei neuen Fenstern ab

Dieses Thema im Forum "Sicherheit" wurde erstellt von LaiceAterna, 18. Januar 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. LaiceAterna

    LaiceAterna ROM

    Registriert seit:
    18. Januar 2004
    Beiträge:
    6
    Hallo!

    Mein IE hat von einem Tag auf den anderen einen bösen Bug bekommen: Sobald ich ein neues Fenster öffne bzw. er es automatisch öffnet, stürzt das aktuelle Fenster ab, das neue öffnet sich nicht (ist aber im Task-Manager eingetragen). Andere IE-Instanzen laufen weiter einwandfrei. Das selbe wenn ich einen Link aus anderen Programmen (Word, Outlook) öffne.

    Ich habe bisher erst eine Erklärung dieses Bugs im Netz gefunden (http://www.mcse.ms/message246508.html) aber die funktioniert bei mir nicht. Und ich habe nicht wirklich Lust, deswegen meinen ganzen PC zu formatieren.

    Ich würde ja gerne den IE einfach neu installieren, aber das geht auch nicht, da ich nirgendwo ne komplette Setup-Datei finde (und ich bezweifle eh, dass das geht - so tief wie der in Windows eingebaut ist).

    Habe schon ausführlich nach Viren, Trojanern, Adware und ähnlichem gesucht, und nichts gefunden.

    Kann mir irgendjemand helfen?!
     
  2. LaiceAterna

    LaiceAterna ROM

    Registriert seit:
    18. Januar 2004
    Beiträge:
    6
    Öfter mal was neues: Jetzt hängt er beim Öffnen eines Fensters, und wenn ich dann rechts auf den entsprechenden Block der TAskleiste klicke und dann links auf den Desktop, geht's weiter. Ich hab langsam das Gefühl, mein PC will mich verarschen...
     
  3. LaiceAterna

    LaiceAterna ROM

    Registriert seit:
    18. Januar 2004
    Beiträge:
    6
    Klar hab ich den Papierkorb noch nicht geleert: die urlmon(3).dll ist vom 29. August 2002, aber mehr steht da auch nicht bei.

    Was Mozilla betrifft: Ich möcht halt eigentlich ganz gerne den IE behalten, der gefällt mir einfach irgendwie besser. Ist halt Geschmackssache. Aber es geht mir natürlich auch ums Prinzip: Ich seh halt nicht gerne tatenlos zu, wenn mein PC aus dem Nichts plötzlich irgendwelche Zicken entwickelt.
     
  4. trudenbiker

    trudenbiker Kbyte

    Registriert seit:
    14. Oktober 2003
    Beiträge:
    291
    Schade, dass du die Urlmon(3).dll schon gelöscht hast. Mit Erstellungsdatum etc. kann man da manches nachvollziehen. Vielleicht hängt sie noch im Papierkorb, ansonst versuch sie mit
    pc inspector wiederherzustellen und zu checken.

    Und wie wär's mit Browser-Wechsel zu Mozilla ??
     
  5. LaiceAterna

    LaiceAterna ROM

    Registriert seit:
    18. Januar 2004
    Beiträge:
    6
    Ja, hab genau den Patch runtergeladen, den Du mir genannt hast. Hab auch gesehen, wie er bei der Installation eine urlmon.dll kopiert hat.

    ---

    Es ist so: Bei manchen Websites ist es wie ganz oben beschrieben.

    Bei anderen auch, aber nach ner knappen Minute oder so kommt dann doch das neue Fenster.

    Und bei wieder anderen kommt das neue Fenster sofort.

    Zwischen normalen Links und Pop-Ups gibt's da übrigens keinen Unterschied.

    DSL hab ich, also wenn Du noch mal schauen würdest nach ner Setup-Datei, wäre das echt klasse! Kannst Dir ruhig Zeit lassen, ich bin eh erst morgen abend wieder da.
     
  6. Wolfgang77

    Wolfgang77 Ganzes Gigabyte

    Registriert seit:
    1. Oktober 2002
    Beiträge:
    20.804
    Hallo,

    also irgendwas hat sich getan .. stürzt das aktuelle Fenster jetzt nicht mehr ab ??. Der Ansatz mit der "urlmon.dll" scheint nicht ganz verkehrt zu seien, aber was nutzt es wenn er immer noch verrückt spielt. Noch mal eine dumme Frage ... hast du den richtigen Patch für den IE runtergeladen (glaube die unterscheiden sich je nach Windows-Version).

    Es gibt die Möglichkeit mit einem Trick den kompletten IE von der MS-Website kopieren und dann von Festplatte oder CD zu installieren, müsste in meiner Tippsammlung suchen im Kopf habe ich das nicht wie ich das gemacht habe. Macht aber auch nur Sinn wenn du einen schnellen Internet-Zugang hast (DSL) mit ISDN wirds lange dauern.

    Dann den IE nochmal installieren.. habe im Moment keinen anderen Rat für dich.

    Grüße
    Wolfgang
     
  7. LaiceAterna

    LaiceAterna ROM

    Registriert seit:
    18. Januar 2004
    Beiträge:
    6
    So, habe mal alles getan, was Du mir empfohlen hast, und das Ergebnis war folgendes.

    Hab nach dem CoolWebSearch gesucht -> nix gefunden und das Update installiert.

    Ergebnis: Funktioniert immer noch nicht. Daraufhin habe ich mal einen Blick auf die Datei C:\windows\system32\urlmon.dll geworfen, wobei mir eine andere Datei namens urlmon(3).dll aufgefallen ist, bei der keinerlei Kommentare etc. standen. Hab die gelöscht, und neu gestartet.

    Jetzt sieht es so aus: Auf manchen Websites geht nix, auf manchen lädt das neue Fenster nach ein paar Sekunden, auf wieder anderen dauert es so knapp 1 bis 2 Minuten, bis es sich öffnet (währendderen alles nach Crash aussieht).

    Meine Windows-Version ist XP/Home/Version 2002/SP1, und mein IE ist 6.0.2800.1106.xpsp2.030422-16-1633 SP1. Habe bisher alle von Microsoft empfohlenen Updates installiert.
     
  8. Wolfgang77

    Wolfgang77 Ganzes Gigabyte

    Registriert seit:
    1. Oktober 2002
    Beiträge:
    20.804
    Hallo,

    dann tausche erstmal die "urlmon.dll" aus. Das machst du am besten mit dem Microsoftpatch Q824145. Glaube der letzte Patch für den IE war vom 12.11.2003. Ich spreche hier vom IE 6.0 SP1... du schreibst leider nichtr welche Version du nutzt.

    Hilft das noch nicht solltest du doch noch mal nach einem Hijacker suchen.. in Richtung Cool Web Search der Firma 'Coolwebsearch' (CWS). Hier gibt es ein kleines in Assembler geschriebenes Programm zum entfernen:

    http://lunatic-skydance.de/mr/soft/SpoonWeg.exe

    oder mal einfach nach einer "sp.exe" Datei auf deinem System suchen.

    Grüße
    Wolfgang
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen