Java Plug In

Dieses Thema im Forum "Browser" wurde erstellt von Kurt W, 23. November 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Kurt W

    Kurt W Kbyte

    Registriert seit:
    22. April 2001
    Beiträge:
    397
    Hallo,

    kurze Frage ich habe bei PC Welt gelesen, das sich im Java Plug In ein "Sicherheitsrisiko" befindet. Meine Version 1.4.2_05
    Wenn ich über die Update Funktion von Java gehe wird mir gesagt, das ich auf dem neuesten Stand bin!!

    Wenn ich versuche über den Link von PC Welt mir die neuste Version herunter zu laden dauert das eine Ewigkeit und ich habe abgebrochen.

    Was ist nun richtig? Welche Version ist nun sicher? Wie groß ist das Update?

    Fragen über Fragen? :bet:

    Danke im Voraus!

    Gruß Kurt
     
  2. pcinfarkt

    pcinfarkt Viertel Gigabyte

    Registriert seit:
    19. August 2004
    Beiträge:
    4.096
  3. Kurt W

    Kurt W Kbyte

    Registriert seit:
    22. April 2001
    Beiträge:
    397
  4. pcinfarkt

    pcinfarkt Viertel Gigabyte

    Registriert seit:
    19. August 2004
    Beiträge:
    4.096
    @ Kurt W,

    Frage vielleicht hier nicht hingehörig.

    Nagele mich nicht auf ein Datum fest, jre 1.5.0 ist wohl ca. ende 09/04 erschienen. Nicht desto trotz ist ja die Info in PCW richtig.
     
  5. Kurt W

    Kurt W Kbyte

    Registriert seit:
    22. April 2001
    Beiträge:
    397
    @pcinfarkt
    Hallo,

    was ist nun mit meiner Version 1.4.2._05 :confused:

    Ist die nun ein Sicherheitsrisiko oder nicht? :aua:

    Grüße Kurt
     
  6. pcinfarkt

    pcinfarkt Viertel Gigabyte

    Registriert seit:
    19. August 2004
    Beiträge:
    4.096
    @ Kurt W,

    Verstehe gar nichts mehr!! In einem Beitrag von mir weiter oben hatte ich einen Link (nochmal: http://plugindoc.mozdev.org/de-DE/windows.html#Java) gepostest , auf welchen Du geantwortet hast
    Und Deine jetzige Frage habe ich Dir auch, so weit ich es als Nicht-Mitarbeiter von Sun kann, beantwortet. Willst Du von der aktuellen Ver 1.5.0 zu 1.4.2._05 zurück?

    Ergänzung

    Kurt, reicht Dir das
    http://www.tecchannel.de/sicherheit/reports/4519.html ?
     
  7. Kurt W

    Kurt W Kbyte

    Registriert seit:
    22. April 2001
    Beiträge:
    397
    @pcinfarkt

    Hallo,

    also jetzt blicke ich nichts mehr :confused:

    Willst Du von der aktuellen Ver 1.5.0 zu 1.4.2._05 zurück?

    Warum zurück?? Entweder habe ich dich komplett falsch verstanden oder ich stehe auf der Leitung!!

    Meine Java Version ist 1.4.2_05
    Laut deinen letzten Links ist hierin die Lücke enthalten und erst mit der Version 1.4.2_06 behoben!! Was hat das dann mit der Version 1.5.0 zu tun?? :confused:

    Gruß Kurt
     
  8. Phil o'Soph

    Phil o'Soph Kbyte

    Registriert seit:
    31. Oktober 2004
    Beiträge:
    335

    Hallo Kurt,

    Du setzt Java 1.4.2_05 ein -- diese beinhaltet die Sicherheitslücke. Derzeit werden von Sun 2 Java Versionen gepflegt:
    • Java 1.4.x -- das ist Java 4, letzte Version 1.4.2_06
    • Java 1.5.x -- das ist Java 5, letzte Version 1.5.0

    Du solltest, wenn nichts anderes dagegen spricht, Java 5 nehmen. Die Unterstützung für Java 4 wird irgendwann einmal eingestellt werden. Nichtsdestotrotz behebt Sun noch Fehler in Java 4. Wenn Du weiterhin auf Java 4 setzen willst, installiere bitte die Version 1.4.2_06.

    Java 1.4.2_05 ist von der Sicherheitslücke betroffen

    Die Nummerierung von Sun ist ein bisschen Konfus, ich weiß. :cool:

    Phil o'Soph
     
  9. Kurt W

    Kurt W Kbyte

    Registriert seit:
    22. April 2001
    Beiträge:
    397
    Danke Phil o'Soph

    Nun habe ich es endlich auch begriffen :bet:

    Da kannst du aber auch verrückt werden, mit den unterschiedlichen Bezeichnungen :D
    Ich hoffe nur das der Download der Version 1.5.0 nicht eine Ewigkeit dauert, ich habe nur ISDN :p

    Noch eine kurze Frage:
    Du solltest, wenn nichts anderes dagegen spricht, Java 5 nehmen. Was sollte bzw. könnte dagegen sprechen??

    @pcinfarkt
    Sorry, ich bin da mit den Versionsnummern etwas durcheinander gekommen. Werde heute Abend selbsverständlich 1.5.0 laden.
    Danke für den Link :danke:

    Gruß Kurt
     
  10. Phil o'Soph

    Phil o'Soph Kbyte

    Registriert seit:
    31. Oktober 2004
    Beiträge:
    335
    Nana, ein einfaches Danke reicht -- zum Anbeten musst Du Dich an ein paar Instanzen über mir wenden :)

    Hat bei mir über 30 Minuten gedauert, wenn ich mich recht erinnere. Solltest Du mit dem IE unter Windows XP SP2 unterwegs sein, guck mal hier:
    http://www.heise.de/security/news/foren/go.shtml?read=1&msg_id=6922676&forum_id=69423

    Vielleicht ist der Download dann nicht so dringend und Du kannst auf eine Heft CD warten.

    Ist in erster Linie für Entwickler wichtig. Mir ist noch keine Seite untergekommen, die mit Java 5 nicht funktioniert.

    Phil o'Soph
     
  11. pcinfarkt

    pcinfarkt Viertel Gigabyte

    Registriert seit:
    19. August 2004
    Beiträge:
    4.096
    @ Phil o'Soph,

    Danke!! Du hast das bestimmt besser erklärt! In dem Link der ersten Antwort stand bereits alles.
     
  12. Kurt W

    Kurt W Kbyte

    Registriert seit:
    22. April 2001
    Beiträge:
    397
    Ja, man muss es halt nur kapieren! :heul:
    Da ich im Vorfeld den IE mit VM verwendet habe, sagten mir die verschiedenen Java Versionen überhaupt nichts. Zumal PC Welt in keinem Wort von der Version 1.5.0 gesprochen hat, sondern nur von den notwendigen Update 1.4.2_06.
    Ich konnte daher zuerst mit deinem Link zu der Version 1.5.0 überhaupt nichts anfangen.

    @ Phil o'Soph

    Mit der geschätzten Downloadzeit von ca. 30 Minuten lagst du Goldrichtig!

    Grüße Kurt
     
  13. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Ich vertehe sowieso nicht, warum die JREs von Sun im Laufe der Zeit immer größer geworden sind. Die MS-Java VM war wesentlich kleiner und gleichzeitig schneller.Dann muss man jusched unter msconfig erstmal wieder deaktivieren. Ist alles wenig erquicklich, was von Sun kommt.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen