Kann ich Windows XP SP2 Image in 2 primäre Partition zurückspielen ???

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von HRoch, 28. August 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. HRoch

    HRoch Byte

    Registriert seit:
    26. Juni 2004
    Beiträge:
    20
    Hallo zusammen,
    ich habe eine Festplatte mit einer Größe von 160 GB. Da ist es naheliegend, mehrerer Betriebssysteme mit Hilfe versteckter Partitionen nebeneinander zu installieren. Für die Erstellung verwende ich Partition Magic 8.01 + Boot Magic 8 als Bootmanager. Bisher hatte ich so Windows ME, Windows 2000 und Windows XP nebeneinander betrieben und ohne Probleme benutzt. Weil die Installation des neuen SP2 mein XP vollkommen zerschossen hat, habe ich dann beschlossen Windows XP mit einer Boot-CD + incl. SP2 vollkommen neu zu installieren, die wichtigsten Basisinstallationen und Konfigurationen vorzunehmen und als Basisimage für den Fall, daß mal garnichts mehr gehen sollte, für eine schnelle Wiederherstellung zur Verfügung zu haben. Das war die hoffenlich nicht zu lange Vorrede!!!!. Basisimage deswegen, da ich mit dem Image auch die usprüngliche Windows 2000 Installation ersetzen wollte mit dem Ziel, zwei Windows XP auf dem Rechner zu haben, die ich dann unterschiedlich nutzen wollte, eines für Spiele, Brennen etc, daß andere ausschließlich fürs Programmieren.
    Gesagt, getan, ich habe das Image auf die 2. primäre Partition zurückgespielt und das 2. Windows XP ganz normal über den Bootmanager starten können. Anschließend habe ich Änderungen an den Benutzerkonten vorgenommen und einige Programme entsprechend dem anderen Verwendungszweck nachinstalliert. Und jetzt kommts! Anschließend habe ich mein 1. Windows XP aufgerufen und feststellen müssen, daß sich die Benutzerkonten in der Anmeldmaske vom 2. Windows XP auf das erste übertragen hatte(mit Bildern aus dem 1.), die Aufstellung über installierte Software der des 2. entsprach, sich die Benutzerkonten nicht mehr aufrufen ließen(nur über Verwaltung), die Suchfunktion ihren Dienst eingestellt hat und diverse Services sich nicht mehr starten ließen.
    Hat jemand von euch dafür eine plausible Erklärung. Kann ich etwa ein Image nur in die gleiche Partition zurückspielen, weil das Betriebssystem bei der Installation diverse Speicheraddressen der aktuellen Partition sich merkt?
    Tut mir leid, aber kürzer ging es leider nicht.
    Für Tipps zur Lösung meines Problems im Voraus besten Dank

    Heiconst
     
  2. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Womit hast du dein Image erstellt ? Ich hatte - allerdings nicht XP-SP2, sondern SP1 mit Hilfe von Partition Magic und dem Partition -Kopieren-Feature in einen freien Speicherbereich kopiert, so dass dann anschließend eine funktionsfähige Klon-Variante zur Verfügung stand. Wichtig ist bei solchen Aktionen, dass die ARC-Pfade in der boot.ini angepast werden, damit auch auf die richtige Partition verwiesen wird. Ich könnte mir z.B. vorstellen, dass hier dein Fehler liegt. D.h., du bekommst gar kein anderes XP zu sehen, sondern der Pfad in der boot.ini verweist auf das ursprüngliche.Vielleicht solltest du beide boot.inis mal posten.
     
  3. manfredgt

    manfredgt Halbes Megabyte

    Registriert seit:
    9. Oktober 2002
    Beiträge:
    559
    Wenn Du von LW C: ein Image erstellst, verweisen die Pfade in der Registry und den .ini - Dateien auf C:
    Wenn Du das Image dann auf D: einspielst, verweisen immer noch alle Pfade in der Registry usw. auf C:
     
  4. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Er schreibt :

    Deshalb kann das mit der Laufwerksproblematik keine Rolle spielen. Das ist nur bei der Installation in eine erweiterte Partition von Bedeutung. Bei primären Partitionen ist die aktive primäre Partition immer C:



     
  5. HRoch

    HRoch Byte

    Registriert seit:
    26. Juni 2004
    Beiträge:
    20
    Zunächst vielen Dank für eure Anteilnahme.
    Die boot.ini in der 3. primären Partition sah natürlich so aus, wie sie nicht aussehen durfte, nämlich:
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
    d.h. sie entsprach der 2. primären Partition, von der ich das Image gezogen habe. Allerdings hat mein Versuch, den Partitionshinweis in "(3)" im nachhinein abzuändern nichts mehr gebracht, die 3. Partition ist hin.
    Welchen Weg schlage ich jedoch am besten ein, um mein Ziel, eine Kopie des 1. Windows XP aus der 2. in der 3. primären Partition abzulegen.
    a) wie Franzkat es beschrieben hat, nämlich mit Partition Magic die Partition zu kopieren oder
    b) mein Image auf die 3. Partition zurückzuspielen
    In beiden Fällen wird dann aber die boot.ini immer noch auf die 2. Partition verweisen, es sei denn, ich würde die Änderungen an der boot.ini vornehmen, bevor ich sie verstecke und mit dem Bootmanager boote.

    Wann hast du die boot.ini geändert, Franzkat? Bereits vor dem Kopieren der Partition?

    Vielen Dank im Voraus

    heiconst


     
  6. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Ich hab es genauso gemacht, wie du es angedeutet hast : Ich habe die boot.ini vorher angepasst, dann die Partition kopiert und hinterher wieder den originalen Zustand der boot.ini auf der Ausgangspartition hergestellt.

    Übrigens gibt es auch ein schönes Tool, womit man sogar von einer DOS-Bootdiskette aus, die boot.ini auf NTFS-Systemen editieren kann :


    editbini.exe

    http://www.terabyteunlimited.com/utilities.html
     
  7. HRoch

    HRoch Byte

    Registriert seit:
    26. Juni 2004
    Beiträge:
    20
    Hallo franzkat,
    es hat geklappt und zunächst einmal vielen Dank für Deine Hinweise.
    Zwar konnte ich meine 2. Windows XP Installation, von der ich auch schon ein Image angefertigt hatte, durch Korrektur der boot.ini mit dem Tool editbini.exe nicht mehr wiederherstellen(die war wohl zu dem Zeitpunkt schon hin und ich habe es garnicht bemerkt), aber das anschließende Clonen meiner Basiskonfiguration hat dann anschließend hingehauen und zwar wie folgt.
    Kopie des Basisimage auf die 2. primäre Partition
    Kopie der 2. primären Partition auf die freie 3. primäre Partition mit Partition Magic.
    Korrektur der Partitionsangaben in der boot.ini der 3. Partition mit editbini.exe von einer DOS-Startdiskette aus.
    Und schon konnte ich beide Windows XP's wieder durchstarten.

    Ein schönes Wochende

    HRoch


     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen