KDE2.2 Update unter Suse 7.2

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von almut39, 19. August 2001.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. almut39

    almut39 Byte

    Registriert seit:
    14. April 2001
    Beiträge:
    47
    Hallo!
    Habe mir vom Suse Server die rpm-Dateien für den KDE2.2
    geladen und mit Yast installiert.
    Die anfängliche Freude über die Verbesserungen und das funktionieren von Features die vorher nicht klappten, wurde jedoch durch neue Fehler die nach dem Update auftraten, sehr getrübt.

    1.
    In der Suse Hilfe unter KDE funktioniert die Suchenfunktion nicht mehr. Es wird folgende Fehlermeldung ausgegeben:
    "Es gibt anscheinend eine Fehleistellung. Sie haben Konqueror mit text/html verknüpt, aber das Programm kann diesen Dateityp nicht verarbeiten."

    2.
    Bei starten des KDE2.2 taucht folgende Fehlermeldung auf:
    Sound server informational message:
    Error while initializing the sound driver:
    device /dev/dsp can\'t be opened (No such device)
    The sound server will continue, using the null output device.

    Der Sound funktioniert auch nur teilweise. TV-Karten Ton ist da.
    Wav Dateien lassen sich nur nach mehrmaligen manuellen starten des Soundservers abspielen.

    Hat jemand die gleichen Probleme?
    Kann mir jemand weiterhelfen?

    mfg
    almut
     
  2. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Hallo Almut !
    Ich weiß zwar nicht genau wie, habe es aber jetzt ohne Änderung in der Datei XSetup hinbekommen.

    Gruß Rene
     
  3. almut39

    almut39 Byte

    Registriert seit:
    14. April 2001
    Beiträge:
    47
    Hallo Steffen,
    hoffe, daß ich helfen kann.
    Ich mache erst mal einen neuen Thread auf.
    Kde 2.2 Update unter Suse 7.2 (II).
    Dort lesen wir uns wieder.
    mfg
    almut
     
  4. SRE

    SRE Byte

    Registriert seit:
    25. September 2000
    Beiträge:
    33
    Danke für den Tipp! Habe es endlich auch geschafft das KDE 2.2 samt meiner Soundblaster 64 zum Laufen zu kriegen. Deine Anleitung war sehr hilfreich. Ich habe es nicht im Runlevel 3, sondern in einem alternativen Desktop gemacht - ganz bequem mit Yast1.
    Vor lauter Übermut, dass der Sound jetzt so schön funzt, habe ich mir auch von NVIDIA die RPMs für die Hardware-Beschleunigung der Grafikkarte runtergeladen und glx aktiviert. Es funktioniert soweit ganz ordentlich, aber
    1. bleibt jetzt gelegentlich mein Opera hängen und bringt das ganze System zum Stillstand.
    2. beim Runterfahren schaltet die Grafikkarte nicht mehr in den Textmodus um - man sieht nur eine streifig-bunte Leiche der KDE 2-Oberfläche. Hast Du da irgenwelche Tipps?

    Gruss

    Steffen
     
  5. almut39

    almut39 Byte

    Registriert seit:
    14. April 2001
    Beiträge:
    47
    Hallo Rene,
    betrifft Konsolenfenster!
    In der Supportdatenbank von Suse gibt es eine Anleitung "xconsole beim Start von X entfernen".
    Hierzu müssen in /usr/lib/x11/xdm/Xsetup
    die letzten vier Zeilen der Datei auskommentiert werden.
    mfg
    almut
     
  6. almut39

    almut39 Byte

    Registriert seit:
    14. April 2001
    Beiträge:
    47
    Hallo,
    ich habe die Basispakete mal mit dem Paketmanager untersucht,
    da bestätigt sich die Anzeige des Kontrollzentrums nicht.
    Bestimmt ein kleiner Fehler im Kontrollzentrum.
    mfg
    Almut
     
  7. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Steht im Kontrollzentrum "KDE Version: 2.2.1pre" und das "pre" wird ja bestimmt für Preview stehen.

    Ich hatte ja erst das KDE Paket von KDE.de runtergeladen und irgendwann heute früh (beim rumprobieren) kam dann auf englisch die Meldung das das aRts Modul nicht zur installierten kdelibs kompatibel ist (oder so ähnlich) obwohl ich eigentlich das komplette KDE-Paket installiert hatte.
     
  8. almut39

    almut39 Byte

    Registriert seit:
    14. April 2001
    Beiträge:
    47
    Hallo Rene,
    Das Problem mit dem Konsolenfenster hab ich mitunter auch noch. Mal schließt es sich und mal nicht. Die Ursache ist für mich im Moment noch unklar. Sollte sich sich noch was ergeben, poste ich das hier noch mal.

    Woher weißt Du, daß die letzten rpms auf KDE 2.2.1 beta basieren? Ich finde es überhaupt von Suse unmöglich, daß die Dateien ständig geändert werden und sie keinen Ton dazu sagen, welche Fehler behoben wurden.
    mfg
    Almut
    [Diese Nachricht wurde von almut39 am 09.09.2001 | 16:18 geändert.]
     
  9. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    So jetzt habe ich die SUSE Pakete installiert und jetzt funktioniert es fast so wie es sein sollte. Mich stört nur das das Konsolenfenster nicht mehr minimiert wird und das es doch noch ein paar Stellen gibt die nicht übersetzt wurden.

    Gruß Rene

    PS: Die SUSE Pakete basieren auf KDE 2.2.1 beta.
     
  10. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Hi Almut,

    habe mich auch an die Installationsanleitung gehalten, bekomme aber trotzdem die Fehlermeldung wenn ich den Soundserver gleich mit KDE hochfahre.
    [Diese Nachricht wurde von ReneW am 09.09.2001 | 10:37 geändert.]
     
  11. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Updaten kann so schwer sein. Bin ich froh, dass ich Debian benutz und diesen RPM-Scheiss nicht hab. Mit dem KDE von Debian hab ich keine Probleme und APT macht updaten kinderleicht.
    Was wollt ihr eigentlich mit dem Soundserver? Stellt das Teil einfach ab, der nervt eh nur und blockiert Nicht-KDE-Programme. Wenn man als User die Lautstärke ändern will, muss man Schreibrechte auf /dev/mixer* haben.
    [Diese Nachricht wurde von Marsch am 09.09.2001 | 10:25 geändert.]
     
  12. almut39

    almut39 Byte

    Registriert seit:
    14. April 2001
    Beiträge:
    47
    Hi, Rene

    Ja, wie schon geschrieben funktioniert jetzt alles wie es sein sollte.
    Auch artsd verursacht keine Probs. mehr.
    mfg
    almut
     
  13. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Das stimmt alles bei mir, ich glaube ehr das bei de KDE2.2 Konfiguration was schief läuft, deaktiviere ich nämlich die Option "Soundserver mit KDE hochladen" wird erst KDE2.2 vollständig geladen und dann der Soundserver (mit Sound bzw. Ton).
     
  14. Reaper-TUX

    Reaper-TUX Byte

    Registriert seit:
    9. Mai 2001
    Beiträge:
    88
    - /dev/dsp0 muß auf user: root und group: audio gesetzt sein
    - Alle user die sound haben sollen müssen in die group audio
    - Die Soundkarte muß natürlich in den kernel fest eingebunden oder als modul geladen werden.
     
  15. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Bei mir gibt es eine Datei "dsp" die mit "dsp0" verlinkt (verknüpft) ist und ich bekomme trotzdem diese Fehlermeldung. Hast Du vielleicht noch eine Idee ??
     
  16. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Funktioniert bei der der Soundserver ?? Ich habe jetzt nämlich erstmal das laden mit KDE deaktiviert damit ich überhaupt Sound habe
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen