Kein Zugriff auf Yast als Root

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von xrittm, 1. Februar 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. xrittm

    xrittm Byte

    Registriert seit:
    1. Februar 2005
    Beiträge:
    12
    Ich habe Suse in der Version 9.1. Seit der Installation eines Paketes ist es mir nicht mehr möglich Yast zu öffnen. Wenn ich versuche Yast aus einer Shell zu starten, erscheint folgende Fehlermeldung:

    Error loading language plugin /usr/lib/YaST2/plugin/libpy2lang_perl.so: libperl.so: cannot open shared object file: No such file or directory
    Segmentation fault at /usr/share/YaST2/clients/menu.ycp:27
    /sbin/yast: line 185: 9950 Speicherzugriffsfehler $ybindir/y2base menu ncurses

    Wie kann ich dieses Problem beheben, wer kann mir helfen???
     
  2. Mylin

    Mylin Viertel Gigabyte

    Registriert seit:
    20. Juni 2003
    Beiträge:
    2.757
    Hast du das Paket über die Konsole schon deinstalliert?
     
  3. xrittm

    xrittm Byte

    Registriert seit:
    1. Februar 2005
    Beiträge:
    12
    Nein, wie geht das?
     
  4. Mylin

    Mylin Viertel Gigabyte

    Registriert seit:
    20. Juni 2003
    Beiträge:
    2.757
    rpm -e <Paketname>
     
  5. xrittm

    xrittm Byte

    Registriert seit:
    1. Februar 2005
    Beiträge:
    12
    Und wie kann ich ohne Yast den Paketnamen wiedererkennen (Ich hab' in Yast nach Basic gesucht und den dort gefundenen Basic-Compiler installiert).
     
  6. xrittm

    xrittm Byte

    Registriert seit:
    1. Februar 2005
    Beiträge:
    12
    Ich hab' unerdessen den Paketnamen bei der Suse Installation eines Kollegen herausgefunden. Es heisst "GAMBAS". Ich habe es deinstalliert, aber es kommt immer noch die selbe Fehlermeldung
     
  7. Mylin

    Mylin Viertel Gigabyte

    Registriert seit:
    20. Juni 2003
    Beiträge:
    2.757
    Na dann mal Paket yast2-perl-bindings neu installieren.
     
  8. xrittm

    xrittm Byte

    Registriert seit:
    1. Februar 2005
    Beiträge:
    12
    OK. Wie heisst das Paket genau?
     
  9. Mylin

    Mylin Viertel Gigabyte

    Registriert seit:
    20. Juni 2003
    Beiträge:
    2.757
  10. xrittm

    xrittm Byte

    Registriert seit:
    1. Februar 2005
    Beiträge:
    12
    Jetzt kommt nur noch:

    Segmentation fault at /usr/share/YaST2/clients/menu.ycp:27
    /sbin/yast: line 185: 9950 Speicherzugriffsfehler $ybindir/y2base menu ncurses

    Und jetzt?
     
  11. Mylin

    Mylin Viertel Gigabyte

    Registriert seit:
    20. Juni 2003
    Beiträge:
    2.757
  12. xrittm

    xrittm Byte

    Registriert seit:
    1. Februar 2005
    Beiträge:
    12
    Soweit so gut: Yast läuft wieder, aber ich kann nix damit machen, stattdessen erscheint die Fehlermeldung:

    Segmentation fault at runlevel/ui.ycp:51
    /sbin/yast2: line 185: 10261 Speicherzugriffsfehler $ybindir/y2base $module "$@" qt -geometry "$Y2_GEOMETRY" $Y2QT_ARGS
     
  13. Mylin

    Mylin Viertel Gigabyte

    Registriert seit:
    20. Juni 2003
    Beiträge:
    2.757
  14. xrittm

    xrittm Byte

    Registriert seit:
    1. Februar 2005
    Beiträge:
    12
    Mylin, you're the best...
     
  15. riker187

    riker187 ROM

    Registriert seit:
    28. März 2005
    Beiträge:
    1
    Ich habe das gleiche Problem:

    Segmentation fault at /usr/share/YaST2/clients/menu.ycp:27
    /sbin/yast: line 185: 17931 Getötet $ybindir/y2base menu ncurses

    beim aufrufen von Yast bzw. Yast2. Ich habe ebenfallls versucht wie beschrieben die 3 Module nue zu insatllieren, aber ich komme nicht so richtig damit klar...

    Wenn ich installieren will:
    www:~/install/yast2 # rpm -i yast2-perl-bindings-2.9.25-8.i586.rpm
    package yast2-perl-bindings-2.9.25-8 is already installed

    Wenn ich deinstallieren will:
    www:~/install/yast2 # rpm -e yast2-perl-bindings-2.9.25-8.i586.rpm
    error: package yast2-perl-bindings-2.9.25-8.i586.rpm is not installed
    (obwohl es das original Packet von der CD ist...)

    und Wenn ich mit "-F" arbeite, klapp es zwar, ändert aber nichts am Fehlerbild...

    kann mir da noch jekamd weiter helfen?

    Gruß, Jens
     
  16. MissionPUA

    MissionPUA ROM

    Registriert seit:
    23. August 2006
    Beiträge:
    3
    wird zwar Jens nicht mehr interessieren ;) aber es soll ja Leute geben die ende 2006 noch so ein Problem haben :)

    also von dem auf der ersten Seite angebenben FTP-Server die yast2-2.10.27....rpm
    und
    yast2-ncurses-2.10....rpm
    herunter landen und per
    rpm -U yast2..... beide nach einander installieren

    dann kommt man zumindest wieder in die oberfläche rein (terminal) und dann eben die anderen die man brauch auch updaten

    Viel Spaß

    Mission
     
  17. neppo1

    neppo1 Halbes Gigabyte

    Registriert seit:
    12. Februar 2006
    Beiträge:
    5.175
    leg deine dvd oder cd ins laufwerk
    tu so als wenn du neu installieren willst
    suse meldet sich mit der meldung das schon
    eine version installiert ist und gibt dir mehrere
    optionen, unter anderem system reparieren
    das klickst du an,dann bekommst du ein ganzen
    wusst von fehler meldungen also was alles defekt ist
    und suse fängt an zu reparieren.
    dannach müsste dein system wieder laufen

    mfg
    neppo1
     
  18. MissionPUA

    MissionPUA ROM

    Registriert seit:
    23. August 2006
    Beiträge:
    3
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen