Keine CD-ROM Erkennung unter DOS

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von PC-Weltler, 10. Februar 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. PC-Weltler

    PC-Weltler Kbyte

    Registriert seit:
    3. März 2001
    Beiträge:
    204
    Ich besitze einen P200 mit Win95. Wenn ich nun versuche, mein CD-ROM Laufwerk (LG 8083B) unter DOS anzusprechen, ist dies leider nie bekannt. Fehlt mir da vielleicht ein DOS-Treiber? Aber wie installiere ich den bzw. woher kann ich einen bekommen?

    Für jede Antwort bin ich Euch sehr dankbar.
     
  2. zuse2218

    zuse2218 Byte

    Registriert seit:
    12. November 2001
    Beiträge:
    59
    hi,
    du benötigst ein hardwaretreiber, damit die hardware das lw erkennt, und ein softwaretreiber, damit die DOS - software den treiber ansprechen kann.
    diese treiber bekommst du normalerweise mit dem kauf eines cd-lw auf diskette.
    du kannst sie auch downloaden. einmal bei deinem cd-lw hersteller und zum anderen von mircrosoft bzw. caldera-dos

    _______________________________________________________
    einbinden des hardwaretreibers in die datei config.sys:
    angenommen dein cd-lw treiber heisst cdrom.sys. den kopierst du in das hauptinhaltsverzeichnis c:
    dann öffnest du mit dem win95 editor oder mit einem textverarbeitungsprogramm die datei c:\config.sys und fügst die folgende zeile ein:
    DEVICE=C:\CDROM.SYS /D:MSCD001

    [so sieht es bei mir aus:
    ?"CD-ROM (J/N)?"DEVICEHIGH=C:\SBPRO\DRV\MTMCDAE.SYS /D:MSCD001 /P:340 /I:10 /T:7 /A:0 /M:20 /L:G
    da ich keine eide-schnittstelle mehr frei habe, habe ich das cd-lw an die soundkarte angeschlossen. ]
    *****************************************************

    einbinden des hardwaretreibers in die datei autoexec.bat:
    angenommen dein cd-lw treiber heisst mscedex.exe. den kopierst du in das hauptinhaltsverzeichnis c:
    dann öffnest du mit dem win95 editor oder mit einem texverarbeitungsprogramm die datei c:\autoexec.bat fügst die folgende zeile ein:

    C:\DOS\MSCDEX.EXE /S /D:MSCD001 /V /M:15

    [so sieht es bei meiner autoexec.bat aus:
    ?"CD-ROM von Novell im oberen Speicher (J/N) ?"
    LH C:\NWDOS\NWCDEX.EXE /D:MSCD001 /M:16 /F:30 ]

    die parameter meiner konfiguration musst du nicht verwenden.
    ausserdem fragt mich novell-dos beim bootvorgang ob ich ein cd-lw haben möchte.

    hoffe du bist ein schritt weiter

    KH

    p.s.
    es ist möglich, das win95 die mscdex.exe im win95 verzeichnis hat. die kannst du für die autoexec.bat datei nehmen.
     
  3. Jörn Stadelmann

    Jörn Stadelmann Viertel Gigabyte

    Registriert seit:
    7. April 2001
    Beiträge:
    4.450
    Sieh mal in deiner Diskettensammlung nach, ob du eine Treiber Diskette für dein CD-ROM hast. Erstelle vorher eine Sicherungskopie der Dateien
    c:\autoexec.bat
    c:\config.sys

    Dann legst du die Diskette ein und fürst die INSTALL.EXE aus. Nun sollte der Zugriff unter DOS auf das laufwerk (nach einem Neustart) funzen. Allerdings hast du jetzt das Problem, das deine Laufwerke unter Windows im MS-DOS Kompatibilitäts-modus Laufen....

    Hierzu solltest du dich mal mit der MSDOS-Hilfe bezüglich der Mehrfachkonfiguration < Menu, MenuItem, MenuDefault, Common, If Config==, goto > vertraut machen ;-)

    Außerdem solltest du hierzu in der MSDOS.SYS den Eintrag

    BootGUI=1
    in
    BootGUI=0
    ändern, sowie in der Autoexec.bat in der Win95 starten Sektion ein

    WIN

    einfügen.

    Wenn du noch Fragen hast, poste nochmal.

    J2x
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen