Knoppix von der Platte starten

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von edwi, 27. September 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. edwi

    edwi ROM

    Registriert seit:
    27. September 2004
    Beiträge:
    1
    Durch Eingabe von

    knoppix tohd=/dev/hda5

    habe ich Knoppix auf einer FAT32-Partition installiert.

    Auf diese Partition habe ich die Konfig-Datei und mein Home-Verzeichnis gespeichert.

    So weit so gut.

    Beim nächsten booten durch

    knoppix fromhd=/dev/hda5 myconfig=/dev/hda5 home=/dev/hda5

    läuf knoppix wunderbar flott von der Platte, das CD-Laufwerk ist wieder frei und die Konfigurationsdaten sind auch OK! Nicht jedoch das home-Verzeichnis. Dieses wird nicht erkannt!

    Lege ich mein home-Verzeichnis zuvor auf einen USB-Stick (/dev/sda4), dann ist nach

    knoppix fromhd=/dev/hda5 myconfig=/dev/hda5 home=/dev/sda4

    auch alles wieder OK.

    Meien Frage: Aus welchem Grund wird das home-Verzeichnis auf /dev/hda5 nicht erkannt?

    Wer weiß Rat? Wie läßt sich dieses Problem lösen?
     
  2. einmaltest

    einmaltest ROM

    Registriert seit:
    30. September 2004
    Beiträge:
    2
    Hallo,

    da du ja bemerkt hast, das die Funktion an für sich funktioniert, würde ich folgendes vorschlagen:
    Verringern der /dev/hda5-Größe auf 800 MB, den neuen Platz (/dev/hda6) als Home Einbinden
    Voila, Problem gelöst.

    Da es sich bei /dev/hda5 um eine log.Part in der erweiterten Partition handelt, kommt es da auf eine mehr oder weniger nicht an.

    Nun der "technische" Hintergrund, warum deine Lösung nicht funktionieren konnte:
    Knoppix sucht auf allen /dev/ nach einer Datei, welche KNOPPIX heißt und bindet dieses Device als /cdrom ein.
    Nun versucht es noch alle anderen Partitionen einzubinden (
    /dev/hda1 nach /mnt/hda1,
    /dev/hda2 nach /mnt/hda2 ...
    /dev/hda5 nach /mnt/hda5 ? Klappt nicht, da das Device schon auf /cdrom hängt,
    /dev/hda6 nach /mnt/hda6, ...)
    Nun wird auf allen /mnt/ nach einer config.tbz gesucht. Leider ist aber /dev/hda5 nicht auf /mnt/hda5, und so wird deine Datei nicht gefunden.

    Versuch doch mal in einer Shell folgenden Befehle:
    su
    mount /dev/hda5 /mnt/test

    Die Fehlermeldung bekommt auch das start-script, und geht weiter.


    Aber wo wir jetzt mal gerade so locker plauschen...

    Es gibt eine offizielle KNOPPIX-Seite, welche sich unter http://www.knopper.net/knoppix verbirgt. Dort gibt es einen Link zu einem Forum unter www.linuxtag.de/forum welches aber leider durch Umstrukturierungen auf dem Server "verloren" gegangen ist. Leider hat Klaus noch keine Zeit gehabt, seine (hoffentlich) vorhandenen BackUps einzuspielen, und daher hat sich jemand bereit gefunden, etwas WebSpace zur Verfügung zu stellen, und ein neues/temporäres Forum aufzubauen. (Danke an schock) Das Forum füllt sich nach und nach, und es sind einige alte Hasen vom original Forum wieder mit dabei.
    Vielleicht sieht man sich da ja mal http://81.169.132.167/knoppix/forum/index.php


    Grüsse RalfonLinux
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen