Kurioses Verhalten von Win2000 nach Linux Inst.

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von inscene, 26. Juni 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. inscene

    inscene ROM

    Registriert seit:
    26. Juni 2004
    Beiträge:
    5
    Hi,

    ich bin zwar kein Debian Neuling, aber stoße hier und dort mal auf einzelne Probleme, diesmal hängt es direkt mit der Installation zusammen, bzw. mit dem Verhalten von Windows 2000 nach der Partitionierung unter der Installations-Routine von Debian testing (Network Image). Ich weiß nicht so genau, ob es ein Windows-, oder ein Debian-Problem ist, ich poste es dennoch mal hier, in der Hoffnung, dass mir weitergeholfen werden kann.

    Meine Festplattenaufteilung sieht folgendermaßen aus:

    hda1 (vfat - Windows 2000 Systempartition)
    hda2 (vfat)
    hda3 (ext3 - Bootflag - Mountpunkt / )
    swap

    Bei der Debian-Installation habe ich hda3 explizit die Bootflag zugewiesen.

    Seitdem ich die Platten partitioniert habe, dauert der Startvorgang von Windows 2000 ungewöhnlich lange, der Explorer reagiert zäh, bis die Laufwerke angezeigt werden, vergehen schon mal 1-2 Minuten auf meinem 2 GHZ Athlon XP Rechner, was ungewöhnlich ist.

    Bevor ich zum ersten mal Debian installiert habe, waren hda3 und swap noch fat32 Partitionen, hab die erst im Debian Installationsprogramm nach ext3 und swap umgeändert. Als ich wieder zu Windows zurückgekehrt bin, tauchen die beiden Partitionen, die ich ja umgewandelt habe, immer noch im Explorer auf. Zugriff habe ich auf die beiden zwar nicht, aber sie tauchen dort auf, was normalerweise nicht geschehen soll. PartitionMagic erkennt die beiden Partitionen korrekt, nur Windows selbst hat damit Schwierigkeiten.

    Gerade eben habe ich die 2 Partitionen mal von PartitionMagic löschen lassen, in freien Speicher umgewandelt und dann wieder von Debian neu partitionieren lassen. Jetzt zeigt Windows 2000 diese nicht mehr unter Arbeitsplatz an, aber das zähe Verhalten bleibt bestehen. Ich gehe davon aus, dass Windows nach den 2 Laufwerken sucht, oder versucht, darauf zuzugreifen, aber letztendlich nichts damit anfangen kann, bin mir da aber nicht sicher.

    Was lief falsch? Übrigens verhält sich auch die fstab sehr merkwürdig. Ich kann dort tun und lassen was ich will, ich bekomme keinen Zugriff auf die beiden fat32 Partitionen (hda1 und hda2) als User, nur als root, obwohl ich auch User-Zugriff eingerichtet habe.

    Vielen Dank schon mal für Antworten.
     
  2. AntiDepressiva

    AntiDepressiva CD-R 80

    Registriert seit:
    22. April 2003
    Beiträge:
    7.651
    Also als Antwort habe ich nur eine Frage:

    Was hat das ganze Chaos mit Windows 2000 zu tun?

    - Partition Magic gehört nicht zu W2K
    - Debian gehört nicht zu W2K
    - fstab auch nicht...
    - hda1,hda2 und hda3 sind nicht wirklich W2K Begriffe...
    - wo finde ich "root" unter W2K?

    Also wo sind jetzt die W2K Probleme, wegen denen Du hier im Windows 2000 Forum postest?
     
  3. inscene

    inscene ROM

    Registriert seit:
    26. Juni 2004
    Beiträge:
    5
    Es ist durchaus ein Windows 2000 Problem. Den Beitrag hab ich unverändert aus dem Debian Forum kopiert, wo ich bereits das Problem geschildert habe.

    http://www.debianforum.de/forum/viewtopic.php?p=158627

    Wie es aussieht, hat Linux nix damit zu tun und ist eine Windows only Geschichte.
     
  4. AntiDepressiva

    AntiDepressiva CD-R 80

    Registriert seit:
    22. April 2003
    Beiträge:
    7.651
    Klar...
    Hinundherpartitioniert...
    Mit Drittanbietertools...
    Linux mit im Spiel...
    Da verbleibt sicher ein sauberes Dateisystem...


    Klar, daß muß ein Windowsproblem sein...
    Das wäre auch pasiert, wenn man ein sauberes Windows-System gebaut hätte...

    *rabauz* irgendetwas hat mich da ganz hart erwischt...

     
  5. inscene

    inscene ROM

    Registriert seit:
    26. Juni 2004
    Beiträge:
    5
    Es ist ein frisches Windows 2000 mit insgesamt 4 Partitionen, die letzten 2 wurden gestern für Debian Linux geopfert und seitdem zickt Windows rum. Windows machts falsch, PM richtig. Wessen Problem ist es?
     
  6. AntiDepressiva

    AntiDepressiva CD-R 80

    Registriert seit:
    22. April 2003
    Beiträge:
    7.651
    Wer sagt, daß es PM richtig macht?
    Wer sagt, daß es Windows falsch macht?

    Installier' doch einfach W2K auf eine saubere Platte, ohne Einsatz irgendwelcher schrottigen Tools und ganz besonder OHNE auf die gleiche Platte Linux (und da besonders Debian!) zu installieren und beobachte das Verhalten.

    Sollte das immer noch auftreten ist es ein W2K Problem und dann poste die Probleme noch mal hier! Inklusiver Hardwaredaten und parallel installierter Software.

    Falls noch Probleme existieren...


    P.S. Was sagt Dir eigentlich diese Aussage:

    "Es ist ein frisches Windows 2000 mit insgesamt 4 Partitionen, die letzten 2 wurden gestern für Debian Linux geopfert und seitdem zickt Windows rum. "

    Seit der Installation von Debian?
    Das MUSS ein Windowsproblem sein...
     
  7. inscene

    inscene ROM

    Registriert seit:
    26. Juni 2004
    Beiträge:
    5
    Hast du überhaupt mein Urprungsposting gelesen? Wenn ja, hättest du dir das gerade sparen können.

    Nochmal zum mitschreiben:

    Es ist ein sauberes Windows 2000. Kein Linux auf der Platte, alles in Ordnung, keine Beanstandungen. 4 Partitionen, alle fat32 und das System läuft und läuft und... mit dem Speed, den ich erwarte.

    Jetzt kommt der Zeitpunkt, wo ich mir mal wieder seit langem Debian Linux installieren wollte, habe 2 Partitionen gekillt und an deren Stelle das Linux installiert.

    Unter Windows 2000 wurden diese 2 Partitionen fälschlicherweise immer noch im Explorer (Arbeitsplatz) angezeigt, obwohl diese da nicht mehr hingehören. Windows kann nicht mit ext3 und swap Partitionen umgehen, also sollen die da gefälligst verschwinden. Die Computerverwaltung (kein billiges Dritthersteller-Amateur-Schrottprogramm, sondern das Windows eigene Tool) bestätigt dieses merkwürdige Verhalten. Das ansteuern aller Partitionen ist sehr träge und dauert auch wieder ein paar Minuten, bis man überhaupt etwas machen kann.

    Jetzt die Frage: Warum zeigt mir PartitionMagic (dieses schrottige Billigprogramm) alles korrekt an? So wie ich es auch haben wollte? Wieso tut es Windows 2000 nicht?

    Gut, an dieser Stelle hab ich gemerkt - Aha, da stimmt was nicht, also schmeissen wir mal Debian wieder runter, bzw killen die 2 Linux Partitionen und sehen, was danach geschieht. Tada, Windows reagiert wieder so, wie es auch ursprünglich getan hat. Einwandfrei.

    Nun ja, danach mal die 2 letzten Partitionen komplett entfernt und das Debian Installationsprogramm die arbeit verrichten lassen und danach wieder das selbe Verhalten unter Windows, aber diesmal zeigt der Windows Explorer bzw. Arbeitsplatz die Laufwerke nicht an (fein gemacht), aber Windows startet immer noch unheimlich träge und zäh, was darauf hindeutet, dass das Problem immer noch nicht behoben ist.

    Würde ich an der Stelle wieder alles rückgängig machen (-> Windows 2000 only), wäre die Welt wieder in Ordnung.

    Erzähl mir nicht, dass Debian da Bockmist gebaut hat, das Linux selbst zickt nicht so derartig rum und PartitionMagic kriegt es schliesslich auch auf die Reihe, mir alles so anzuzeigen, wie es richtig sein sollte.

    Alles, was ich möchte, wäre zu wissen, wie man es hinbekommt, dass Windows die Linux Partitionen, die ich explizit vergeben habe, endlich mal "vergisst" und merkt "aha, da sind ja nur noch 2 Partitionen für mich da?!".

    Meine Finger tun jetzt ein bissl weh und hoffe mal, dass man mir jetzt ein wenig helfen kann... ein bissl frustrierend das ganze.
     
  8. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Handelt es sich bei den drei Partitionen um primäre Partitionen ? Wenn ja, warum ist die zweite FAT32-Partition als primäre Partition eingerichtet. Wenn es eine erweitere ist, wo liegt die logische Partition ? Wo liegt der Linux-Loader : Im MBR oder wird über den NT-Loader gebootet ?

     
  9. persilschein69

    persilschein69 Byte

    Registriert seit:
    26. Juni 2004
    Beiträge:
    57
    An franzkat:

    Er sagt hda1 bis hda4... Also sind es primäre Partitionen. Logische wären hda5 usw. Er wird mit einem Debian-Loader booten, da der umgekehrte Fall das Erzeugen eines Bootsects für Debian unter 2000 erfordert, alles klar?


    Ich bin zwar ein Troll, aber (an den User):

    Elegante Lösung durch geschickte Partitions-Wahl.

    hda1 FAT16 grösse= 300 NB (Aktiv) (=C)
    - erstellen mit Win98-Bootdisk (bootdisk.com hat images) OHNE Unterstützung
    - hier kommt selber kein System drauf, sondern nur die Loader, Bootsects etc.

    hda2 erweiterte Partition (mit w98) Rest der Platte MIT Unterstützung

    Jetzt beliebig viele logische Partitionen (zunächst sämtlich FAT32, also mit Unterstütz.) und alle mit W98 -Bootdisk anlegen (kein PartitionsNRmismatch)

    hda5 (=D)
    hda6 (=E)
    hda7 (=F) wird später ext3
    hda8 (=G wird später swap)

    Du installierst 2000 zuerst. Wählst (Ziel selber wählen) D: und konvertierst es später nach NTFS. E: kannst Du nachkonvertieren

    Dann installierst Du Debian (in den MBR von C:=hda1) und übernimmst den Bootsect (für LILO etc.) von 2000.

    C: LÄSST Du FAT16.

    Falls du Daten zwischen Debian und Win austauschen willst, wähle C: als FAT32 (= MIT Unterstützung) und entsprechend grösser. Späteres Automount.


    Mein Tipp: Lege mehr FAT32-Parts als Puffer (hintendran) an. Nach dem Strickmuster kannste dann Slack, BSD etc. auch noch an das Multibootsystem einbinden.

    Wie gesagt: Partitinieren und Formatieren NUR mit W98-Disk.
    NUR eine primäre (und die ist aktiv und FAT16/32).
    Den Rest in logische Parts (hda5 usw.)

    Damit haste ne saubere Part.Struktur für alle Gelegenheiten (äh Solaris braucht glaube ich zwingend weitere Primäre). PartMagic kann übrigens nur mit Fehlern ext2/3 -Systeme umpartitionieren. Pfoten weg im Zusammenhang ;-)
     
  10. inscene

    inscene ROM

    Registriert seit:
    26. Juni 2004
    Beiträge:
    5
    Genau.

    @persilschein69

    Danke für die ausführliche Hilfestellung. So etwas habe ich noch nie in Betracht gezogen, ist aber eine wirklich gute Idee. Werde das ausprobieren, sobald ich dazu komme.

    Derzeit ist es bis auf den ersten Teil deines Postings genau so, wie du es beschrieben hast.

    hda1 (= C:\) --- Windows 2000, primär, fat32
    hda2 (=D:\) --- Bunker für irgendwelchen Kram, auch fat32
    und dann eben hda3 für ext3 und danach der swap Speicher

    Das einzige, was dann noch erledigt werden müsste, wäre eine Partition für den Loader (in diesem Falle GRUB) freizuschaufeln, aber wäre kein allzu großer Aufwand. Im Moment ist der ja im Bootsektor.
     
  11. persilschein69

    persilschein69 Byte

    Registriert seit:
    26. Juni 2004
    Beiträge:
    57
    Ok.

    Du hast schon verstanden. Die zukünftige C: (=hda1) wird eine systemFREIE Partition.

    Dahinter ist es aber nicht so, wie ich vorgeschlagen habe. Dahinter sind nur logische in einer erweiterten (keine weiteren primären).

    Ein verschieben und vornedran eine primäre einfügen scheitert zudem an mehrerem.
    - Du hast schon 4 primäre (mehr geht nicht)
    - win wird system-Partition verschieben nicht verkraften

    Konkret: Sauber bei Null mit ner sinnvollen Grössenplanung ansetzen.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen