lilo-conf - Autostart Betriebssystem

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von knoppix-newbi, 9. September 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. knoppix-newbi

    knoppix-newbi ROM

    Registriert seit:
    9. September 2005
    Beiträge:
    4
    Hallo,
    hab heute mein erstes Linux-System überhaupt auf meinem PC installiert (Knoppix 3.7). Habe jetzt nur das Problem, dass ich die LiLo-Konfigurationsdatei anpassen möchte und nicht sicher weiß, was ich genau machen muss. Knoppix ist auf hda6 und WinXP auf hda1 (?) installiert. Möchte, dass Win automatisch startet, wenn ich beim booten nichts mache, zurzeit startet Knoppix automatisch. Außerdem möchte ich mehr Zeit für die Auswahl haben, muss ich dann "timeout=100" eingeben?
    Wer kann mir bitte helfen?
    Danke!
    Klaus

    Die lilo.conf sieht so aus:

    # /etc/lilo.conf - See: 'lilo(8)' and 'lilo.conf(5)',
    # --------------- 'install-mbr(8)', '/usr/share/doc/lilo/',
    # and '/usr/share/doc/mbr/'.

    lba32

    boot=/dev/hda

    root=/dev/hda6

    bitmap=/usr/share/lilo/debianlilo.bmp
    bmp-colors=1,,0,2,,0
    bmp-table=120p,173p,1,15,17
    bmp-timer=254p,432p,1,0,0

    install=bmp

    delay=20

    prompt
    timeout=50

    map=/boot/map

    vga=791

    default="Linux"

    image=/boot/vmlinuz
    label="Linux"
    initrd=/boot/initrd.img
    append="ramdisk_size=100000 init=/etc/init lang=de apm=power-off nomce quiet splash"
    read-only
    image=/boot/vmlinuz-2.4.27
    label="Linux(2.4)-1"
    initrd=/boot/initrd.img-2.4.27
    append="ramdisk_size=100000 init=/etc/init lang=de apm=power-off nomce quiet splash"
    read-only

    image=/boot/vmlinuz-2.6.7
    label="Linux(2.6)-2"
    initrd=/boot/initrd.img-2.6.7
    append="ramdisk_size=100000 init=/etc/init lang=de apm=power-off nomce quiet splash"
    read-only

    other=/dev/sda1
    label="WinXP/2K(sda1)"
    other=/dev/sda5
    label="WinXP/2K(sda5)"
    other=/dev/sdc5
    label="WinXP/2K(sdc5)"
    other=/dev/hdc1
    label="WinXP/2K(hdc1)"
    other=/dev/hdc5
    label="WinXP/2K(hdc5)"
    other=/dev/hda1
    label="Windows(hda1)"
    other=/dev/hda5
    label="Windows(hda5)"
    other=/dev/hda7
    label="Windows(hda7)"
    other=/dev/hda8
    label="Windows(hda8)"
    other=/dev/hda9
    label="Windows(hda9)"
     
  2. RaBerti1

    RaBerti1 Viertel Gigabyte

    Registriert seit:
    24. November 2000
    Beiträge:
    5.094
    Hi!

    Kaum Linux auf der HD und schon in die Tiefen abgetaucht... Nun ja, LiLo ist eigentlich out, grub ist der neuere Bootloader. Macht aber nix:

    delay= 60

    sollte die Wartezeit auf eine Minute bringen.

    Und

    default="Windows(hda1)"

    sollte das Win von hda1 starten.

    BTW:
    Wie kommst Du da eigentlich noch an diesen Alt-kernel 2.4.27 dran? Ist ja unglaublich...
    Und diese fürchterlich vielen Varianten mit installiertem Windows sind sicherlich auch nicht der Weisheit letzter Schluß. Schmeiß raus, was mit Sicherheit als überflüssig gelten kann.

    MfG Raberti
     
  3. knoppix-newbi

    knoppix-newbi ROM

    Registriert seit:
    9. September 2005
    Beiträge:
    4
    Hallo Raberti

    und schon einmal herzlichen Dank!

    Die vielen Varianten mit installiertem Windows sind lediglich HDD-Partitionen. Da ist kein Betriebssystem drauf. Kann ich die alle (z. B. "other=/dev/hda5
    label="Windows(hda5)") in der lilo-conf löschen damit die Liste nicht so lang ist?
    Der alte Kernel 2.4.27 wurde bei der Installation von Knoppix 3.7 automatisch installiert, übrigens aber auch zeitgleich der Kernel 2.6.7. Keine Ahnung, warum das so ist. Ich fang ja erst an... ;-)
    Da stellt sich mir direkt die Frage, wie man Knoppix/Linux einfach updaten kann??? Hast du da auch einen kurzen Tipp für mich?
    Danke!
    Klaus
     
  4. knoppix-newbi

    knoppix-newbi ROM

    Registriert seit:
    9. September 2005
    Beiträge:
    4
    Hmmm, hat leider alles nicht funktioniert. Weder delay=60 (und timeout=100), noch default="Windows(hda1)". Ist denn die lilo.conf im Verzeichnis /etc die Richtige?
     
  5. RaBerti1

    RaBerti1 Viertel Gigabyte

    Registriert seit:
    24. November 2000
    Beiträge:
    5.094
    Sorry,
    da muß ich Dich denn doch erstmal auf eine Konsole (das ist auf windowsisch die Eingabeaufforderung) verweisen, in die Du dann
    man lilo
    oder
    man lilo.conf

    eintippen solltest, danach Bestätigen mit Enter. Raus kommt man jeweils mit
    q

    Viel Erfolg!
    Feierahmd!

    MfG Raberti
     
  6. knoppix-newbi

    knoppix-newbi ROM

    Registriert seit:
    9. September 2005
    Beiträge:
    4
    Neee, hatte schon die richtige Datei angepackt. Da lilo aber mit "install=bmp" bootet, musste ich von der neuen lilo.conf erst ein bmp machen lassen. Jetzt läuft alles so wie gewünscht und sogar Kernel 2.6.7 wird jetzt verwendet.

    Danke noch einmal!

    Klaus
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen