Linux Erfahrungsbericht: Fujitsu Siemens

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von nocommentplease, 10. Januar 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. nocommentplease

    nocommentplease ROM

    Registriert seit:
    10. Januar 2002
    Beiträge:
    2
    Linux Erfahrungsbericht: PC "Fujitsu Siemens Highclass P 180 5 0-60/512"

    Am 4.1.2002 kaufte ich mir obigen Computer bei Saturn für 1179 EURO.

    Die Ausstattung im Detail:
    Intel Pentium 4 Prozessor 1,8 GHz,
    Chipsatz i845 ATX,
    512 MB SDRAM,
    Seagate 60 GB HD,
    64 MB nVidia Geforce2 MX-400 mit TV-OUT,
    Sound 16 Bit on board AC97,
    Samsung 16x18x DVD-ROM,
    LG Electronics 16x10x32x CDRW,
    Logitech Mouseman Wheel Mouse,
    Keyboard,
    Windows XP Home OEM (Recovery CD, Drivers CD),
    MS Works 2001 OEM (Word 2000 SR1, Works 6.0, Picture It! Foto,
    Encarta Weltatlas 2001, AutoRoute 2001),
    Nero 5.5.5.6 CD,
    WinDVD 3.1 FSC CD,
    MS Midtown Madness 2 CD,
    MS Crimson Skies CD,
    Norman Virus Control 5.2,
    AOL Saturn Edition

    Nachdem ich das vorinstallierte Windows XP auf drei CD-RWs mit Hilfe des
    eingebauten Brenners anfertigte, kam die SuSE Linux 7.3 Boot CD zum Zug:
    Ich partitionierte die 60 GB Platte in etwa zwei gleich große Teile,
    den ersten Teil sollte Windows XP bekommen, den zweiten Linux.
    (Dass für XP eine Neuinstallation angesagt war, brauche ich ja nicht zu
    erwähnen. Erstens hatte ich kein Tool zur Hand, das NTFS ohne
    Neuinstallation partitionieren könnte und zweitens traue ich der
    Vorinstallation sowieso nicht...)

    Als Größe für die Swap-Partition wählte ich 256 MB. Außerdem entschied
    ich mich für das Dateisystem ext3, schließlich will ich von Windows
    aus auch auf meine Linux Dateien zugreifen können, und Dank der
    Rückwärtskompatibilität zu ext2, kann ich unter Windows mit explore2fs
    auf meine Linux Partition zugreifen.
    Die Windows XP NTFS Partition läßt sich auch unter Linux mounten,
    obwohl in der SuSE Support Datenbank steht, dass dies nicht geht, wenn
    NTFS Version 2 verwendet wird:

    http://sdb.suse.de/de/sdb/html/dstark_linux_xp.html

    Das erste Problem war schnell ausgemacht: Linux wollte nicht booten,
    es blieb einfach hängen. Zum Glück haben die SuSE Entwickler die
    Bootoption "Failsafe" angeboten. Mit dieser gings dann. Es war
    übrigens die Option "disableapic" für ein erfolgreiches booten
    nötig ist. In der SuSE Support Datenbank findet sich ein DELL Board
    mit gleichem Fehler:

    http://sdb.suse.de/de/sdb/html/swiegra_delldimension8100.html

    Die Installation verlief unkompliziert, Hardware wurde automatisch
    erkannt oder ließ sich sehr einfach mit YaST2 konfigurieren.
    Entschied mich für die Standard-Software Installation, später
    installierte ich dann Fehlendes nach wie Netscape, Spiele etc.

    Den Bootmanager Lilo installierte ich mit Hilfe von YaST2 im Master
    Boot Record. Es wird die Warnung ausgegeben, dass Lilo unter Zylinder
    1024 installiert werden muss, oder dafür die Option "lba32" benötigt. Was
    bequem im Menü Optionen einstellbar ist.
    Auch den Menüpunkt "Windows XP" konfiguriere ich hier.

    Ein Problem stellte allerdings die Konfiguration des On Board AC97
    Soundchips dar: YaST2 erkannte ihn als "82820 820 (Camino 2) Chipset
    AC\'97 Audio Controller" und ließ sich scheinbar erfolgreich
    konfigurieren. Leider gab der MP3 Spieler xmms keinen Ton von sich...
    Schließlich fand ich heraus, dass AC97 des Intel Chipsatzes i845 noch nicht
    unterstützt wird:

    http://www.linuxhardware.org/features/01/11/12/2029218.shtml

    Zum Glück bietet Open Sound System einen Treiber an, der ist schnell
    heruntergeladen und einfach zu installieren: http://www.opensound.com
    Dieser erkennt meinen Soundchip als "Intel 815 ICH2 (Rev 1)", was zwar
    nicht ganz stimmt, aber trotzdem funktioniert.
    Im YaST2 Runlevel editor habe ich vorher die alsasound Module
    entfernt. (Der OSS Treiber hat eine Evaluierungszeit von 6 Monaten und läuft
    höchstens 3 Stunden am Stück. Die Vollversion kostet 45 US$.)

    Ich verlasse für einige Zeit meinen Rechner, als ich zurückkomme, sehe
    ich nur die KDE Login Maske. Wer hat mich bitteschön ausgeloggt???
    Das ganze läßt sich reproduzieren. In der Log-Datei /var/log/messages
    ist dies auch schön protokolliert:

    Server for display :0 terminated unexpectedly

    Jedoch ging kein Fehler voran. Mit Hilfe des Protokolls finde ich
    schnell die Zeitspanne heraus: 15 min. Ich sehe im BIOS Setup nach,
    tatsächlich ist "Standby Timeout" auf 15 min eingestellt. Ich stelle die
    Option kurzer Hand auf "disabled". (Mir ist zwar schleierhaft, wieso sich das
    als ein Logout auswirkt, aber...)

    Jetzt möchte ich auch die Fähigkeiten der Grafikkarte ausnutzen:
    Ich starte SAX2, das die NVIDIA Karte erkennt. Es warnt, dass einige
    Module nicht gefunden werden, diese will ich nachinstallieren. Jetzt
    fällt leider auf, dass ich nur die 1 CD Distribution von der PC-Welt
    2/2002 habe. Ich lade die Pakete von SuSE herunter und installiere sie
    mit YaST1, weil ich weiß wie man von Hand etwas herunterlädt und
    installiert. YaST2 würde das viel bequemer über Online Update
    anbieten... Als ich SAX2 nach Installation der Pakete starte, wird
    eine Meldung angezeigt, dass die 3D Fähigkeiten nur durch ein
    Online-Update aktivierbar sind, na gut, dann doch ein Online Update,
    was sich als unkompliziert erweist. Endlich kann ich die SAX2
    Konfiguration abschließen. Zu beachten war hier nur, dass meine Mouse
    nicht automatisch erkannt wurde. Und um das Scrollrad nutzen zu
    können, muß man in Menü Expert "Z Axis Mapping" auf "Buttons"
    einstellen mit den Parametern 4 und 5. Dies ist auch in der SuSE
    Support Datenbank beschrieben.

    Fazit:
    + SuSE Linux 7.3 ließ sich sehr einfach installieren.
    + YaST2 zeigte sich auskunftsfreudig und bot Lösungen zu den Problemen an.
    ("disableapic", "lba32")
    - Für den AC97 Soundchip lag kein Treiber bei, jedoch bot OSS Abhilfe.
    - Das automatische Beenden der KDE Session nach 15 Minuten wurde durch
    einen BIOS Parameter ausgelöst: Das hätte haarig werden können.
    + SAX2 half die Grafikkarte optimal zu konfigurieren. Durch
    Unachtsamkeit deaktivierte ich das Scrollrad der Mouse.
    - ZIPdrive und Palm III waren zwar schnell eingebunden, benötigte aber doch
    Linux Knowhow, das ich von meiner letzten Installation hatte.
    - Mein Joystick "Gravis Gamepad" ließ sich nicht konfigurieren. Nur die
    Buttons reagieren. Im newsnet sehe ich, dass jemand das gleiche
    Problem hat. Offensichtlich ein Kernel Bug. Auch wie man die
    Kernelmodule überhaupt lädt, konnte ich nur im newsnet finden, nicht in der
    Support Datenbank: modprobe joydev; modprobe ns558; modprobe analog
    + Windows XP ließ sich übrigens ebenfalls problemlos neu installieren...
    * Den CD-Brenner habe ich noch nicht unter Linux getestet.

    PS: Der eingebaute CD-Brenner "LG Electronics GCE-8160B" belegt in
    PC-Welt Top 10 Platz 1 (2/2002), Test in 12/2001

    --
    Alle Rechte vorbehalten. Jede Veröffentlichung benötigt meine Zustimmung.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen