1. Bitte immer die Rechnerkonfiguration komplett posten!
    Vollständige Angaben zur Konfiguration erleichtern die Hilfestellung und machen eine zügige Problemlösung wahrscheinlicher. Wie es geht steht hier: Klick.
    Information ausblenden

LPT PCI Karte steht nicht in der BIOS Tabelle... Speicheradresse?

Dieses Thema im Forum "Hardware allgemein" wurde erstellt von foerthner, 2. Dezember 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. foerthner

    foerthner ROM

    Registriert seit:
    2. Dezember 2004
    Beiträge:
    3
    Hallo,

    ich versuche seit geraumer Zeit mit C unter WindowsXP (Compiler: lcc-win32) meine Parallele Schnittstelle anzusteuern.. Ich habe dazu einen DeviceDriver (UserPort) um den Hardwarezugriff zu erlauben. Und um mein Motherbord vor beschädigungen von meiner externen Schaltung zu bewahren, möchte ich die Ports einer Dual-LPT PCI card nutzen. Dies hat nie funktioniert. Wenn ich testhalber die onboard schnittstelle nehme funktioniert die Ansteuerung wunderbar, aber die will ich ja eigentlich nicht benutzen...
    Komisch is, dass das Bios beim Starten nur eine Basisadresse bei LPT Port anzeigt, nämlich 0378, die anderen die von der Karte kommen sollten werden nicht angezeigt, ist das normal? Die Karte funktioniert zwar in Windows, verwendet aber keine Resourcen (wie es die onboard tut, da wird auch der speicherbereicht im Gerätemanager brav angezeigt). Die Karte ist eine Manhattan Mercury Dual Port Enhanced Parallel Card. Wie finde ich den richtigen Speicherbereich raus? Oder geht das mit der Karte gar nicht???

    Ich wäre euch echt dankbar wenn ihr mir helfen könntet, weil ich suche schon sehr lange im netz und finde keine lösung...

    Gruß Andreas


    PS: Ich habe gerade rausgefunden, dass man angeblich die Karte auf die Standartadressen einstellen kann, aber wie weis ich noch nicht, jumper gibts nicht.... software auch nicht, also ich hab zumindest keine....
     
  2. foerthner

    foerthner ROM

    Registriert seit:
    2. Dezember 2004
    Beiträge:
    3
    Hi,

    ich habe meine Schaltung schon auch Galvanisch getrennt, vom PC, aber ich fands halt besser wenn ich noch den weg über die pci karte geh... ich hab aber auch noch kein lpt diagnose programm (und ich hab schon ein paar probiert) gefunden, dass die schnittstellen findet... Ich wollte auch nicht zuviel fertiges zeugs kaufen, weil des ganze meine Facharbeit wird und die Eigenleistung wohl im Mittelpunkt steht...
    Die Karte installiert noch einen pci Mulit-I/O-Adapter, der resourcen verwendet.. aber da sind keine Standart LPT-Bereiche dabei...
    trotzdem danke...
    Hat vielleicht sonst jemand noch ne idee?

    Gruß Andi
     
  3. foerthner

    foerthner ROM

    Registriert seit:
    2. Dezember 2004
    Beiträge:
    3
    Hallo,

    ich habs mitlerweile...
    Der Standart windows Treiber hat nicht funktioniert, mit einem original (nichtsignierten *g*) Treiber funktionierts.. trotzdem danke an alle

    Gruß Andreas
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen