Mause geht plnicht mehr in SuseLinux7.3!

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Heliko, 24. Juni 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Heliko

    Heliko Byte

    Registriert seit:
    7. April 2002
    Beiträge:
    28
    Die Linux 7.3 Installation lief wunderbar mit KDE und Yast2. Nachdem ich die Soundkarte auch aktiviert hatte geht die Maus plötzlich nicht mehr! Da tappt man ziemlich hilflos mit Tab etc. durch die Menus, habe ein Update via FTP gemacht, nichts hift. Die Datei /dev/mouse ist nicht vorhanden, ich meine sowas sollte da sein, wie kann ich nun die Maus wieder aktivieren??

    Heliko
     
  2. Heliko

    Heliko Byte

    Registriert seit:
    7. April 2002
    Beiträge:
    28
    Es wird immer schlimmer ... Ich habe gesehen, dass direkt in /etc auch ein XF86Config ist, in der sogar ein Abschnitt Pointer ist mit sinnvollem Inhalt. Darauf hin habe ich in der XF86Config unter /etc/X11 einen "Pointer"-Abschnitt hinzugefügt und bei der Maus device auf /dev/psaux gesetz (ist auch so vorhanden).
    Da ctrl+alt+backspace nichts gebracht hat habe ich mal SuSEConfig gemacht, und danach startete Linux nur noch im Text Mode, obwohl er Runlevel 5 gemeldet hat!!
    Mit Yas2, der dann im Textmode kam, habe ich den kde wieder zum laufen gebracht, aber die Maus will immer noch nicht ...
    Ich vermute dass da etwas anderes ist, entweder stört die Soundkarte, oder ist es die zweite Printerkonfiguration mit lpd (die erste ist mit cups und geht, es war ein versehen lpd zu installieren).
    Lamgsam glaube ich wirklich dass nur noch eine Neuinstallation die Maus in Ordnung bringen wird.
    Jedenfalls besten Dank für die guten Tipps bis jetzt, man lernt ja einiges dazu...
    Grüsse
    Heliko

    7.3.2002: Problem gelöst, es war die Soundkarte die den Interrupt der Maus (5) weggeschnappt hat. Aus irgendwelchen Gründen war die Soundkarte 2 mal installiert.
    Danke an alle für die Tipps
    Heliko
    [Diese Nachricht wurde von Heliko am 03.07.2002 | 08:00 geändert.]
     
  3. quereller

    quereller Kbyte

    Registriert seit:
    22. Juni 2001
    Beiträge:
    277
    Um den link anzulegen musst du einen abstand zwischen der quelle und dem eigentlichen link lassen
    ln -s /dev/psaux /dev/mouse
    Aber sch au nochmal nach ob /dev/psaux auch existiert. Möglich ist auch das es auch wieder ein link ist oder z.b. bei mir /dev/misc/psaux
    um das file zu finden gibst du ein find /dev/ -name psaux
    dann schaust du nach ob es wirklich das richtige device ist mit stat /dev/psaux o.ä.
    Der Device type ist a,1.
    Dann legst du eben ein link an oder du kanst es auch dierekt in dias file integrieren.

    Hoffe es klappt.
     
  4. Heliko

    Heliko Byte

    Registriert seit:
    7. April 2002
    Beiträge:
    28
    Das hat leider nichts gebracht. Allerdings habe ich folgendes bemerkt:
    - da gibt es noch ein Feld "InputFashion" "Mouse",
    - es steht "Vendor" "Logitech",
    - noch ein Eintrag ist da, "Name" "Wheel Mouse" (oder ähnlich, diese Einträge stammen wohl aus meinen Aktionen im Sax2),
    - kann etwas daran liegen dass bei "Device" "/dev/mouse" steht und der link auf ln -s /dev/psaux/dev/mouse steht, oder muss ich da irgendwo Space einfügen?
    Den Eintrag "ZAxis...." habe ich hinzugefügt, die Zeilen mit # nicht, ich denke das sind nur Kommentare.
    Was kamm ich jetzt noch tun???
    Grüsse Heliko
     
  5. quereller

    quereller Kbyte

    Registriert seit:
    22. Juni 2001
    Beiträge:
    277
    Nur keine Panik !
    Mach zuerst ein copie der datei!

    Also gib mal "vi /etc/X11/XF86Config-4" oder wenns nicht geht "vi /etc/X11/XF86Config" ein. Dann enderst du die datei so ab

    Section "InputDevice"

    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "4 5"

    # ChordMiddle is an option for some 3-button Logitech mice

    # Option "ChordMiddle"

    EndSection

    Wenn du nur 2 Tasten + ein rad hast dann muss es so heissen

    Option "ZAxisMapping" "3 4"

    Dann drückst du ZZ

    Dann lgibst du ein ln -s /dev/psaux /dev/mouse

    und starttest den Xserver mit ctrl +alt+ backspace neu

    wenns nicht geht copierst du die alte datei zurück mit!
     
  6. Heliko

    Heliko Byte

    Registriert seit:
    7. April 2002
    Beiträge:
    28
    Finde keine Datei mit diesem Namen, nur solche mit XFreeconfig.savesax (o.ä), da steht nur etwas über die Maus, kein Pointer. Im Moment wird sowieso alles nur schlimmer, von der Konsole aus komme ich nicht mehr weit in Sax, er fliegt nach den Bildschirmeinstellungen wieder raus, vom KDE aus komme ich bis zum Maus-menu aber ich konnte die Änderungen nicht abspeichern.
    Verzweiflung breitet sich aus...
    Grüsse Heliko
    Übrigens die Maus ist eine Logitech Wheel-Mouse am PS/2-Bus
    [Diese Nachricht wurde von Heliko am 25.06.2002 | 17:58 geändert.]
     
  7. quereller

    quereller Kbyte

    Registriert seit:
    22. Juni 2001
    Beiträge:
    277
    Hallo was steht in der /etc/X11/XFree86-4 in der sektion pointer.
    Was hast du für eine maus und wo ist sie angeschlossen?
     
  8. Heliko

    Heliko Byte

    Registriert seit:
    7. April 2002
    Beiträge:
    28
    Das ist wohl der richtige Weg, auch wenn es bis jetzt nicht geklappt hat, aber ich probiere weiter. Zur Not werde ich die Soundkarte wieder deinstallieren, dass müsste doch auch gehen, aber wie? (unter WIN98 wüsste ich es ...)
    Gruss Heliko
     
  9. wickey

    wickey Megabyte

    Registriert seit:
    8. Januar 2002
    Beiträge:
    1.126
    Nehme an, Du hast SuSE Linux 7.3. Richte die Maus mal mit sax2 neu ein. Einfach sax2 in der bash eintippen.

    grüße wickey
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen